Action Button - Process Failed - with No Log

Post Reply
chewza
Regular Participant
Posts: 150
Joined: Tue Aug 17, 2010 11:51 am
OLAP Product: TM1
Version: 9.5
Excel Version: 7

Action Button - Process Failed - with No Log

Post by chewza »

Hi there

I get a "Process Failed" message from an action button. No error log or entry in Tm1Server log.
Any ideas?

Many thx!
Wim Gielis
MVP
Posts: 3129
Joined: Mon Dec 29, 2008 6:26 pm
OLAP Product: TM1, Jedox
Version: PAL 2.0.9.18
Excel Version: Microsoft 365
Location: Brussels, Belgium
Contact:

Re: Action Button - Process Failed - with No Log

Post by Wim Gielis »

TM1 Perspectives ? PAfE ? A sheet dragged on a PAW dashboard ?

The process exists ? For instance, in case the process name could be retrieved dynamically from a cell.
Process parameters are fine ?
Best regards,

Wim Gielis

IBM Champion 2024
Excel Most Valuable Professional, 2011-2014
https://www.wimgielis.com ==> 121 TM1 articles and a lot of custom code
Newest blog article: Deleting elements quickly
User avatar
PavoGa
MVP
Posts: 618
Joined: Thu Apr 18, 2013 6:59 pm
OLAP Product: TM1
Version: 10.2.2 FP7, PA2.0.9.1
Excel Version: 2013 PAW
Location: Charleston, Tennessee

Re: Action Button - Process Failed - with No Log

Post by PavoGa »

chewza wrote: Thu Apr 11, 2024 5:04 pm Hi there

I get a "Process Failed" message from an action button. No error log or entry in Tm1Server log.
Any ideas?

Many thx!
Make sure all the parameters you're passing include an "=" in the box. Easy to miss this if using named ranges.

dimAccount (wrong)
=dimAccount (correct)
Ty
Cleveland, TN
EP_explorer
Regular Participant
Posts: 209
Joined: Sat Dec 04, 2010 2:35 pm
OLAP Product: PAL
Version: 2.0.9
Excel Version: 2016

Re: Action Button - Process Failed - with No Log

Post by EP_explorer »

May be user doesn't have rights for the process.

In this case I see the same behaviour
User clicks on button, see error window and nothing in log file
ardi
Community Contributor
Posts: 156
Joined: Tue Apr 02, 2013 1:41 pm
OLAP Product: tm1, cognos bi
Version: from TM1 9.4 to PA 2.0.9.6
Excel Version: 2010
Location: Toronto, ON

Re: Action Button - Process Failed - with No Log

Post by ardi »

This is an indication that the process did not get triggered at all, and usually this is due to security access or the name of process is not spelled correctly.

If the name of Process is in a reference cell then check the cell, i usually use Named Ranges for process name, process params, and all other properties of action button
Ardian Alikaj
konstantin-spb
Posts: 16
Joined: Thu Feb 20, 2014 8:42 am
OLAP Product: TM1
Version: PA 2.0.9
Excel Version: 2016
Location: Russia, Saint-Petersburg

Re: Action Button - Process Failed - with No Log

Post by konstantin-spb »

1) No security rights to run the process;
2) There are many models on one server
and a different model is specified for the button.
Logs are written to a log file of a different model.
chewza
Regular Participant
Posts: 150
Joined: Tue Aug 17, 2010 11:51 am
OLAP Product: TM1
Version: 9.5
Excel Version: 7

Re: Action Button - Process Failed - with No Log

Post by chewza »

Thx all - got it sorted! Issue with named range in Excel
Post Reply