TI problem loading "Comments"

Post Reply
lynnsong986
Posts: 35
Joined: Wed Feb 28, 2018 2:20 pm
OLAP Product: TM1
Version: 10.2.2
Excel Version: 2010

TI problem loading "Comments"

Post by lynnsong986 » Wed Oct 09, 2019 2:15 pm

Hello,

I have a cube with 2 dimensions:

Inputs: elements are various items that feed the model
Input_Meas: two elements in this, one is Rates, the other is a string element "Comments"

I have the CSV setup as below
colA colB colC colD
Inputs Rates Measure Comments
element Data Element ????

I got error message saying the dimensions in the variables don't match the number of dimensions in the cube.

how can I update the cube with the comments as well?

thanks!

ascheevel
Posts: 72
Joined: Fri Feb 15, 2013 5:49 pm
OLAP Product: TM1
Version: 11.2
Excel Version: 2016

Re: TI problem loading "Comments"

Post by ascheevel » Wed Oct 09, 2019 2:18 pm

Post your code from data tab?

Wim Gielis
MVP
Posts: 2214
Joined: Mon Dec 29, 2008 6:26 pm
OLAP Product: TM1
Version: PAL 2.0.8
Excel Version: Office 365 - latest
Location: Brussels, Belgium
Contact:

Re: TI problem loading "Comments"

Post by Wim Gielis » Wed Oct 09, 2019 6:14 pm

I would expect a file with 3 columns:
- an element for dimension 1
- an element for dimension 2
- the cell value

Don't think it's going to be more basic than this.
I have the feeling that, based on the questions you ask here in the forum, you will gain a lot with a basic TM1 training.
While this will be a paid training, it will help you in a great deal moving forward.
Best regards,

Wim Gielis

Excel Most Valuable Professional, 2011-2014
http://www.wimgielis.com ==> 109 TM1 articles and a lot of custom code
Newest blog article: Set up a TM1 model with AutoHotKey as a service or application

lynnsong986
Posts: 35
Joined: Wed Feb 28, 2018 2:20 pm
OLAP Product: TM1
Version: 10.2.2
Excel Version: 2010

Re: TI problem loading "Comments"

Post by lynnsong986 » Wed Oct 09, 2019 8:17 pm

I actually just went to a 3-day training, day one on reporting, day two on rules and day three on TI. I wish the training could be longer and cover more details...

The question really is that I have a string element in the measure dimension (as the last element) and I have a column in CSV that holds the texts for this comment element. in the TI process under variables, should this column go in as data with Type string or something else? I tried but couldn't make it to work.

Again I really appreciate your help!
Attachments
Capture3.PNG
Capture3.PNG (14.97 KiB) Viewed 515 times
Capture2.PNG
Capture2.PNG (16.14 KiB) Viewed 515 times
Capture.PNG
Capture.PNG (27.6 KiB) Viewed 515 times

ascheevel
Posts: 72
Joined: Fri Feb 15, 2013 5:49 pm
OLAP Product: TM1
Version: 11.2
Excel Version: 2016

Re: TI problem loading "Comments"

Post by ascheevel » Wed Oct 09, 2019 8:32 pm

Thanks for posting screenshots. So you're trying to load the amount and comments at the same time, no problem in TI. You can define the contents of the Comments variable as Data the same way you did for the Amount variable in the variables tab (your 1st screenshot). In the mapping tab, you'll then tell the process which element in your measures dimension each Data variable maps to. When you navigate to the data tab after doing that, you'll see two CellPut statements in the generated statements section. The first will be a CellPutN that will write the amount to the Input_Meas measure and the second will be CellPutS to the comments measure (provided you set it up right in the mapping tab!).

lynnsong986
Posts: 35
Joined: Wed Feb 28, 2018 2:20 pm
OLAP Product: TM1
Version: 10.2.2
Excel Version: 2010

Re: TI problem loading "Comments"

Post by lynnsong986 » Wed Oct 09, 2019 8:49 pm

Thanks so much for helping me out!! we went through a merger (4 big utilities merged) and the mergeCo is now using TM1 for budget/forecasts. I have no IT background whatsoever, so I'm very sorry if my questions are too basic for you. The problem with TM1 is that, unlike Excel with which I can always find solutions by googling, it's a lot harder to find answers directly related to my questions.

lynnsong986
Posts: 35
Joined: Wed Feb 28, 2018 2:20 pm
OLAP Product: TM1
Version: 10.2.2
Excel Version: 2010

Re: TI problem loading "Comments"

Post by lynnsong986 » Wed Oct 09, 2019 8:53 pm

sorry I tried but got the same popup, I don't understand as I have two dimensions and I have two elements under variables?
Attachments
Capture2.PNG
Capture2.PNG (24.34 KiB) Viewed 502 times
Capture.PNG
Capture.PNG (11.02 KiB) Viewed 502 times

Wim Gielis
MVP
Posts: 2214
Joined: Mon Dec 29, 2008 6:26 pm
OLAP Product: TM1
Version: PAL 2.0.8
Excel Version: Office 365 - latest
Location: Brussels, Belgium
Contact:

Re: TI problem loading "Comments"

Post by Wim Gielis » Wed Oct 09, 2019 8:56 pm

This screenshot looks okay, inspect the subtabs in the Maps tab.
Best regards,

Wim Gielis

Excel Most Valuable Professional, 2011-2014
http://www.wimgielis.com ==> 109 TM1 articles and a lot of custom code
Newest blog article: Set up a TM1 model with AutoHotKey as a service or application

lynnsong986
Posts: 35
Joined: Wed Feb 28, 2018 2:20 pm
OLAP Product: TM1
Version: 10.2.2
Excel Version: 2010

Re: TI problem loading "Comments"

Post by lynnsong986 » Wed Oct 09, 2019 9:02 pm

I can't proceed, the same pop up came up when I clicked on Dimensions or Advanced. and I tried to delete the process and recreate it, same thing happened. What else could have gone wrong here?

Wim Gielis
MVP
Posts: 2214
Joined: Mon Dec 29, 2008 6:26 pm
OLAP Product: TM1
Version: PAL 2.0.8
Excel Version: Office 365 - latest
Location: Brussels, Belgium
Contact:

Re: TI problem loading "Comments"

Post by Wim Gielis » Wed Oct 09, 2019 9:12 pm

If you can, set all Contents of the Variables to Other. Like that, the wizard is bypassed.
Then move on gradually. Did you do that ?
Best regards,

Wim Gielis

Excel Most Valuable Professional, 2011-2014
http://www.wimgielis.com ==> 109 TM1 articles and a lot of custom code
Newest blog article: Set up a TM1 model with AutoHotKey as a service or application

ascheevel
Posts: 72
Joined: Fri Feb 15, 2013 5:49 pm
OLAP Product: TM1
Version: 11.2
Excel Version: 2016

Re: TI problem loading "Comments"

Post by ascheevel » Wed Oct 09, 2019 9:24 pm

Set the third variable to other or ignore and you'll be able to proceed.

lynnsong986
Posts: 35
Joined: Wed Feb 28, 2018 2:20 pm
OLAP Product: TM1
Version: 10.2.2
Excel Version: 2010

Re: TI problem loading "Comments"

Post by lynnsong986 » Wed Oct 09, 2019 9:47 pm

yes it worked! what is the logic behind this if you don't mind me asking?

lynnsong986
Posts: 35
Joined: Wed Feb 28, 2018 2:20 pm
OLAP Product: TM1
Version: 10.2.2
Excel Version: 2010

Re: TI problem loading "Comments"

Post by lynnsong986 » Wed Oct 09, 2019 9:48 pm

thanks so much for your time!

ascheevel
Posts: 72
Joined: Fri Feb 15, 2013 5:49 pm
OLAP Product: TM1
Version: 11.2
Excel Version: 2016

Re: TI problem loading "Comments"

Post by ascheevel » Thu Oct 10, 2019 1:59 pm

lynnsong986 wrote:
Wed Oct 09, 2019 9:47 pm
yes it worked! what is the logic behind this if you don't mind me asking?
Defining variables as Data/Element/Consolidation/Attribute serves only to help the TI determine what else you need to define in the Maps tab in order to prepare the generated statements for the prolog/metadata/data/epilog tabs. You could mark all the variables as other and write the CellPutN and CellPutS statements in the data tab for this example yourself. You can test this if you want by first going through the Prolog, metadata, data, and epilog tabs and copying all text in the generated statements sections and pasting below each section and then change all variables to other. Cycle through the prolog/metadata/data/epilog tabs and you'll see the generated statements disappeared except for where you pasted outside of that section. As you get more experience and comfort working in TI, you may find that you prefer to mark all variables as other and write the code in prolog/metadata/data/epilog tabs freehand. Doing so will give you more flexibility and make you a better developer. In the meantime, scrutinize the generated statements to help your own understanding and keep the TM1 reference docs handy.

For your specific example, you needed to change variable 3 "measure" to other/ignore because your cube has 2 dimensions and you had marked 2 variables as element and another 2 as data. With each element variable mapping to one dimension in the cube, the TI would only expect 1 data variable. Having 2 is nonsensical to the TI because you wouldn't want to write 2 data values to the same measure. When you have more than 1 variable marked as data, the TI will expect the count of variables marked element to be one less than the count of dimensions in the cube and you'll then specify in the Maps tab which measure each data variable goes to.

Hope this helps.



IBM reference on TI functions, essential when writing your own script in TI:
https://www.ibm.com/support/knowledgece ... 70006.html


IBM reference TI tutorial:
https://www.ibm.com/support/knowledgece ... c0007.html

lynnsong986
Posts: 35
Joined: Wed Feb 28, 2018 2:20 pm
OLAP Product: TM1
Version: 10.2.2
Excel Version: 2010

Re: TI problem loading "Comments"

Post by lynnsong986 » Thu Oct 10, 2019 3:31 pm

I didn't expect any answers yet you took the time to explain it in such great details...I can't tell you how much I appreciate it!!

I did go through a few rounds during my training changing variable type to "Other" then manipulate the codes directly under Map. I didn't realize where the problem was and didn't even consider doing that in this situation.

I really like TM1 and will continue to learn it, hopefully I'll be good one day!

thank you so so so much!!

Post Reply