CubeViewer Subset editor

Post Reply
nicola531
Posts: 43
Joined: Thu Oct 22, 2009 7:58 am
OLAP Product: TM1
Version: 9.5.1
Excel Version: 2007

CubeViewer Subset editor

Post by nicola531 » Wed Aug 29, 2012 1:53 pm

Hello everybody,

we have a problem related to the Cube Viewer (Tm1Web) subset viewer / selection .
We have a TM1 application on a server where there is TM1 9.5.2.
The application is containing some very large dimensions (2500 more elements).
What we experience is that we enter a view with those dimensions in page and when we do the SubSet Editor to select an element, (in advanced mode:pop up window) and we try to select an element it take something like 4-15 seconds to select one single item.
It is not depending to the view or data. it happens even if the view it is empty.
The server has IE 9.
The point is that we are trying to make blind trials to understand what can be the problem because it is difficult to isolate.
I mean that the same application in different contexts reacts in different ways. For examples:

- On another physical server with IE 8 the subset editor is fast.
- On the browser of the server where we have the problem (IE 9) is it slow
- On our computer (Intel i5 processor) it is fast
- On slower processor computer is slower
- with firefox is fast
- we tried on the server with the localhost at nothing changes so it should no be the network.

This means that we have different variables that seems to interact in the problem and we cannot understand what is important to know.
From the Task Manager we see that every time we make a click one of the local processor goes to 100% for the necessary time, which probably tells us that the more fast is he processor the fastest is the response (probably is a JS slow?)
I expected to have a network problem on that server but the IE network profiler tells us that there is a large system time response so it seems that we have a delay in the response.


- client computer processor
- browser
- physical server
- other

What, in your opinion, can be the important thing to look in this case in order at least to isolate the cause?

Another thing I cannot understand is that there is the paging in the web subset editor so every time we should interact every time with a single page, but it seems that the bigger is the dimension the slower it is the system so I understand that all the dimension is taken into consideration.

Last question: I know that in the TM1 Architect there is a way to cache the subset viewed, is there anything for the web?


Thanks in advance for your response,

N.

Post Reply