RESOLVED - Data Reservation

Post Reply
Posts: 101
Joined: Thu Oct 20, 2011 6:53 am
OLAP Product: TM1
Version: 9.5.2
Excel Version: 2007
Location: London, UK

RESOLVED - Data Reservation

Post by tosca1978 » Fri Jun 22, 2012 8:53 am

All, I have resolved the issue. The particular elements that I was looking at had been submitted during testing. I have to reject and then release ownership for the data reservation to be released.

Silly mistake on my part - apologies for wasting anyone's time!


Using v10.1.0


we have just upgraded from 9.5.2 to 10.1.0. and I have built a new contributor model to replace one in Cognos Enterprise Planning. I am now facing Data Reservation for the first time (I have read that this was in v9.5.2 however I never used it in this version).

The Cube:

I have a simple forecast input cube. I have a CellSecurity control cube (for the forecast input cube) with rules that restrict areas of the cube to read only. This is to replicate the access tables used in the original Cognos Enterprise Planning model. The same restrictions apply to all user groups and works well. For example depending on what product the user has selected, they will only be able to input data into certain measures (those that are applicable to the product). The cube view and approval hierarchy are deployed to a Contributor model where access/security is determined by Contributor.

I have signed in as a test user (a member of the test user group) and taken ownership/edited/committed/submitted data -all works fine.

The issue:

Logged in as admin I opened the cube in architect and I cannot edit any data or upload data to the cube using a TI (I want to do this as I want to import all data from the old Enterprise Planning model). When I right click on a cell (that is not restricted by the CellSecurity rule) I get the following message: "Cell is not editable: No Data Reservation".

I have read the help files, searched google and TM1 Forum and cannot match the error message.

What I have tried:

1. Opened }CubeProperties control cube. RequiredShared is automatically at the cross section of DataReservationMode (although I have read that Admin needs to enable the Data Reservation feature for it to work, according to the IBM documentation update ( ... wg27024911) this is the default mode assigned to all cubes represented by Cube Views or Manual Dependancies. So I assume since I have created a cube view this has been assigned. I have tried replacing "RequiredShared" with "OFF". This changes the error message to "no write access to "Cell is not editable: No write access to element '*' ". This I don't understand as Admin has write access as per the CellSecurity cube. I have changed back to "RequiredShared" in the }CubeProperties control cube for the remainder of testing.

2. I have opened the }Capabilties control cube and set "Grant" to the Admin user group for "ManageDataReservation" and "DataReservationOverride" (for all permissions). Still get the "Cell is not editable: No Data Reservation" error message at this stage

3. I have created a TI with the following in the Proloue:

Code: Select all

CubeDataReservationReleaseAll('Forecast Input by Month','','||||||','|');
The TI runs without errors yet I still get the "Cell is not editable: No Data Reservation" error message.

The solution:

Rather than swithing Data Reservation off I am keen to get to grips with it and use it. However if I don't understand the error message and it isn't documented (I have read the user guide and can't see it) I'm a but stuck.

If anyone can suggest where I am going wrong I would appreciate it.

Many thanks.

Posts: 10
Joined: Fri Sep 02, 2011 2:14 pm
OLAP Product: TM1
Version: 9.5.2
Excel Version: 2007

Re: RESOLVED - Data Reservation

Post by jcortes » Sat Mar 27, 2021 1:38 am

Hi, can you solve it. Can you explain to me what |`|||| etc, means? Tanks a lot

User avatar
Steve Rowe
Site Admin
Posts: 2161
Joined: Wed May 14, 2008 4:25 pm
OLAP Product: TM1
Version: 10.2.2., PAW
Excel Version: Nearly all of them

Re: RESOLVED - Data Reservation

Post by Steve Rowe » Mon Mar 29, 2021 11:45 am ... seall.html

The help for the function as above, the pipe is used to delimit the element references supplied, so '||||||' would mean the whole cube for a cube with 7 dimensions.
Technical Director

Post Reply