TM1 9.4.1 - wrong values on DBRW

Post Reply
gabi
Posts: 20
Joined: Thu Jun 19, 2008 12:44 pm

TM1 9.4.1 - wrong values on DBRW

Post by gabi » Mon Mar 15, 2010 9:07 am

Hello,

Few months ago we found the "wrong values on DBRW" on TM1 9.4.1 FP2 and reported to IBM.
The DBRW bug was rare and random so testing the HF16 for that bug was Impossible.
We implemented HF16 (Server and clients) to resolve the DBRW bug according IBM support solution.

Now, the BUG appears again on TM1 9.4.1 FP2 HF16.\
Is there anyone else encountered this BUG? Do you know if 9.4.1 FP3 solved that BUG with a better fix?

Thank you,
Gabi
Gabi Cohen
Biconix International

kpk
MVP
Posts: 214
Joined: Tue Nov 11, 2008 11:57 pm
OLAP Product: TM1, CX
Version: TM1 7x 8x 9x 10x CX 9.5 10.1
Excel Version: XP 2003 2007 2010
Location: Hungary

Re: TM1 9.4.1 - wrong values on DBRW

Post by kpk » Mon Mar 15, 2010 10:01 am

Hello,

Could you check the same slice from the admin user?
I can see a private view in your doc.

Regards,
Peter
Best Regards,
Peter

lotsaram
MVP
Posts: 3251
Joined: Fri Mar 13, 2009 11:14 am
OLAP Product: TableManager1
Version: PA 2.0.x
Excel Version: Office 365
Location: Switzerland

Re: TM1 9.4.1 - wrong values on DBRW

Post by lotsaram » Mon Mar 15, 2010 10:52 am

Usually when this happens it is due to one of two things as opposed to a rare and difficult to track down bug.

1/ The client Excel session has been used to log on as several different users and has become "somewhat confused"
2/ The client's Excel session was open in a previous server session (i.e. the user has not shut down Excel but for whatever reason a TM1 restart has occurred in the interim)

The fixes in both cases are the same, either restart the Excel session and perspectives or run the M_Clear TM1 macro.

If that works then you have Occam's Razor in action; always look for the most likely explanation first. If that doesn't fix it and the incorrect sliced values apply to all client sessions and not just particular sessions where points 1 or 2 above apply and the only fix is a full TM1 server restart then you probably do have yourself a "rare and random bug."

User avatar
Steve Rowe
Site Admin
Posts: 1920
Joined: Wed May 14, 2008 4:25 pm
OLAP Product: TM1
Version: 10.2.2., PAW
Excel Version: Nearly all of them

Re: TM1 9.4.1 - wrong values on DBRW

Post by Steve Rowe » Mon Mar 15, 2010 1:15 pm

Irrespective of the reasons this a major fail from IBM, how can you put a client out there that you can not rely on delivering the correct results 100% of the time? Does it fails quietly too so you don't even know you are looking at the incorrect figures? Awful... :shock:

I can just imagine explaining to my users,
"oh btw sometimes TM1 will tell you the wrong information but don't worry about it just restart Excel when it happens."
User : " Errrr, OK so what you mean is TM1 doesn't work and we shouldn't use it."
Me : "No, it's just that sometimes it get's confused."
User : "What?? How can a computer get confused, it's not a person. You mean it's broken don't you?"
Me : "Errrr, No not exactly, it's just that sometimes it won't tell you the right answer"
User : "So how's that different to broken and how can I tell if it's not working?"
Me : *scrunchs crisp packet* "I might be just about to go through a tun..." *click*

Bring back 714!

Paul Segal
Community Contributor
Posts: 257
Joined: Mon May 12, 2008 8:11 am
OLAP Product: TM1
Version: 10.2.2
Excel Version: 2010

Re: TM1 9.4.1 - wrong values on DBRW

Post by Paul Segal » Mon Mar 15, 2010 3:35 pm

Bring back 7.14!
Wouldn't help much, at least on lotsaram's second point, as 7.14 had been known to do the exact same thing.
Paul

gabi
Posts: 20
Joined: Thu Jun 19, 2008 12:44 pm

Re: TM1 9.4.1 - wrong values on DBRW

Post by gabi » Tue Mar 16, 2010 8:59 am

kpk wrote:Hello,

Could you check the same slice from the admin user?
I can see a private view in your doc.

Regards,
Peter
It's not a saved view - It's slice and dice of the default view.
I can't reproduce this bug as It's rare and random - That's the big problem as I can't tell the users how to avoid it or advice them to manually check any value in Excel reports.
Gabi Cohen
Biconix International

kpk
MVP
Posts: 214
Joined: Tue Nov 11, 2008 11:57 pm
OLAP Product: TM1, CX
Version: TM1 7x 8x 9x 10x CX 9.5 10.1
Excel Version: XP 2003 2007 2010
Location: Hungary

Re: TM1 9.4.1 - wrong values on DBRW

Post by kpk » Tue Mar 16, 2010 1:50 pm

gabi wrote: It's not a saved view - It's slice and dice of the default view.
I can't reproduce this bug as It's rare and random - That's the big problem as I can't tell the users how to avoid it or advice them to manually check any value in Excel reports.
I asked it because there was a client where something similar occurred some years ago.
I am not sure what was the exact situation. Maybe it was a bit different and the DBRW Excel was published to TM1web.

The reason for the data inconsistency was that dimension element level security was implemented for one of the page dimensions and when the user selected an element on the sheet (or the websheet?) TM1 retrieved value for an other element but showed the selected element in the SUBNM cell.

Therefore my questions:
- Are you sure that any of you have experienced this issue with the Admin user as well?
- Do you have a security restriction for any of the title dimensions?

If the reason for your issue is something similar then you can reproduce the bug testing a non admin user with NONE, Write, Read level elements.

Regards,
Peter
Best Regards,
Peter

Post Reply