Dimension elements wrongly displayed for multiple TM1RPTROW in Active form

Post Reply
wbf
Posts: 5
Joined: Thu Nov 25, 2021 1:09 am
OLAP Product: TM1
Version: 10.2.0
Excel Version: 2013

Dimension elements wrongly displayed for multiple TM1RPTROW in Active form

Post by wbf » Thu Nov 25, 2021 4:07 am

I'm amending an active form to add row dimension (DimC) via TM1RPTROW. There are already two existing TM1RPTROW in the report.

Things I have performed:
1. Remove TM1RPTTITLE for DimC out from TM1RPTVIEW
2. Adding TM1RPTROW before the two existing ones
3. Manually delete all the rows under TM1RPTROW

After rebuilding the worksheet the dimensions in first row underneath TM1RPTROW is correct but dimensions from second row onwards are somehow ordered wrongly.

https://imgur.com/a/QLMC4w7

Funny thing is, I have also rebuild the view in cube viewer and generate via button 'Active form'. The elements ordering in the generated reports are also wrongly displayed (as per url image)

Is there something that I have missed out?

Appreciate for any advice!

Wim Gielis
MVP
Posts: 2792
Joined: Mon Dec 29, 2008 6:26 pm
OLAP Product: TM1, Jedox
Version: PAL 2.0.9.10
Excel Version: Microsoft 365
Location: Brussels, Belgium
Contact:

Re: Dimension elements wrongly displayed for multiple TM1RPTROW in Active form

Post by Wim Gielis » Thu Nov 25, 2021 8:07 am

Welcome to the forum.

Is the version mentioned in your profile correct ? Then please upgrade. IIRC there has been such a bug.
Best regards,

Wim Gielis

Excel Most Valuable Professional, 2011-2014
https://www.wimgielis.com ==> 120 TM1 articles and a lot of custom code
Newest blog article: Documenting processes and rules https://github.com/wimgielis

wbf
Posts: 5
Joined: Thu Nov 25, 2021 1:09 am
OLAP Product: TM1
Version: 10.2.0
Excel Version: 2013

Re: Dimension elements wrongly displayed for multiple TM1RPTROW in Active form

Post by wbf » Mon Nov 29, 2021 11:30 pm

That's the version for my personal use only.
This specific client having issue is using the stable version 2.0.9 with Excel 2013 - however, could not find any related fix on 2.0.9.5

Thanks,

Mark RMBC
Community Contributor
Posts: 267
Joined: Tue Sep 06, 2016 7:55 am
OLAP Product: TM1
Version: 10.1.1
Excel Version: Excel 2010

Re: Dimension elements wrongly displayed for multiple TM1RPTROW in Active form

Post by Mark RMBC » Tue Nov 30, 2021 10:32 am

Hi,

Two questions:

Is the incorrect order being shown in the image the order of the dimensions in the cube?
When you open the active form in TM1Web is the order correct?

If the answer to the above 2 questions is Yes this is the bug I think Wim was referring to.
My understanding is that this had been fixed a while ago!

regards,

Mark

wbf
Posts: 5
Joined: Thu Nov 25, 2021 1:09 am
OLAP Product: TM1
Version: 10.2.0
Excel Version: 2013

Re: Dimension elements wrongly displayed for multiple TM1RPTROW in Active form

Post by wbf » Wed Dec 01, 2021 4:41 am

Thank you both. Will check with support and see if they patch this in any later version

Post Reply