TM1 CAM Login not possible after CA Update

Post Reply
Posts: 107
Joined: Fri Aug 09, 2019 10:11 am
OLAP Product: TM1 / TM1 Web / Perspectives
Version: Planning Analytics V2.0.9
Excel Version: Office 365

TM1 CAM Login not possible after CA Update

Post by HighKeys » Sun Nov 14, 2021 2:11 pm

Hello Community,

i have a problem, we updated CA from 11.0.13 to 11.2.1, after the update CA works normally, we can use the SSO and all functions are working.

In TM1 is no login possible, i got this message in Architect: "SystemServerClientNotFound"

In the TM1 Logs i can see this: "TM1.Login Login Error: SystemServerConnectWithCAMPassport failed"

We installed the CA update over our old installation (as recommended form IBM).

I really dont have any idea, i updated the Interop files again just to be sure but still same issue.

Anyone has an idea, i think it should be some basic stuff i dont think about.

Thank you so much


We dont have ssl activated at the moment.

Posts: 84
Joined: Wed May 06, 2020 2:58 pm
OLAP Product: Planning Analytics
Version: 2.0.9
Excel Version: 2016

Re: TM1 CAM Login not possible after CA Update

Post by burnstripe » Mon Nov 15, 2021 12:32 pm

Have you tried using fiddler to track where the url redirection is failing?
If you have fiddler open while you're logging in it'll track your activity and should help indicate what URL are being used.

When updating the interop files, did you simply update the ones already there, if so try taking the bi_interop files across from the tm1 install, located here, C:\Program Files\ibm\cognos\tm1_64\bi_interop. Perhaps the files in the Cognos Analytics install have become corrupted. Once files have been placed and updated in Cognos Analytics, don't forget to restart IIS for the changes to take effect.

I'm also assuming no ports have been changed and the IIS directory name remains the same as it was previously.

.... it may also be worth disabling singlesignon temporarily by disabling the SSO login and legacy SSO rules within the BI folder in IIS. If you still get the authentication error whilst it's disabled then at least you know it's a configuration issue with the bi_interop files or tm1s.cfg. If it doesn't error when disabled then it seems like the credentials aren't being passed, and have you tried accessing CA from the same machine that has Architect, as i would expect them to both fail if this is the case.

Post Reply