TM1Web logout not working

Post Reply
BobTP
Posts: 3
Joined: Tue Mar 09, 2021 2:51 pm
OLAP Product: TM1
Version: 10.2.2
Excel Version: Excel 2010

TM1Web logout not working

Post by BobTP » Wed Mar 10, 2021 9:10 am

Dear all,

If our users are logging out from TM1Web they are still active and not inactive.
They are staying active until the timeout from TM1Web is finishing the session.
We are using TM1 10.2.2 and have Chrome 85.0... as main browser.

I tried other browsers and the result is mixed, older versions from Firefox and Internet Explorer are fine.
But with Microsoft Edge the logout does also not work.

With logout I mean not closing the window or browser but using the TM1WEB Button for this.
We guess that the many active users are the reason for regular crashs of TM1WEB.

Does anyone has the same problem and if yes, did you find a solution?

Thanks a lot for your help and time.

Wim Gielis
MVP
Posts: 2675
Joined: Mon Dec 29, 2008 6:26 pm
OLAP Product: TM1, Jedox
Version: PAL 2.0.8
Excel Version: Microsoft 365
Location: Brussels, Belgium
Contact:

Re: TM1Web logout not working

Post by Wim Gielis » Wed Mar 10, 2021 9:21 am

Hello,

I have never seen this situation.

The version you are talking about reached end of support 1.5 years ago.
I would suggest upgrading and see if it still occurs.
Best regards,

Wim Gielis

Excel Most Valuable Professional, 2011-2014
https://www.wimgielis.com ==> 117 TM1 articles and a lot of custom code
Newest blog article: Avoid circular references https://github.com/wimgielis

declanr
MVP
Posts: 1706
Joined: Mon Dec 05, 2011 11:51 am
OLAP Product: Cognos TM1
Version: PA2.0 and most of the old ones
Excel Version: All of em
Location: Manchester, United Kingdom
Contact:

Re: TM1Web logout not working

Post by declanr » Wed Mar 10, 2021 9:45 am

I don't recall specifically seeing this either but just a thought came to mind.
Are you using the web url api to open additional windows? Its a complete guess but I wonder if that opens as a separate thread and they don't get disconnected.
However, I used to use the url api a lot and don't recall seeing any particular issues from it.
Declan Rodger

BobTP
Posts: 3
Joined: Tue Mar 09, 2021 2:51 pm
OLAP Product: TM1
Version: 10.2.2
Excel Version: Excel 2010

Re: TM1Web logout not working

Post by BobTP » Wed Mar 10, 2021 9:56 am

Hello Declan,

no, we don`t use the web url api to open additional windows.
In my tests for the logout with different browsers, I just opened TM1WEB and logged out.
So I did not open any report or anything else.

Thanks a lot.

Bob

User avatar
ykud
MVP
Posts: 136
Joined: Sat Jan 10, 2009 10:52 am
Contact:

Re: TM1Web logout not working

Post by ykud » Fri Mar 12, 2021 10:56 pm

BobTP wrote:
Wed Mar 10, 2021 9:10 am
We guess that the many active users are the reason for regular crashs of TM1WEB.
Number of users wasn't really ever the reason for crashes in my experience. I'd look into playing with your JVM parameters in jvm.settings as per this technote

Something like this

Code: Select all

  -Xmx16256m
  -Xms4096m
  -Xmn4096m
  -Xgcpolicy:balanced
  -Xverbosegclog:${bin_path}/logs/verbosegc_%Y%m%d.%H%M%S.%pid.log,1,20000
  
should give you plenty of headroom and also give you a detailed crash dump log if does indeed go down.

And you're on the old enough version so the 'schedule regular tm1web service restarts just to be safe' is applicable as well :)

BobTP
Posts: 3
Joined: Tue Mar 09, 2021 2:51 pm
OLAP Product: TM1
Version: 10.2.2
Excel Version: Excel 2010

Re: TM1Web logout not working

Post by BobTP » Wed Mar 17, 2021 2:53 pm

Thanks a lot for your feedback ykud
I will try the restart first

Post Reply