TM1.SQLAPI error message in TM1Server log

Post Reply
Emixam
Posts: 95
Joined: Tue May 21, 2019 3:33 pm
OLAP Product: TM1
Version: PA 2.0.x
Excel Version: 2016
Location: The Internet

TM1.SQLAPI error message in TM1Server log

Post by Emixam » Wed Jan 13, 2021 4:34 pm

Hello,

We recently update all of our IBM applications (PA, CA, PAW, Controller, FAP, ..) and we started getting these error in our TM1Server log everytime we execute or open a TI:

Code: Select all

8288   []   ERROR   2021-01-10 04:00:24.664   TM1.SQLAPI   01000[Microsoft][ODBC SQL Server Driver][SQL Server]Changed database context to 'DataSourceName'.
8288   []   ERROR   2021-01-10 04:00:24.664   TM1.SQLAPI   01000[Microsoft][ODBC SQL Server Driver][SQL Server]Changed language setting to us_english.
8288   []   ERROR   2021-01-10 04:00:24.664   TM1.SQLAPI   01000[Microsoft][ODBC Driver Manager] Cursor library not used.  Load failed
8288   []   INFO   2021-01-10 04:00:24.685   TM1.SQLAPI   Checking Driver Capabilities for database "DataSourceName" 
8288   []   INFO   2021-01-10 04:00:24.685   TM1.SQLAPI         Driver supports SQLFetchScroll
Except these error message, everything behave as expected. I would like to know if there is a potential risk and/or what is the cause of that error message.

Thank you and have a nice day !

Note: if I uncheck the 'Use Unicode' box, the 3rd error disappear:

Code: Select all

2432   [36]   ERROR   2021-01-13 11:30:32.634   TM1.SQLAPI   01000[Microsoft][ODBC SQL Server Driver][SQL Server]Changed database context to 'DataSourceName'.
2432   [36]   ERROR   2021-01-13 11:30:32.634   TM1.SQLAPI   01000[Microsoft][ODBC SQL Server Driver][SQL Server]Changed language setting to us_english.
2432   [36]   INFO   2021-01-13 11:30:32.670   TM1.SQLAPI   Checking Driver Capabilities for database "DataSourceName" 
2432   [36]   INFO   2021-01-13 11:30:32.670   TM1.SQLAPI         Driver supports SQLFetchScroll
Sorry for my English :)

lotsaram
MVP
Posts: 3453
Joined: Fri Mar 13, 2009 11:14 am
OLAP Product: TableManager1
Version: PA 2.0.x
Excel Version: Office 365
Location: Switzerland

Re: TM1.SQLAPI error message in TM1Server log

Post by lotsaram » Wed Jan 13, 2021 5:36 pm

Have noticed this too. It seems the SQLAPI logger got a little too "verbose". I think this might be a bug and also might have already been patched in a fix pack.

See this https://www.ibm.com/support/knowledgece ... gging.html
Please place all requests for help in a public thread. I will not answer PMs requesting assistance.

Emixam
Posts: 95
Joined: Tue May 21, 2019 3:33 pm
OLAP Product: TM1
Version: PA 2.0.x
Excel Version: 2016
Location: The Internet

Re: TM1.SQLAPI error message in TM1Server log

Post by Emixam » Thu Jan 14, 2021 1:53 pm

Thanks Lotsaram,

I guess we need to understand what cause this error on our ODBC driver. I was thinking about removing TM1.SQLAPI logs from the tm1server log with the following line but I'm afraid I won't get the 'real' errors such as E16) Cannot connect to ODBC data source

Code: Select all

log4j.logger.TM1.SQLAPI=OFF
Sorry for my English :)

User avatar
macsir
Community Contributor
Posts: 747
Joined: Wed May 30, 2012 6:50 am
OLAP Product: TM1
Version: PAL 2.0.9
Excel Version: Office 365
Contact:

Re: TM1.SQLAPI error message in TM1Server log

Post by macsir » Thu Jan 14, 2021 8:26 pm

What is the version of your TM1 server? I have seen some in 2.0.8 but they disappeared after upgrading to 2.0.9.1.
In TM1,the answer is always yes though sometimes with a but....
http://tm1sir.blogspot.com.au/

Emixam
Posts: 95
Joined: Tue May 21, 2019 3:33 pm
OLAP Product: TM1
Version: PA 2.0.x
Excel Version: 2016
Location: The Internet

Re: TM1.SQLAPI error message in TM1Server log

Post by Emixam » Thu Jan 14, 2021 11:25 pm

macsir wrote:
Thu Jan 14, 2021 8:26 pm
What is the version of your TM1 server? I have seen some in 2.0.8 but they disappeared after upgrading to 2.0.9.1.
PA 2.0.9.4 (11.8.00300.34)
Sorry for my English :)

Post Reply