Problem with GIT integration

Post Reply
scrumthing
Posts: 43
Joined: Tue Jan 26, 2016 4:18 pm
OLAP Product: TM1
Version: 2.0.9
Excel Version: too many

Problem with GIT integration

Post by scrumthing » Thu Jul 23, 2020 10:53 am

I played around with the git integration on my local machine and encountered an error for which I could find nothing on the forum or the internet. I am using 2.0.9.1.

Code: Select all

{'error': {'code': '289', 'message': 'Failed to delete temporary TM1 Git directory "d:\\zz_shared\\_development\\tm1\\mysamples\\data\\}git$".'}}
That error message I get on every call after the first GitInit. Have tried using a different account for the service with admin priviliges.
I can create tm1 objects and they will be saved to the disk. So there can't be a problem with user rights.
Anyone an idea where to look next?
There is no OLAP database besides TM1!

luizg2019
Posts: 19
Joined: Thu Sep 12, 2019 11:02 pm
OLAP Product: TM1 - PAW & Architect
Version: PA 2.0.7 - PAW 2.0.44
Excel Version: office 2016

Re: Problem with GIT integration

Post by luizg2019 » Thu Jul 23, 2020 11:21 am

Did you try to manually delete the }git folder and the }git.ctx file from your data folder and then do another GitInit?

scrumthing
Posts: 43
Joined: Tue Jan 26, 2016 4:18 pm
OLAP Product: TM1
Version: 2.0.9
Excel Version: too many

Re: Problem with GIT integration

Post by scrumthing » Thu Jul 23, 2020 12:15 pm

Yes, tried that. Forgot to mention it. Afterwards I can do a GitInit again with a proper result as far as I can see it.

Code: Select all

{'@odata.context': '$metadata#ibm.tm1.api.v1.Git', 'URL': 'xxx.git', 'Deployment': 'dev', 'DeployedCommit': {'ID': None, 'Summary': None, 'Author': None}, 'Remote': {'Connected': True, 'Branches': ['master'], 'Tags': []}}
There is no OLAP database besides TM1!

luizg2019
Posts: 19
Joined: Thu Sep 12, 2019 11:02 pm
OLAP Product: TM1 - PAW & Architect
Version: PA 2.0.7 - PAW 2.0.44
Excel Version: office 2016

Re: Problem with GIT integration

Post by luizg2019 » Thu Jul 23, 2020 1:14 pm

Well, that's really strange then. You get that error when you try to do a gitpush?

When I first tried git on PAL 2.0.7 I got a "tm1 failed to connect to git" error but it was because I didn't restart the tm1 server after installing the github certificates. Maybe could be a problem with the certificates? Do you have two-factor authorization on your git repository?

scrumthing
Posts: 43
Joined: Tue Jan 26, 2016 4:18 pm
OLAP Product: TM1
Version: 2.0.9
Excel Version: too many

Re: Problem with GIT integration

Post by scrumthing » Thu Jul 23, 2020 1:30 pm

I will double check that but I can send the GITINIT without an error. Seems more like a file system issue to me but have no idea why...
There is no OLAP database besides TM1!

Post Reply