Process Tree Expanding Error in PAW

Post Reply
User avatar
macsir
Community Contributor
Posts: 695
Joined: Wed May 30, 2012 6:50 am
OLAP Product: TM1
Version: PAL 2.0.8
Excel Version: Office 365
Contact:

Process Tree Expanding Error in PAW

Post by macsir » Mon Mar 09, 2020 12:49 am

Hi, all

We are on PAW 2.0.46 and I found this error when expanding process tree. Other trees are fine. Any idea?
Caused by: com.fasterxml.jackson.core.JsonParseException: Invalid UTF-8 start byte 0xa0
at [Source: (com.ibm.ba.pm.harmony.common.tm1.TM1RestResult$InputStreamProxy); line: 1, column: 268191]
Seems like some UTF-8 characters is causing the issue but I couldn't find any.

Thanks.
In TM1,the answer is always yes though sometimes with a but....
http://tm1sir.blogspot.com.au/

kangkc
Community Contributor
Posts: 206
Joined: Fri Oct 17, 2008 2:40 am
OLAP Product: TM1, PA , TMVGate
Version: 2.x
Excel Version: 36x
Location: Singapore
Contact:

Re: Process Tree Expanding Error in PAW

Post by kangkc » Tue Mar 10, 2020 12:17 am

macsir wrote:
Mon Mar 09, 2020 12:49 am
Hi, all

We are on PAW 2.0.46 and I found this error when expanding process tree. Other trees are fine. Any idea?
Caused by: com.fasterxml.jackson.core.JsonParseException: Invalid UTF-8 start byte 0xa0
at [Source: (com.ibm.ba.pm.harmony.common.tm1.TM1RestResult$InputStreamProxy); line: 1, column: 268191]
Seems like some UTF-8 characters is causing the issue but I couldn't find any.

Thanks.
Just a wild guess, some process name uses special characters that're reserved by JSON and it is not handled in PAW ?

User avatar
macsir
Community Contributor
Posts: 695
Joined: Wed May 30, 2012 6:50 am
OLAP Product: TM1
Version: PAL 2.0.8
Excel Version: Office 365
Contact:

Re: Process Tree Expanding Error in PAW

Post by macsir » Tue Mar 10, 2020 3:03 am

No, I went through all of them. Can't find any. Thanks.
In TM1,the answer is always yes though sometimes with a but....
http://tm1sir.blogspot.com.au/

User avatar
macsir
Community Contributor
Posts: 695
Joined: Wed May 30, 2012 6:50 am
OLAP Product: TM1
Version: PAL 2.0.8
Excel Version: Office 365
Contact:

Re: Process Tree Expanding Error in PAW

Post by macsir » Fri Mar 13, 2020 12:38 am

I even tested with following statement which works fine.
https://PROD SERVER:8010/api/v1/Processes
In TM1,the answer is always yes though sometimes with a but....
http://tm1sir.blogspot.com.au/

User avatar
macsir
Community Contributor
Posts: 695
Joined: Wed May 30, 2012 6:50 am
OLAP Product: TM1
Version: PAL 2.0.8
Excel Version: Office 365
Contact:

Re: Process Tree Expanding Error in PAW

Post by macsir » Wed Mar 18, 2020 1:50 am

I recopy the whole data folder again from 10.2.2 to PA. The issue went away and not sure why. Pretty much they are same bunch of processes.
In TM1,the answer is always yes though sometimes with a but....
http://tm1sir.blogspot.com.au/

Post Reply