Problem copying data between 2 cubes using TI

Post Reply
lynnsong986
Posts: 81
Joined: Wed Feb 28, 2018 2:20 pm
OLAP Product: TM1
Version: 10.2.2
Excel Version: 2016

Problem copying data between 2 cubes using TI

Post by lynnsong986 » Wed Jan 08, 2020 6:30 pm

Hello,

I have a source cube "ca_tax" and a target cube "ca_bal_sheet_cash_flow".

the source cube has 3 dimensions: Years, Company_BU, Tax_Meas
the target cube has 3 dimensions: Years, Company, Statementline
"Deferred tax Asset" and "Deferred Tax Liability" exist in both Tax_Meas and StatementLine dimensions.

The difference between dimensions "Company_BU" and "Company" is that "Company" has only the consolidated elements from "Company_BU":
i.e. in dimension Company_BU, I have BU
31101
31102
31103
31104
31105 all rolled up into company 31

where in dimension Company, I only have 31 as an element.

I can't use DB directly in rules to pull DTA/DTL as this triggers circular references given how the other balance sheet items are calculated. So I came up with a TI to copy the data over from source to target. However nothing got copied although the subsets and views were created successfully in both cubes. Is it because "31" is a consolidated element in the source view and a level-0 element in the target view? Can someone please show me how to make this work?

thanks so much,
Attachments
Data.PNG
Data.PNG (9.53 KiB) Viewed 99 times
Prolog2.PNG
Prolog2.PNG (46.03 KiB) Viewed 99 times
Prolog.PNG
Prolog.PNG (39.16 KiB) Viewed 99 times

lynnsong986
Posts: 81
Joined: Wed Feb 28, 2018 2:20 pm
OLAP Product: TM1
Version: 10.2.2
Excel Version: 2016

Re: Problem copying data between 2 cubes using TI

Post by lynnsong986 » Wed Jan 08, 2020 7:24 pm

I created a new cube and use rules to pull the numbers then use TI, it works. I think I know the answer. TI can only read/write from/to leaf-level cells?

lotsaram
MVP
Posts: 3340
Joined: Fri Mar 13, 2009 11:14 am
OLAP Product: TableManager1
Version: PA 2.0.x
Excel Version: Office 365
Location: Switzerland

Re: Problem copying data between 2 cubes using TI

Post by lotsaram » Wed Jan 08, 2020 9:16 pm

lynnsong986 wrote:
Wed Jan 08, 2020 7:24 pm
I created a new cube and use rules to pull the numbers then use TI, it works. I think I know the answer. TI can only read/write from/to leaf-level cells?
Not quite. TI can read from any intersection. Generally you would considder that TI can only write numeric data to leaf intersections but there is an exception if using the CellPutProportionalSpread function.

There are different ways you can achieve what you want to do via TI
1. process zero supressed leaf cells from source to target. This approach will probably be faster even though processing more cells. But you need to remenber to use the CellIncrementN function NOT CellPutN and map from Company_BU to Company, either with a AttrS or SubSt the first 2 characters to get the company from company_BU
2. process zero supressed consolidated cells where the source view only contains company level. For this approach you don't need to transform company_BU to company but you do need to be more carefult with how the view is constructed and make sure not to skip consolidations

################
Admins I think also the OP posted in the wrong forum.
Please place all requests for help in a public thread. I will not answer PMs requesting assistance.

lynnsong986
Posts: 81
Joined: Wed Feb 28, 2018 2:20 pm
OLAP Product: TM1
Version: 10.2.2
Excel Version: 2016

Re: Problem copying data between 2 cubes using TI

Post by lynnsong986 » Thu Jan 09, 2020 2:24 pm

Thank you so much lotsaram for your time explaining this to me! I'll definitely give it a try!

Post Reply