PAX Dynamic Report is not rendering to TM1 Web

Post Reply
AskAndAnswer
Posts: 39
Joined: Fri Jun 02, 2017 6:35 pm
OLAP Product: Planning Analytics
Version: 2.0...
Excel Version: 2016

PAX Dynamic Report is not rendering to TM1 Web

Post by AskAndAnswer » Fri Nov 01, 2019 4:06 pm

Hello,
I found several discussions about this issue, but none of them actually answered a question why dynamic reports are not properly rendering in TM1 Web.
I am on Planning Analytics and PAX 2.0.6 and I have a dynamic report with four row dimensions, one of which (Time) is based on the subset created by MDX on the same sheet. The MDX is based on the date range. When the report is recalculated in PAX, it displays all data. If I publish it to Web, I get all dimension elements, but DBRW formulas do not show any data.
The report worked before the server refresh from production. Dimension order in the cube did not change. Also, there are three tabs on the websheet, two of them don't work, but one works. The one that works does not use MDX in TM1RPTROW, instead it has a reference to a dynamic subset. I tried to use the same dynamic subset on the websheet that does not work, and it still did not work.

Are there any known bugs or issues that can explain what's going on? Are the first two websheets corrupted, but I can't find where?

AskAndAnswer
Posts: 39
Joined: Fri Jun 02, 2017 6:35 pm
OLAP Product: Planning Analytics
Version: 2.0...
Excel Version: 2016

Re: PAX Dynamic Report is not rendering to TM1 Web

Post by AskAndAnswer » Fri Nov 01, 2019 9:05 pm

Since I figured it out, I'll post the solution:
It looks like this version of Planning Analytics has an issue reading aliases. All row dimension elements should have principal names.

Wim Gielis
MVP
Posts: 2262
Joined: Mon Dec 29, 2008 6:26 pm
OLAP Product: TM1
Version: PAL 2.0.8
Excel Version: Office 365 - latest
Location: Brussels, Belgium
Contact:

Re: PAX Dynamic Report is not rendering to TM1 Web

Post by Wim Gielis » Fri Nov 01, 2019 9:10 pm

Thanks. Is it fixed in a later version ?
Best regards,

Wim Gielis

Excel Most Valuable Professional, 2011-2014
http://www.wimgielis.com ==> 109 TM1 articles and a lot of custom code
Newest blog article: Set up a TM1 model with AutoHotKey as a service or application

a1m80t
Posts: 10
Joined: Mon Mar 09, 2015 11:54 pm
OLAP Product: TM1
Version: 9.1 to 10.2.2
Excel Version: Office 2010

Re: PAX Dynamic Report is not rendering to TM1 Web

Post by a1m80t » Sat Nov 02, 2019 5:12 pm

Wim Gielis wrote:
Fri Nov 01, 2019 9:10 pm
Thanks. Is it fixed in a later version ?
I don't have this problem in PA 2.0.8 and I'm pretty sure it wasn't in 2.0.6 either

Post Reply