Lost data after restart the computer

Post Reply
Alex Leung
Posts: 3
Joined: Fri May 24, 2019 1:23 am
OLAP Product: Planning Analytics
Version: 2.0.6
Excel Version: Excel 2013 32-bit

Lost data after restart the computer

Post by Alex Leung » Thu Jun 27, 2019 1:50 am

Dear all,

I am using TM1 10.2.2. I restart the computer which is running a TM1 server. But i did not stop the TM1 service before restarting.

After restarting the computer, the tm1 service also restarted. However, i found that a part of data was lost.

Below shows the action between 24/6 - 26/6:
1) Run Daily Process - Save Data All at 3:00 pm on 24/6.
2) I imported May exchange rate on 24/6 successfully.
3) Run Daily Process - Backup at 11:00 pm
3) I can generate the financial report on 25/6 correctly based on May exchange rate.
4) Run Daily Process - Save Data All at 3:00 pm on 25/6.
5) Run Daily Process - Backup at 11:00 pm
6) Restart the computer without shutting down the tm1 service at 11:00 am on 26/6.
7) After restarting the computer & tm1 service, the exchange rates in May become zero but other months exchange rate still exists.

I tried to find the reason by transaction log in period 24/6 - 26/6.
Only found the transaction on 24/6 which wrote the value on May exchange rate. But there is no transaction to clear the values.

And i restored the 25/6 image, the exchange rate of May exists.

In this issues, is the reason of losing data most likely due to restart the computer without shutting down the tm1 service?

Besides, i would like to ask why running "SaveDataAll" cannot prevent the losing data issue. Should i restart the tm1 service everyday to save the data?

Please help.

Thanks & Regards,
Alex

Post Reply