PAW unable to connect to TM1 Database

Post Reply
slique-cya
Posts: 12
Joined: Thu Jul 28, 2011 12:01 am
OLAP Product: TM1, Planning Analytics
Version: v9.5.2 v10.1, v2.0.6
Excel Version: v2003-2016

PAW unable to connect to TM1 Database

Post by slique-cya » Mon May 27, 2019 10:55 am

Hi, 

 I am using the Planning Sample TM1 database to test the installation process of Planning Analytics Workspace. I can connect to the Welcome Page of PAW.  The issue is when I try to create a New Book, instead of seeing  the TM1 database, I get the following error: 

"Path not exist" 

I also navigated to the "Administer" page where I could pick up the Planning Sample TM1 database. I can see the TM1 server that is running but it also shows an error message: 

"Cannot display resource information. Unable to connect to server."

This is my first time installing Planning Analytics Workspace so please forgive me if I have missed out any information that might help in this instance. PAW is installed on the below environment: 

- Hyper-V Virtual Machine
- Windows Server 2016 Standard Edition OS
- Docker EE version 18.09.6
- Docker-Compose version 1.24.0
- PAW version 2.0.41
- TM1 version PA 2.0.6

I even turned off Firewalls (Both Windows and ESET) and I still get the same error on both the server and on a separate client machine.

dr.nybble
Posts: 135
Joined: Wed Aug 17, 2011 3:51 pm
OLAP Product: TM1
Version: 10.2.2
Excel Version: Excel 2007

Re: PAW unable to connect to TM1 Database

Post by dr.nybble » Mon May 27, 2019 1:58 pm

In order for the "Administer" page to display resource information, the "IBM Planning Analytics Administration Agent" service must be configured and running. The TM1 Server also needs to be reporting the correct address to the admin host.

You may need to specify the IPAddressV4 setting in tm1s.cfg so TM1 reports the correct IP address to the admin host.

If you capture a Fiddler trace or network trace in the browser, what request is failing?

slique-cya
Posts: 12
Joined: Thu Jul 28, 2011 12:01 am
OLAP Product: TM1, Planning Analytics
Version: v9.5.2 v10.1, v2.0.6
Excel Version: v2003-2016

Re: PAW unable to connect to TM1 Database

Post by slique-cya » Tue May 28, 2019 1:25 pm

Hi dr.nybble

So I have confirmed that the "IBM Planning Analytics Administration Agent" service is running - I was running all along apparently.

I added the IPAddressV4 parameter onto the .cfg file (the AdminHost and IPAddressV4 parameters are the same)

But after restarting the TM1 Service, TM1 Admin Server, as well as the PAW Admin Tool, I go the following error.

"pa-gateway’s server IP address could not be found"

This is after successfully validating the configuration on PAW Admin tool
PAW Admin Validation.png
PAW Admin Validation.png (11.3 KiB) Viewed 119 times
Below is a screenshot of the PAW script
PAW Scripts.png
PAW Scripts.png (46.83 KiB) Viewed 119 times

slique-cya
Posts: 12
Joined: Thu Jul 28, 2011 12:01 am
OLAP Product: TM1, Planning Analytics
Version: v9.5.2 v10.1, v2.0.6
Excel Version: v2003-2016

Re: PAW unable to connect to TM1 Database

Post by slique-cya » Wed Jun 05, 2019 9:24 am

An update:

After re-installing PAW AND adding the TM1 PortNumber onto the Inbound Firewall Rules, I can now access the TM1 Server via PAW. The following changes were made:

1. updated the tm1s.cfg file.
- IPAddress=T
- IPVersion=ipv4

2. Added TM1 PortNumber, AdminServer Ports, and HTTPPortNumber onto the Inbound Firewall Rules.

The above seemed to take care of the "Path Not Exist" error. I am still unable to see the TM1 Server resource info on the administration tab, but that is a secondary issue at this point. If I crack that as well, I'll be sure to update this thread.

Post Reply