RushTI execution error

Post Reply
EvgenyT
Community Contributor
Posts: 275
Joined: Mon Jul 02, 2012 9:39 pm
OLAP Product: Cognos TM 1
Version: 10.2.2
Excel Version: 2013
Location: Sydney, Australia

RushTI execution error

Post by EvgenyT » Thu May 23, 2019 3:22 am

Hi,

Has anyone here used RushTI successfully yet?

Background:
  • Running Python 3.6.7150.0
  • Due to restriction on a cloud server (cant download and use pip install TM1py), I had to paste TM1py package manually into ...\Python36\Libs.
  • I have tested Rest API connection to the server with check.py (in Tm1Py sampler). Connection successful
  • I have also confirmed with Postman with a simple GET
  • I have also confirmed by running a simple code from the samples, I get JSON feedback
Puling my hair out with an issue here, snippet from the Rush.txt

2019-05-23 12:54:42,662 - RushTI - ERROR - Execution failed. Process: ProcessName: {'ParamOne': '1', 'ParaTwo': '1'}. Elapsed time: 0:00:00. Error: 'ProcessService' object has no attribute 'execute_with_return'.
2019-05-23 12:54:42,662 - RushTI - ERROR - RushTI ends. 1 fails out of 1 executions. Elapsed time: 0:00:00.015625

If anyone has experience a similar problem or can decipher Python for me, it would be much appreciated

Regards,

Evgeny

Paul Segal
Community Contributor
Posts: 257
Joined: Mon May 12, 2008 8:11 am
OLAP Product: TM1
Version: 10.2.2
Excel Version: 2010

Re: RushTI execution error

Post by Paul Segal » Thu May 23, 2019 10:57 am

Best to ask on the RushTI github page? https://github.com/cubewise-code/rushti/issues
Paul

lotsaram
MVP
Posts: 3248
Joined: Fri Mar 13, 2009 11:14 am
OLAP Product: TableManager1
Version: PA 2.0.x
Excel Version: Office 365
Location: Switzerland

Re: RushTI execution error

Post by lotsaram » Thu May 23, 2019 2:00 pm

Which TM1 server version are you using?
The ExecuteWithReturn function used by RushTI was introduced in a more recent PAL version, 2.0.4 or 2.0.5. So if your server is 10.2.2 or early v11 it won't work.
Please place all requests for help in a public thread. I will not answer PMs requesting assistance.

EvgenyT
Community Contributor
Posts: 275
Joined: Mon Jul 02, 2012 9:39 pm
OLAP Product: Cognos TM 1
Version: 10.2.2
Excel Version: 2013
Location: Sydney, Australia

Re: RushTI execution error

Post by EvgenyT » Thu May 23, 2019 9:22 pm

Paul Segal wrote:
Thu May 23, 2019 10:57 am
Best to ask on the RushTI github page? https://github.com/cubewise-code/rushti/issues
I have asked on GitHub as well, but since tm1forum has more active participants, I thought I would ask here too.
Thanks

Evgeny

EvgenyT
Community Contributor
Posts: 275
Joined: Mon Jul 02, 2012 9:39 pm
OLAP Product: Cognos TM 1
Version: 10.2.2
Excel Version: 2013
Location: Sydney, Australia

Re: RushTI execution error

Post by EvgenyT » Thu May 23, 2019 11:21 pm

lotsaram wrote:
Thu May 23, 2019 2:00 pm
Which TM1 server version are you using?
The ExecuteWithReturn function used by RushTI was introduced in a more recent PAL version, 2.0.4 or 2.0.5. So if your server is 10.2.2 or early v11 it won't work.
Resolved it by downloading an earlier release "https://github.com/cubewise-code/rushti ... /tag/0.1.0" as advised by Marius from GitHub.
We are v11.0.5.79-0

Make sure to encode your password to with https://www.base64encode.org/, else python throws out an "incorrect padding" error.

Regards,

Evgeny

Post Reply