Page 1 of 1

RulesOverwriteCellsOnLoad is NOT working

Posted: Fri May 03, 2019 1:23 am
by macsir
Hi, all
My version is 10.2.2 FP7, I put a numeric value into a cell, e.g. 888 and then applied a rule to get value from another cell, e.g. 999.
The parameter RulesOverwriteCellsOnLoad is not in the config file and I restart the server, disable the rule, the original value 888 is still there.
According to https://www.ibm.com/support/knowledgece ... nload.html It should be true if this parameter is not present in the configuration file.
Even if I put RulesOverwriteCellsOnLoad=T into config file and reboot, the original value 888 is still there.
And then I put RulesOverwriteCellsOnLoad=F into config file and reboot, the original value 888 is still there.

It looks like RulesOverwriteCellsOnLoad has no effect at all, am I doing something wrong here? Thanks.

Re: RulesOverwriteCellsOnLoad is NOT working

Posted: Fri May 03, 2019 5:03 am
by macsir
I can confirm same situation on PAL 2.0.6. Has anyone really got this parameter working as expected?

Re: RulesOverwriteCellsOnLoad is NOT working

Posted: Mon May 06, 2019 8:03 pm
by macsir
Anyone can give advice?

Re: RulesOverwriteCellsOnLoad is NOT working

Posted: Tue May 07, 2019 12:09 pm
by Drg
TM1SERVER_APP_version=TM1SERVER_APP-AW64-ML-RTM-11.0.6.71-0



WORKED FINE.
write some data in cube. append on this slice rule savedataall restart.

RulesOverwriteCellsOnLoad=F data save after disable rule
RulesOverwriteCellsOnLoad=T data loss after disable rule

Re: RulesOverwriteCellsOnLoad is NOT working

Posted: Wed May 15, 2019 11:53 pm
by macsir
Drg wrote:
Tue May 07, 2019 12:09 pm
TM1SERVER_APP_version=TM1SERVER_APP-AW64-ML-RTM-11.0.6.71-0



WORKED FINE.
write some data in cube. append on this slice rule savedataall restart.

RulesOverwriteCellsOnLoad=F data save after disable rule
RulesOverwriteCellsOnLoad=T data loss after disable rule
hi, Drg
I have same version as yours but not working.
What I have done is, set RulesOverwriteCellsOnLoad=T first, savedataall and reboot.
create a simple cube with simple value,
111.PNG
111.PNG (2.73 KiB) Viewed 474 times
attach a rule for copying value from "3" cell, savedataall and reboot
222.PNG
222.PNG (2.86 KiB) Viewed 474 times
after rebooting, disable the rule,
444.PNG
444.PNG (3.93 KiB) Viewed 474 times

Re: RulesOverwriteCellsOnLoad is NOT working

Posted: Wed May 15, 2019 11:54 pm
by macsir
and those two original values "1" and "2" are still there
555.PNG
555.PNG (2.95 KiB) Viewed 473 times
What's wrong here???

Re: RulesOverwriteCellsOnLoad is NOT working

Posted: Fri May 17, 2019 10:17 am
by Drg
I have read the documentation and I understand its name as shown in the picture below.
Another question that I found an interesting feature is that it is marked with the third option. I suppose this is updated with the update of the cube and in combat situations it will lead you according to the documentation.
123.png
123.png (51.12 KiB) Viewed 442 times

Re: RulesOverwriteCellsOnLoad is NOT working

Posted: Fri May 17, 2019 10:19 am
by Drg
Yes today we update to 2.0.7

Other configs.
[TM1S]
ServerLogging=F
SecurityPackageName=Kerberos
IntegratedSecurityMode=1
UseSSL=T
ServerName=HauptAbu1
DataBaseDirectory=D:\PAModels\HauptAbu1
AdminHost=
PortNumber=
ClientMessagePortNumber=
Savetime=
Downtime=
LicenseMetricTime=
ProgressMessage=True
AuditLogOn=T
AuditLogMaxFileSize= 100 MB
AuditLogUpdateInterval=60
PersistentFeeders=F
ParallelInteraction=T
IPVersion=ipv4
ServerCAMIPVersion=ipv4
AllowSeparateNandCRules=T
DistributedPlanningOutputDir=tunit
ForceReevaluationOfFeedersForFedCellsOnDataChange=T
RunningInBackground=T
LoggingDirectory=

Re: RulesOverwriteCellsOnLoad is NOT working

Posted: Mon May 20, 2019 3:51 am
by macsir
Drg wrote:
Fri May 17, 2019 10:17 am
I have read the documentation and I understand its name as shown in the picture below.
Another question that I found an interesting feature is that it is marked with the third option. I suppose this is updated with the update of the cube and in combat situations it will lead you according to the documentation.
123.png
Appreciated your testing! I found my root cause now. It is because of PersistentFeeders. I have that enabled and obviously, after disabling, RulsOverwriteCellsOnLoad works as expected. :D
I noticed your third testing. Yes, it did happen to me as well and I have done further testing on that. Once they are zeros before rebooting with RulsOverwriteCellsOnLoad=F, if you write some new values to same cells, these old rule-overwritten values won't come back after rebooting. Seems that they have been deleted permanently. I am guessing IBM is using some "roll-back" mechanism to cache these old values somewhere for rolling back. Anyway, it is good to know. :lol:

Re: RulesOverwriteCellsOnLoad is NOT working

Posted: Mon May 20, 2019 8:08 am
by lotsaram
macsir wrote:
Mon May 20, 2019 3:51 am
I found my root cause now. It is because of PersistentFeeders. I have that enabled and obviously, after disabling, RulsOverwriteCellsOnLoad works as expected. :D
That's interesting. RulsOverwriteCellsOnLoad should be independent of PersistentFeeders! That this doesn't work when PersistentFeeders is switched on might say something to the recent bugs where (persistent) feeders deleted data on server load

Re: RulesOverwriteCellsOnLoad is NOT working

Posted: Mon May 20, 2019 8:58 pm
by macsir
lotsaram wrote:
Mon May 20, 2019 8:08 am
macsir wrote:
Mon May 20, 2019 3:51 am
I found my root cause now. It is because of PersistentFeeders. I have that enabled and obviously, after disabling, RulsOverwriteCellsOnLoad works as expected. :D
That's interesting. RulsOverwriteCellsOnLoad should be independent of PersistentFeeders! That this doesn't work when PersistentFeeders is switched on might say something to the recent bugs where (persistent) feeders deleted data on server load
That is my original thought too. But what I tell is if you have PersistentFeeders switched on in 10.2.2 FP7, this parameter still doesn't work after testing. :o