CAM Groups with back slash in v11

Post Reply
grusty
Posts: 9
Joined: Thu Oct 11, 2018 10:11 pm
OLAP Product: IBM Planning Analytics
Version: 2.0
Excel Version: 2013 32 bit

CAM Groups with back slash in v11

Post by grusty » Fri Apr 12, 2019 3:38 pm

We recently upgraded from v10.2.2 to v11 and when I run Security Refresh it crashes. I noticed that new CAM groups that I add have a forward slash instead of a backslash. Does anyone know if this could be what is causing the issue? Do I need to delete all the old CAM groups with a backslash and re-add them?
Picture1.png
Picture1.png (141.84 KiB) Viewed 146 times

moby91
MVP
Posts: 211
Joined: Fri Mar 11, 2011 2:18 pm
OLAP Product: TM1
Version: 9.5.1
Excel Version: 2003 2007

Re: CAM Groups with back slash in v11

Post by moby91 » Sat Apr 20, 2019 1:50 pm

https://www-01.ibm.com/support/docview. ... wg21650631
CAM user ID backslash/forward slash change in TM1 10.2

Technote (troubleshooting)

Problem(Abstract)
TM1 users logging in with a CAM user ID will find that TM1 10.2 no longer will accept a CAM user ID with backslash character. They can log in but the character will be changed to a forward slash.

Symptom
The first time such a user logs in the }TM1_DefaultDisplayValue value will automatically change from Namespace\<UserName> to Namespace/<UserName>.

Cause
TM1 has standardized on CAM user ID format. There is no way around this.

Resolving the problem
If the TM1 environment has dependencies on the backslash character, relevant edits will have to be made to those affected objects and code.

Post Reply