Websheet connected to wrong server

Post Reply
bunchukokoy
Regular Participant
Posts: 193
Joined: Thu Dec 03, 2009 8:47 am
OLAP Product: IBM Cognos TM1
Version: 10.2.2.x
Excel Version: 2010
Location: Singapore

Websheet connected to wrong server

Post by bunchukokoy » Mon Apr 08, 2019 9:43 am

Hello guys.

Does anyone know what could be the issue here? This image below shows a downloaded websheet, a snapshot.
I connected to our DEV environment though. Somehow, I got connected to the TEST environment, and it's proven by the Server Manager function in our TEST env., the data we're getting. Weird.

On Perspectives it's working fine. But on web, the TM1USER() returns my camid for TEST environment. We have these sheets running all correct before in our previous TM1 version. No formula was changed.

Image below shows EDP TEST as the server I am connected on. Although EDP DEV is the one I logged on to.
These two instances reside in same machine. EDP PROD is in a separate machine.

As always, thanks in advance!
Connected to wrong server.JPG
Connected to wrong server.JPG (30.85 KiB) Viewed 377 times

lotsaram
MVP
Posts: 3290
Joined: Fri Mar 13, 2009 11:14 am
OLAP Product: TableManager1
Version: PA 2.0.x
Excel Version: Office 365
Location: Switzerland

Re: Websheet connected to wrong server

Post by lotsaram » Mon Apr 08, 2019 11:37 am

This is normal or expected behaviour. If the different instances share the same
- admin host
- authentication method
- username
- password

... then for each TM1User function TM1Web will attempt to log in with the same credentials as the "primary" instance (that the user logged in from).

Where multiple instances are then authenticated against it it then up to the report designer (i.e. you) to implement logic in the IF functions to determine the instance name, what the priority order should be to establish the instance to use in the DBRW & SUBNM references. (Typically I use DEV>TEST>PROD with the logic that this minimizes risk should a user be authenticated against multiple instances. But others may prefer the priority logic in reverse.)

I guess you have DEV & TEST on the same admin host. In TM1Web to only connect to a single instance at a time you need to separate the admin hosts.
Please place all requests for help in a public thread. I will not answer PMs requesting assistance.

manpreet
Posts: 20
Joined: Mon May 20, 2019 9:54 am
OLAP Product: TM1
Version: 10.2.2
Excel Version: 2013

Re: Websheet connected to wrong server

Post by manpreet » Mon Jun 03, 2019 4:31 am

hey bunchukokoy,

Did you solved this problem i am also facing the same problem.

if you have solved this can you please share the solution.

thank you.

Post Reply