PAW not working after network changes

User avatar
gtonkin
MVP
Posts: 739
Joined: Thu May 06, 2010 3:03 pm
OLAP Product: TM1
Version: PAL 2.0.3
Excel Version: 2016 64-bit
Location: JHB, South Africa
Contact:

Re: PAW not working after network changes

Post by gtonkin » Tue Oct 09, 2018 2:23 pm

>docker ps -a returns the same result - just seems like the gateway has not installed.

User avatar
gtonkin
MVP
Posts: 739
Joined: Thu May 06, 2010 3:03 pm
OLAP Product: TM1
Version: PAL 2.0.3
Excel Version: 2016 64-bit
Location: JHB, South Africa
Contact:

Re: PAW not working after network changes

Post by gtonkin » Tue Oct 09, 2018 2:30 pm

Just re-ran scripts\paw.ps1:

Code: Select all

PS C:\paw> scripts/paw.ps1
The IBMCognosGatewayURL variable is not set. Defaulting to a blank string.
Pulling social (pa-docker:5000/planninganalytics/social:1.0.50-windowsservercore)...

Get https://pa-docker:5000/v2/: dial tcp: lookup pa-docker: no such host

Execution failed with exit code 1
At C:\paw\scripts\init.ps1:58 char:13
+             throw "Execution failed with exit code $LASTEXITCODE"
+             ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : OperationStopped: (Execution failed with exit code 1:String) [], RuntimeException
    + FullyQualifiedErrorId : Execution failed with exit code 1

dr.nybble
Regular Participant
Posts: 152
Joined: Wed Aug 17, 2011 3:51 pm
OLAP Product: TM1
Version: 10.2.2
Excel Version: Excel 2007

Re: PAW not working after network changes

Post by dr.nybble » Tue Oct 09, 2018 4:06 pm

If you ever see the "pulling" message then likely the images are not loaded (or got removed).

dharav9
Posts: 38
Joined: Wed Aug 15, 2018 3:18 pm
OLAP Product: TM1
Version: 10.3
Excel Version: 2016

Re: PAW not working after network changes

Post by dharav9 » Wed Feb 13, 2019 2:29 am

Hi,

I experienced the same issue earlier. We identified that port 80 might be open for other app. Port 80 is generic port number for many applications.
So we updated the PAW/CONFIG/Paw.ps1 file with $environment line to change port number. We changed to port 82 and run powershell as admin. Test the change in powershell by scripts/paw.ps1. PA-Gateway connected----done. Now re-start PAW => ./start.ps1

Everything works.

Hope it helps. Thank You

Dharav

User avatar
gtonkin
MVP
Posts: 739
Joined: Thu May 06, 2010 3:03 pm
OLAP Product: TM1
Version: PAL 2.0.3
Excel Version: 2016 64-bit
Location: JHB, South Africa
Contact:

Re: PAW not working after network changes

Post by gtonkin » Wed Feb 13, 2019 10:12 am

Thanks for the information - unfortunately in my case it did not appear to be something else on port 80 but will definitely add your comments to my ever-growing notes for the next time!

Mark RMBC
Regular Participant
Posts: 203
Joined: Tue Sep 06, 2016 7:55 am
OLAP Product: TM1
Version: 10.1.1
Excel Version: Excel 2010

Re: PAW not working after network changes

Post by Mark RMBC » Thu Aug 22, 2019 12:00 pm

Hi,

I am getting a gateway error, it says exited.

I have tried to run the .\WindowsContainerNetworking-LoggingAndCleanupAide.ps1 -Cleanup -ForceDeleteAllSwitches command in powershell but am getting the following error:

.\WindowsContainerNetworking-LoggingAndCleanupAide.ps1 : The term
'.\WindowsContainerNetworking-LoggingAndCleanupAide.ps1' is not recognized as the name of a cmdlet, function, script
file, or operable program. Check the spelling of the name, or if a path was included, verify that the path is correct
and try again.
At line:1 char:1
+ .\WindowsContainerNetworking-LoggingAndCleanupAide.ps1
+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+ CategoryInfo : ObjectNotFound: (.\WindowsContai...CleanupAide.ps1:String) [], CommandNotFoundException
+ FullyQualifiedErrorId : CommandNotFoundException

Does anyone know what I am doing wrong?

regards, Mark

dr.nybble
Regular Participant
Posts: 152
Joined: Wed Aug 17, 2011 3:51 pm
OLAP Product: TM1
Version: 10.2.2
Excel Version: Excel 2007

Re: PAW not working after network changes

Post by dr.nybble » Thu Aug 22, 2019 1:28 pm

Is that file in your current directory? It complains it cannot find that PowerShell script.

Mark RMBC
Regular Participant
Posts: 203
Joined: Tue Sep 06, 2016 7:55 am
OLAP Product: TM1
Version: 10.1.1
Excel Version: Excel 2010

Re: PAW not working after network changes

Post by Mark RMBC » Thu Aug 22, 2019 2:25 pm

Hi dr.nybble,

I suspected this might have something to do with it. I don't know where the file is, I was just following some advice from IBM website
https://www-01.ibm.com/support/docview. ... bm10881484
They didn't specify you needed the location of the file. How would I find it?

I don't know if you can offer any advice on the issue we have:

we noticed paw webpage said the page isn't working.
We then ran docker ps-a and noticed the gateway was exited.
We then attempted to run scripts/paw.ps1 but this errored saying cannot start service pa-gateway failed to create endpoint pa-gateway on network nat : HNS failed with error : The object already exists

We checked if anything was using port 80 but it didn't appear anything was.
We tried stop and then restart via the admin tool, and rebooting the server and trying scripts/paw.ps1 again (didn't work)
we then decided to try Docker container rm pa-gateway
we then tried to run scripts/paw.ps1 and got an error and when running scripts/paw.ps1 ps the pa-gateway shows as exited 128

any advice would be appreciated!

regards, Mark

dr.nybble
Regular Participant
Posts: 152
Joined: Wed Aug 17, 2011 3:51 pm
OLAP Product: TM1
Version: 10.2.2
Excel Version: Excel 2007

Re: PAW not working after network changes

Post by dr.nybble » Thu Aug 22, 2019 5:35 pm

It's a Microsoft script located here:

https://github.com/MicrosoftDocs/Virtua ... upAide.ps1

Mark RMBC
Regular Participant
Posts: 203
Joined: Tue Sep 06, 2016 7:55 am
OLAP Product: TM1
Version: 10.1.1
Excel Version: Excel 2010

Re: PAW not working after network changes

Post by Mark RMBC » Fri Aug 23, 2019 7:36 am

Thanks dr.nybble.

Just to be sure, if I copy this script and save it to a folder location I can then run the script in powershell?

Also given the issues I explained in my previous comment do you think running this script would be worth a try or would you suggest anything else?

regards, Mark

dr.nybble
Regular Participant
Posts: 152
Joined: Wed Aug 17, 2011 3:51 pm
OLAP Product: TM1
Version: 10.2.2
Excel Version: Excel 2007

Re: PAW not working after network changes

Post by dr.nybble » Fri Aug 23, 2019 6:41 pm

Yes save it and run.

You may first do the following:

docker ps -a | sls gateway

If there are any gateway containers delete them

docker rm <container-id>

Check if the WinNAT module has any static mappings defined (it should not have port 80/443 mapped if there are no gateways):
Get-NetNatStaticMapping

If port 80/443 still show as mappings even after removing any pa-gateway containers try to remove them:
Get-NetNatStaticMapping | Remove-NetNatStaticMapping

Try PAW again to see if the pa-gateway can now bind to port 80/443

Otherwise it's script time......

Mark RMBC
Regular Participant
Posts: 203
Joined: Tue Sep 06, 2016 7:55 am
OLAP Product: TM1
Version: 10.1.1
Excel Version: Excel 2010

Re: PAW not working after network changes

Post by Mark RMBC » Tue Aug 27, 2019 10:34 am

Hi dr.nibble,

many thanks. So we got the container running, not saying exited anymore.

However we noticed in the admin tool configuration that the url's needed to be changed.

Finally we were able to login to workspace but it wouldn't open any books and said, it could not find the TM1 database.

Could this be to do with the network interface order?

dr.nybble
Regular Participant
Posts: 152
Joined: Wed Aug 17, 2011 3:51 pm
OLAP Product: TM1
Version: 10.2.2
Excel Version: Excel 2007

Re: PAW not working after network changes

Post by dr.nybble » Tue Aug 27, 2019 4:31 pm

You may need to set the 'IPAddressV4' setting in the tm1s.cfg file.

If your machine has multiple NICs then TM1 may choose the wrong one to advertise via the Admin Host.

Mark RMBC
Regular Participant
Posts: 203
Joined: Tue Sep 06, 2016 7:55 am
OLAP Product: TM1
Version: 10.1.1
Excel Version: Excel 2010

Re: PAW not working after network changes

Post by Mark RMBC » Mon Sep 02, 2019 3:22 pm

Hi dr.nibble,

Hope you are listening!

We have an issue, separate to the one above, with the pa-gateway container having a status of dead.

The error message says
paGateway issue.PNG
paGateway issue.PNG (80.05 KiB) Viewed 10724 times
We are unable to restart the container from the admin tool or via a reboot?

regards, Mark

dr.nybble
Regular Participant
Posts: 152
Joined: Wed Aug 17, 2011 3:51 pm
OLAP Product: TM1
Version: 10.2.2
Excel Version: Excel 2007

Re: PAW not working after network changes

Post by dr.nybble » Tue Sep 03, 2019 12:15 am

Ugh, some kind of Docker problem.

Can you remove it with docker rm ?

Mark RMBC
Regular Participant
Posts: 203
Joined: Tue Sep 06, 2016 7:55 am
OLAP Product: TM1
Version: 10.1.1
Excel Version: Excel 2010

Re: PAW not working after network changes

Post by Mark RMBC » Tue Sep 03, 2019 2:20 pm

Hi dr.nibble,

Yes, managed to remove the container, ran paw.ps1 stop, then paw.ps1 and everything is working (fingers crossed).

Apologies for throwing questions at you, but could you answer the following please?

Is it possible to have docker installed on one server and PAW installed on another server? If not what are the main reasons (I assume none of the scripts would work for a start)? So for example say you already have docker installed on a machine, can you install PAW on a different machine but use the docker you already have installed?

regards, Mark

Post Reply