Page 1 of 1


Posted: Wed Nov 08, 2017 9:29 am
by st2000
Hello all,

I just installed PA 2.0.3 into a Linux VM (CentOS 7 on Virtualbox 5.2, Host Win10 Pro 64 Bit). It works as I can start Cognos Configuration and the processes (Admin Server, TM1 Server, Planning Sample). I configured the support for pre-TLS1.2 clients to true.

But although I can see the login page (localhost:9510/tm1web/), after typing the topmost parameter for Adminhost (name, IP or localhost), I get a window showing just: SSL_TLSv2. Same behaviour inside of the VM (Firefox) and outside from the host PC (IE 11).

This indicates a problem with certificates, but a login to applications like PMHUB works. tm1_inst (for PA V2 R0, latest I found at IBM) guides how to import a certificate using a keytool command to run from the JAVA_HOME folder, but at first it asks if I trust the file ("yes"), then it says JAVA I/O Error, no such file. I use the preinstalled JAVA 1.8 already contained into CentOS 7. Is there anything obvious I could have missed?

Best regards,

Re: PA 2 SSL_TLSv2

Posted: Mon Jan 15, 2018 6:53 am
by guntupalli
i came across this even though getting the same error.

1.did you run the keytool command from 'bin' location that is associated to JAVA_HOME?
2.check the permissions before going to execute the command..

keep posting.

Best Regards

Re: PA 2 SSL_TLSv2

Posted: Mon Jan 29, 2018 1:16 pm
by asd900
Hi, i'm also having a similar issue on CentOS 7 with tm1 web giving me a error that says SSL_TLSv2,
while i'm still able to access tm1 applications.

I have imported a certificate using the keytool command from the location of the JAVA_HOME folder,
but to no success.

did you ever manager to solve this issue ? as i am not sure what i should do next.

Regards Matt

Re: PA 2 SSL_TLSv2

Posted: Mon Mar 05, 2018 10:37 am
by st2000
I managed to come over the problems partly:
  • I installed an IBM Java 7 instead of a kind of openJava already installed into the CentOS7 by default
  • then the import of the certificate into the keystore worked as described into the tm1_inst.pdf
  • and also I changed the URLs in from localhost to IP as far as they concern the application server; this seems to become exposed directly to the webserver and is not translated internally to the servers DNS name or IP
I could use now from the host outside from the VM TM1web and also Applications as they are pre-configured (VM-Network: Host-only, static IP).
But nevertheless I can't access from the Windows 10 - host via Architect or Performance Modeler to the Server inside the VM, which would be needed to create own Metadata and use a Linux Server at least for prototyping, development or demo purposes.

Unfortunately IBM only supports Windows and Linux OS which are not free. Even CentOS works here only as the nearestby variation to RHEL 7.
So I would need a separate windows license for each VM I work on... not very helpful.

IBM should offer a preconfigured VM including CentOS or different free OS for download, this would make it far easier for many of us.
For future tool evaluations this and also the need to use ILMT when hosted on a non-IBM cloud will be considered against other products as far as I will have to perform this somewhen.