app_maintenance.bat with CAM Security-INVALID_IDENTITY

Post Reply
duc82000
Posts: 3
Joined: Thu Jun 08, 2017 4:25 pm
OLAP Product: TM1
Version: 10.2.2
Excel Version: Excel 2016

app_maintenance.bat with CAM Security-INVALID_IDENTITY

Post by duc82000 » Thu Jun 08, 2017 7:50 pm

I am trying to run the app_maintenance.bat and getting an INVALID_IDENTITY error.

The things I tried to overcome this is below:
1) I looked at the previous forum and tried to manually get the CAM_Passport information needed by logging on the BI Server and the pressing F12
(http://www-01.ibm.com/support/docview.w ... wg21981075). There isn't any CAM_Passport info from doing this.

2) Also, from http://www.tm1forum.com/viewtopic.php?t=10265 and https://greenydangerous.com/2015/01/27/ ... challenge/
I tried to create a powershell script that will be saved into the text file. The powershell script ran fine but it created a text file that was empty.

Is there another way for me to try and get the CAM_Passport information to pass it to the app_maintenance.bat script?

Any help is much appreciated.
Duc

duc82000
Posts: 3
Joined: Thu Jun 08, 2017 4:25 pm
OLAP Product: TM1
Version: 10.2.2
Excel Version: Excel 2016

Re: app_maintenance.bat with CAM Security-INVALID_IDENTITY

Post by duc82000 » Mon Jun 12, 2017 7:50 pm

I was able to get the Cam_Passport parameter manually and pass it to app_maintenance script but still getting INVALID_IDENTITY.


Thanks,
Duc

duc82000
Posts: 3
Joined: Thu Jun 08, 2017 4:25 pm
OLAP Product: TM1
Version: 10.2.2
Excel Version: Excel 2016

Re: app_maintenance.bat with CAM Security-INVALID_IDENTITY

Post by duc82000 » Mon Jun 12, 2017 10:01 pm

I got the script to dump the Cognos passport parameter and then passed it to the app_maintenance script. It is now working fine.

Emixam
Posts: 107
Joined: Tue May 21, 2019 3:33 pm
OLAP Product: TM1
Version: PA 2.0.x
Excel Version: 2016
Location: The Internet

Re: app_maintenance.bat with CAM Security-INVALID_IDENTITY

Post by Emixam » Tue Mar 30, 2021 6:17 pm

Anybody still using app_maintenance with CAM with the new version of TM1Web (Planning Analytics Local 2.0.55 and after) ? It stop working for us since we did the upgrade. Maybe it's because TM1 Applications (pmpsvc) is now using a different port number than TM1Web ?

This was working before (port 9510)

Code: Select all

D:
cd "D:\Program Files\ibm\cognos\tm1_64\webapps\pmpsvc\WEB-INF\tools"
app_maintenance.bat 
-serviceUrl hostName.domainName:9510/pmpsvc 
-username MyUserName 
-userpwd  MyPassword
-CAMNamespace MyNameSpace
-applicationid df446e27-7221-4af3-9a65-e3d63eade41 
-op deactivate
This is no longer working (port 9511)

Code: Select all

D:
cd "D:\Program Files\ibm\cognos\tm1_64\webapps\pmpsvc\WEB-INF\tools"
app_maintenance.bat 
-serviceUrl hostName.domainName:9511/pmpsvc 
-username MyUserName 
-userpwd  MyPassword
-CAMNamespace MyNameSpace
-applicationid df446e27-7221-4af3-9a65-e3d63eade41 
-op deactivate
I get the following error message:

Code: Select all

An exception occured during operation execute:'com.ibm.cognos.fpmsvc.exception.FPMSVCException: Invalid identity string. :INVALID_IDENTITY'
 WHILE [CCLMsg: system text='INVALID_IDENTITY']
exitCode=700

Am I missing something ?
Sorry for my English :)

Post Reply