Process re-starting in a chore TM1 10.2.0

Post Reply
jyoung66
Posts: 24
Joined: Fri Aug 13, 2010 2:14 am
OLAP Product: TM1
Version: PAW 2 PAX
Excel Version: 2016

Process re-starting in a chore TM1 10.2.0

Post by jyoung66 » Sat Jun 28, 2014 6:09 am

Hi

Hoping someone can help with an issue that I have not come across before

A long running chore has processes that seem to be restarting, the chore is only scheduled once at 12:30am local time

I have attached an extract from the TM1Server log

Note that the process DIM_Build_Business_Unit_Grouping_Tenant runs at local time 12:30:02 AM, then at 3:09:54 AM and 3:36:17 AM before finishing at 4:42:29 AM

There is no information as to WHY this process restarted in the logs

The information I have provided is just an extract, I have more information that I can provide but the log file is large.

Other information:
There is another chore running just prior to this that started at 12:01am and finished at 3:10am local time
There is a DataSaveAll at 3:10 as well
The chore that finishes at 3:10 has process that do not take advantage of Parallel Interaction; lots of view creates and destroys

I am guessing that the problem relates to the processes constantly having to roll back and restart due to conflicts

A consultant pointed me to log4j.logger.TM1.Commit=DEBUG as a means of getting more information and I plan to do this overnight tonight, but I am concerned that this may come with an overhead

Any suggestions?
Happy to provide any more information as required
Attachments
Published extract.xlsx
(9.54 KiB) Downloaded 50 times

declanr
MVP
Posts: 1628
Joined: Mon Dec 05, 2011 11:51 am
OLAP Product: Cognos TM1
Version: PA2.0 and most of the old ones
Excel Version: All of em
Location: Manchester, United Kingdom
Contact:

Re: Process re-starting in a chore TM1 10.2.0

Post by declanr » Sat Jun 28, 2014 7:09 am

SaveDataAll requires a system wide lock so anything else going on at that time will be rolled back.

Just take the SaveDataAll out of that process and make sure it only runs when all of your chores have run. That's not to say you don't have other issues but I would start by getting rid of the SaveDataAll.
Declan Rodger

jyoung66
Posts: 24
Joined: Fri Aug 13, 2010 2:14 am
OLAP Product: TM1
Version: PAW 2 PAX
Excel Version: 2016

Re: Process re-starting in a chore TM1 10.2.0

Post by jyoung66 » Sat Jun 28, 2014 7:27 am

Thank you

Yes I see in the logs there are always SaveDataAll happening around the time of the restarts

that looks like it may be the issue

jyoung66
Posts: 24
Joined: Fri Aug 13, 2010 2:14 am
OLAP Product: TM1
Version: PAW 2 PAX
Excel Version: 2016

Re: Process re-starting in a chore TM1 10.2.0

Post by jyoung66 » Sun Jun 29, 2014 2:11 am

Actually, while this was PART of the problem (although it did go part of the way to fixing so thank you) there seemed also to be a conflict with another chore; the first process in the second chore had to re-start after the first had finalised (about 3.5 hours later!)

My suspicion is that the first chore is using pre parallel interaction view and subset destroys and creates and this may be causing contentions

I plan to address this and see how it goes.

Greatful for any other suggestions though

Post Reply