Cube Viewer suppress zeroes hiding non-zero cells

Post Reply
jamesbennett
Posts: 17
Joined: Wed Aug 08, 2018 10:01 am
OLAP Product: IBM Cognos TM1
Version: 10.2.2
Excel Version: 2016

Cube Viewer suppress zeroes hiding non-zero cells

Post by jamesbennett » Fri Jan 25, 2019 1:38 pm

I have just discovered that in (at least) one of my cubes, toggling the 'suppress zeroes' function on and off hides a row of non-zero cells in the cube viewer, as well as the zero-value cells. The suppressed cells are leaf-level and calculated via the cube rules. Has anyone encountered this before, or know why it might be happening?

Wim Gielis
MVP
Posts: 2214
Joined: Mon Dec 29, 2008 6:26 pm
OLAP Product: TM1
Version: PAL 2.0.8
Excel Version: Office 365 - latest
Location: Brussels, Belgium
Contact:

Re: Cube Viewer suppress zeroes hiding non-zero cells

Post by Wim Gielis » Fri Jan 25, 2019 1:40 pm

Sure. Are these values properly fed ? I suspect they are not, and hence, they disappear.
Best regards,

Wim Gielis

Excel Most Valuable Professional, 2011-2014
http://www.wimgielis.com ==> 109 TM1 articles and a lot of custom code
Newest blog article: Set up a TM1 model with AutoHotKey as a service or application

jamesbennett
Posts: 17
Joined: Wed Aug 08, 2018 10:01 am
OLAP Product: IBM Cognos TM1
Version: 10.2.2
Excel Version: 2016

Re: Cube Viewer suppress zeroes hiding non-zero cells

Post by jamesbennett » Fri Jan 25, 2019 1:47 pm

I believe so. The rules calculate values for five divisions using an 'All divisions' consolidation. On an unsuppressed view, values show up for all five divisions. When zeroes are suppressed, one of the five disappears.

David Usherwood
Site Admin
Posts: 1375
Joined: Wed May 28, 2008 9:09 am

Re: Cube Viewer suppress zeroes hiding non-zero cells

Post by David Usherwood » Fri Jan 25, 2019 2:02 pm

Have you checked? In Perspectives, right-click on a cell, select 'Check Feeders'.

jamesbennett
Posts: 17
Joined: Wed Aug 08, 2018 10:01 am
OLAP Product: IBM Cognos TM1
Version: 10.2.2
Excel Version: 2016

Re: Cube Viewer suppress zeroes hiding non-zero cells

Post by jamesbennett » Fri Jan 25, 2019 2:26 pm

David Usherwood wrote:
Fri Jan 25, 2019 2:02 pm
Have you checked? In Perspectives, right-click on a cell, select 'Check Feeders'.
What should I be seeing here? I do this and it shows the formula in the top half of the window, but nothing in the Trace / Value columns as in the 'Trace Calculations' window.

Same result for the cells that are not disappearing on 'suppress zeroes'.

David Usherwood
Site Admin
Posts: 1375
Joined: Wed May 28, 2008 9:09 am

Re: Cube Viewer suppress zeroes hiding non-zero cells

Post by David Usherwood » Fri Jan 25, 2019 2:35 pm

You selected 'Trace Calculations'. You need to select 'Check Feeders'. Make sure you are at the N level and on a calculated value.

jamesbennett
Posts: 17
Joined: Wed Aug 08, 2018 10:01 am
OLAP Product: IBM Cognos TM1
Version: 10.2.2
Excel Version: 2016

Re: Cube Viewer suppress zeroes hiding non-zero cells

Post by jamesbennett » Fri Jan 25, 2019 4:57 pm

Definitely check feeders! See the picture if it works:
Untitled.png
Untitled.png (48.89 KiB) Viewed 1014 times

David Usherwood
Site Admin
Posts: 1375
Joined: Wed May 28, 2008 9:09 am

Re: Cube Viewer suppress zeroes hiding non-zero cells

Post by David Usherwood » Sun Jan 27, 2019 10:39 am

That does look correct - but I am pretty sure you do have a feeder issue. Suggest you restart the server and recheck - possibly you have conditional feeders and the parameters have changed without a restart or refeed.

Wim Gielis
MVP
Posts: 2214
Joined: Mon Dec 29, 2008 6:26 pm
OLAP Product: TM1
Version: PAL 2.0.8
Excel Version: Office 365 - latest
Location: Brussels, Belgium
Contact:

Re: Cube Viewer suppress zeroes hiding non-zero cells

Post by Wim Gielis » Sun Jan 27, 2019 1:11 pm

When restarting TM1 delete the *.feeders file too, just to see if that helps too.
Best regards,

Wim Gielis

Excel Most Valuable Professional, 2011-2014
http://www.wimgielis.com ==> 109 TM1 articles and a lot of custom code
Newest blog article: Set up a TM1 model with AutoHotKey as a service or application

declanr
MVP
Posts: 1626
Joined: Mon Dec 05, 2011 11:51 am
OLAP Product: Cognos TM1
Version: PA2.0 and most of the old ones
Excel Version: All of em
Location: Manchester, United Kingdom
Contact:

Re: Cube Viewer suppress zeroes hiding non-zero cells

Post by declanr » Sun Jan 27, 2019 5:37 pm

There is a bug that one my customers currently has, I believe they are on PA 2.0.5 but not 100% as I don’t have access to install etc in their environment.
The issue means that check feeders never shows “not fed” - I tested this with a simple a = b rule on a 2 dim cube. Again due to not having access to the install/admin side I can’t confirm it’s not a setup issue but I can’t think of any configuration that could cause it so I am assuming a bug and will go through the internal customer (large enterprise) procedures to get it logged with IBM.
Declan Rodger

User avatar
qml
MVP
Posts: 1074
Joined: Mon Feb 01, 2010 1:01 pm
OLAP Product: TM1 / Planning Analytics
Version: 2.0.6 and all previous
Excel Version: 2007 - 2016
Location: London, UK, Europe

Re: Cube Viewer suppress zeroes hiding non-zero cells

Post by qml » Mon Jan 28, 2019 9:43 am

declanr wrote:
Sun Jan 27, 2019 5:37 pm
There is a bug that one my customers currently has, I believe they are on PA 2.0.5 but not 100% as I don’t have access to install etc in their environment.
The issue means that check feeders never shows “not fed” - I tested this with a simple a = b rule on a 2 dim cube. Again due to not having access to the install/admin side I can’t confirm it’s not a setup issue but I can’t think of any configuration that could cause it so I am assuming a bug and will go through the internal customer (large enterprise) procedures to get it logged with IBM.
Yup, we have that too. Same version, same problem. I think we already had it with 2.0.4.
Kamil Arendt

David Usherwood
Site Admin
Posts: 1375
Joined: Wed May 28, 2008 9:09 am

Re: Cube Viewer suppress zeroes hiding non-zero cells

Post by David Usherwood » Mon Jan 28, 2019 2:54 pm

Returning to @jamesbennett's problem - you should be able to identify the feeder issue by careful review of your rules and feeders.

konstantin-spb
Posts: 3
Joined: Thu Feb 20, 2014 8:42 am
OLAP Product: TM1
Version: TM1 10.2.2, PA 2.0.8
Excel Version: 2016
Location: Russia, Saint-Petersburg

Re: Cube Viewer suppress zeroes hiding non-zero cells

Post by konstantin-spb » Thu Oct 10, 2019 9:13 am

Suppose you have the right feeders...
What rules (calculations) do you use for totals? N or C?

If you use the calculation of totals (sum or percent) like this ("supress zeroes" will hide them):

Code: Select all

['Accounts{PL':'GM' , 'Measures{PL':'1'] = C:['Accounts{PL':'60'] + ['Accounts{PL':'61'];
['Accounts{PL':'GMP' ,'Measures{PL':'1'] = C:['Accounts{PL':'61'] \ ['Accounts{PL':'60'] * -1;
You can change them to like this:

Code: Select all

['Accounts{PL':'GM' , 'Measures{PL':'1'] = N:['Accounts{PL':'60'] + ['Accounts{PL':'61'];
['Accounts{PL':'GMP' ,'Measures{PL':'1'] = N:['Accounts{PL':'61'] \ ['Accounts{PL':'60'] * -1;
If these are your final totals (other totals do not depend on them), you can also change them to like this:

Code: Select all

['Accounts{PL':'GM' , 'Measures{PL':'1'] = N:0.001;  C:['Accounts{PL':'60'] + ['Accounts{PL':'61'];
['Accounts{PL':'GMP' ,'Measures{PL':'1'] = N:0.00001;C:['Accounts{PL':'61'] \ ['Accounts{PL':'60'] * -1;

Post Reply