Cryptic TM1 Messages Decoded

Ideas and tips for enhancing your TM1 application
John Hammond
Community Contributor
Posts: 262
Joined: Mon Mar 23, 2009 10:50 am
OLAP Product: TM1/PM/Cafe/Persp PAX 2.0.45
Version: 10.2 Dev PA 2.0
Excel Version: 2010 and 2013
Location: City of London

Re: Cryptic TM1 Messages Decoded

Post by John Hammond » Fri Sep 30, 2011 2:18 pm

tm1 Turbo Integrator invalid string expression

The datasource variables you are expecting to default to String ended up defaulting to Numeric normally this is the time dimension.

Obvious after the fact but can be maddening!

John Hammond
Community Contributor
Posts: 262
Joined: Mon Mar 23, 2009 10:50 am
OLAP Product: TM1/PM/Cafe/Persp PAX 2.0.45
Version: 10.2 Dev PA 2.0
Excel Version: 2010 and 2013
Location: City of London

Re: Cryptic TM1 Messages Decoded

Post by John Hammond » Tue Oct 04, 2011 12:53 pm

tm1 rules editor shows out of date copy of the rule

You are using the non advanced rules editor which uses .blb files

http://bihints.com/the_fallacy_of_blb_files

You updated the .rux file when the server was offline and because TM1 displays the .blb file ahead of the .rux REGARDLESS OF MODIFICATION STAMPS you will see an older version of the rule.

Solutions

Always use the advanced rules editor

OR

Kill all .blb files which are as useful as herpes

Dont know if this is only a problem in 90 so if anybody could elicidate...

John Hammond
Community Contributor
Posts: 262
Joined: Mon Mar 23, 2009 10:50 am
OLAP Product: TM1/PM/Cafe/Persp PAX 2.0.45
Version: 10.2 Dev PA 2.0
Excel Version: 2010 and 2013
Location: City of London

Re: Cryptic TM1 Messages Decoded

Post by John Hammond » Wed Oct 05, 2011 4:20 pm

TM1 user does not have admin rights to run TI proc suddenly

The daft apeth is double clicking which defaults to the editor. Tell the stupid mofo to right click and chose execute.

John Hammond
Community Contributor
Posts: 262
Joined: Mon Mar 23, 2009 10:50 am
OLAP Product: TM1/PM/Cafe/Persp PAX 2.0.45
Version: 10.2 Dev PA 2.0
Excel Version: 2010 and 2013
Location: City of London

Re: Cryptic TM1 Messages Decoded

Post by John Hammond » Wed Oct 12, 2011 4:24 pm

TM1 only user himself can see the updates he made

User has entered batch update mode (poss through TI failure). Tell user to log off and deal with any commit of his batch update as appropriate.

John Hammond
Community Contributor
Posts: 262
Joined: Mon Mar 23, 2009 10:50 am
OLAP Product: TM1/PM/Cafe/Persp PAX 2.0.45
Version: 10.2 Dev PA 2.0
Excel Version: 2010 and 2013
Location: City of London

Re: Cryptic TM1 Messages Decoded

Post by John Hammond » Mon Oct 17, 2011 11:11 am

Code: Select all

# Now set up the view
CubeName = CellGetS('Menu',Menu,'CubeName') ;
IF ( CubeName @<> '' ) ;
   ViewName = CellGetS('Menu',Menu,'ViewName') ;
On accidentally typing a key combination suddenly turns to:

Code: Select all

                                                                           # Now set up the view
                                     ;CubeName = CellGetS('Menu',Menu,'CubeName') 
                                                                         ; IF ( CubeName @<> '' ) 
                                     ; ViewName = CellGetS('Menu',Menu,'ViewName') 
Right click in an area of whitespace in TM1 TI editor and you will see all of the Cut and Paste Options followed by "Right to Left Reading" order. You can tick and untick this to get the effect above.

Unless you have just teleported into this universe from an analog where left and right handedness are different this is not a very useful option though I am going to ask IBOGLIX if they can also provide an option to rotate characters in the editor by 180 degrees as I regularly use glasses that reverse the image on the retina and while I am adapting both ways to wearing or not wearing these I am unable to program TI.

John Hammond
Community Contributor
Posts: 262
Joined: Mon Mar 23, 2009 10:50 am
OLAP Product: TM1/PM/Cafe/Persp PAX 2.0.45
Version: 10.2 Dev PA 2.0
Excel Version: 2010 and 2013
Location: City of London

Re: Cryptic TM1 Messages Decoded

Post by John Hammond » Mon Oct 17, 2011 12:28 pm

Cannot find dimension element containing a dash

Answer

Dash is em dash that you copied in from word or emai program - always type your dashes into TM1 directly.

User avatar
Steve Vincent
Site Admin
Posts: 1050
Joined: Mon May 12, 2008 8:33 am
OLAP Product: TM1
Version: 10.2.2 FP1
Excel Version: 2010
Location: UK

Re: Cryptic TM1 Messages Decoded

Post by Steve Vincent » Mon Oct 17, 2011 3:05 pm

John Hammond wrote:Cryptic Error

This Process is not complete and cannot be run

Real Error

You had an error that you fixed but you didn't change the code. Type a blank space in the prolog to amend the code without really amending it and this will go away.
Have also seen this when the name of a parameter clashes with the name of a variable. If you get duplicate variables TI will warn you and revert back to the original name but for some reason not related to coder ineptitude it is not able to do the sane for a variable/paramter name clash and gives you this tosh instead.
If this were a dictatorship, it would be a heck of a lot easier, just so long as I'm the dictator.
Production: TM1 64 bit 10.2.2, Windows 2008/2012 Server. Excel 2010, IE11 for t'internet

John Hammond
Community Contributor
Posts: 262
Joined: Mon Mar 23, 2009 10:50 am
OLAP Product: TM1/PM/Cafe/Persp PAX 2.0.45
Version: 10.2 Dev PA 2.0
Excel Version: 2010 and 2013
Location: City of London

Re: Cryptic TM1 Messages Decoded

Post by John Hammond » Mon Oct 24, 2011 9:20 am

Prolog line (0): Unable to open data source CubeName

One of the subsets in your view of CubeName has no elements

John Hammond
Community Contributor
Posts: 262
Joined: Mon Mar 23, 2009 10:50 am
OLAP Product: TM1/PM/Cafe/Persp PAX 2.0.45
Version: 10.2 Dev PA 2.0
Excel Version: 2010 and 2013
Location: City of London

Re: Cryptic TM1 Messages Decoded

Post by John Hammond » Mon Oct 24, 2011 5:23 pm

Cube Viewer Hierarchy expands upwards instead of downwards

You have Filter -> Sort set which is changing the order of the display

User avatar
Michel Zijlema
Site Admin
Posts: 705
Joined: Wed May 14, 2008 5:22 am
OLAP Product: TM1, PALO
Version: both 2.5 and higher
Excel Version: 2003-2007-2010
Location: Netherlands
Contact:

Re: Cryptic TM1 Messages Decoded

Post by Michel Zijlema » Mon Oct 24, 2011 5:59 pm

TI Process log displays Cell type is consolidated when it isn't.
Cause: Formula used to calculate the variable being used in CellPutN command had a forward slash for divide not a backwards slash.
See this technote.

John Hammond
Community Contributor
Posts: 262
Joined: Mon Mar 23, 2009 10:50 am
OLAP Product: TM1/PM/Cafe/Persp PAX 2.0.45
Version: 10.2 Dev PA 2.0
Excel Version: 2010 and 2013
Location: City of London

Re: Cryptic TM1 Messages Decoded

Post by John Hammond » Tue Oct 25, 2011 3:31 pm

Thanks Michael.

TM1 Feeders do not get triggered on attribute change.

Think this par for the course only data value changes to the cube where the feeder is located seem to do this. Feeder containing ATTRS statement is treated as conditional though I havent tested whether REEVALUATECONDITIONALFEEDERS works with this though it does not seem to work that well anyway...

John Hammond
Community Contributor
Posts: 262
Joined: Mon Mar 23, 2009 10:50 am
OLAP Product: TM1/PM/Cafe/Persp PAX 2.0.45
Version: 10.2 Dev PA 2.0
Excel Version: 2010 and 2013
Location: City of London

Re: Cryptic TM1 Messages Decoded

Post by John Hammond » Tue Nov 01, 2011 7:34 pm

On entering the subset editor: Failed to create document

TM1 will crash the next time you try this!

John Hammond
Community Contributor
Posts: 262
Joined: Mon Mar 23, 2009 10:50 am
OLAP Product: TM1/PM/Cafe/Persp PAX 2.0.45
Version: 10.2 Dev PA 2.0
Excel Version: 2010 and 2013
Location: City of London

Re: Cryptic TM1 Messages Decoded

Post by John Hammond » Thu Dec 08, 2011 6:40 pm

TM1 Service does not crash, but does not display and stops using CPU after acquiring 10-11Mb of memory.

You have no TM1 data directory!

Wim Gielis
MVP
Posts: 2278
Joined: Mon Dec 29, 2008 6:26 pm
OLAP Product: TM1
Version: PAL 2.0.8
Excel Version: Office 365 - latest
Location: Brussels, Belgium
Contact:

Re: Cryptic TM1 Messages Decoded

Post by Wim Gielis » Fri Dec 16, 2011 8:24 pm

TM1.Server.Network net_SetBufferAt: Attempted to set position past network buffer size. Probable client crash.

The situation:

A file with a good deal of DBRW formulas works fine (not too fast but it worked without issues).
The file had the hard-coded "server:cubename" text in a cell.

On the same physical server, a second TM1 model was created. Same TM1 versions and so on.
Most of the cubes were the same, some of them had less dimensions. We used a copy of the database directory of what we could use, and built the other parts of the application next to it.
The cube used in the spreadsheet did not change at all.
The user at the company had replaced the "server:cubename" text with a comparable VIEW function.
Using the file locally on the PC, worked fine and correctly.
Using the file through Excel in a Citrix environment: file opens and DBRW's show nothing.
Switching to the Server Explorer shows that the model is not responding and that client is crashing.
Therefore, the entry in the message log shown above. Server remains up and running.

We managed to log on again after a few minutes. Then, we deleted the 12 columns for actuals data in the GL. File worked perfectly.
We added January, worked perfectly. We added February - August, worked perfectly. We added September, did not work, same crash.
Now, September was the moment of moving to the new TM1 model, and the VIEW function.

If we take a hard-coded "server:cubename" if works nice on Citrix. With the VIEW function it did not work on Citrix for data as of September onwards.
(The same file with the VIEW function on the OLD model also works.)

Anyone knows why this would crash on Citrix while it works locally?
I'm not an expert on Citrix so probably I cannot answer questions on that specifically.
Best regards,

Wim Gielis

Excel Most Valuable Professional, 2011-2014
http://www.wimgielis.com ==> 109 TM1 articles and a lot of custom code
Newest blog article: Set up a TM1 model with AutoHotKey as a service or application

John Hammond
Community Contributor
Posts: 262
Joined: Mon Mar 23, 2009 10:50 am
OLAP Product: TM1/PM/Cafe/Persp PAX 2.0.45
Version: 10.2 Dev PA 2.0
Excel Version: 2010 and 2013
Location: City of London

Re: Cryptic TM1 Messages Decoded

Post by John Hammond » Thu Dec 22, 2011 12:12 pm

Wim I would have a look in the Citrix logs or try to minimise what the citrix session is doing (ie not have it attach your current disks and printers).

Problem: Data Directory copy stops working

Cause: You would expect that the current directory for the service process would be the TM1 data directory and this is true for 99% of the time, but some circumstances mean that the service process picks up the subdirectory of an admin.
(Note that cd does not alter the process running TM1

I dont know the why of this if anyone could shed light on this it would be much appreciated.

Solution: Short term reboot the server which restores the default path as TM1 Data Directory.

Long term: specify the full TM1 data directory ( a pain I know)

John Hammond
Community Contributor
Posts: 262
Joined: Mon Mar 23, 2009 10:50 am
OLAP Product: TM1/PM/Cafe/Persp PAX 2.0.45
Version: 10.2 Dev PA 2.0
Excel Version: 2010 and 2013
Location: City of London

Re: Cryptic TM1 Messages Decoded

Post by John Hammond » Fri Dec 30, 2011 11:22 am

TM1 Cubes showing all values as 'N/A'

Something to do with

User has entered batch update mode (poss through TI failure). Tell user to log off and deal with any commit of his batch update as appropriate by right clicking on the TM1 Server > Deferred Updates tab

John Hammond
Community Contributor
Posts: 262
Joined: Mon Mar 23, 2009 10:50 am
OLAP Product: TM1/PM/Cafe/Persp PAX 2.0.45
Version: 10.2 Dev PA 2.0
Excel Version: 2010 and 2013
Location: City of London

Re: Cryptic TM1 Messages Decoded

Post by John Hammond » Mon Jan 16, 2012 3:28 pm

User cannot select all in subset

soln: in subset editor you can choose whether or not to display a toolbar - (WTF you would want to restrict a user's view i dont know!)

Wim Gielis
MVP
Posts: 2278
Joined: Mon Dec 29, 2008 6:26 pm
OLAP Product: TM1
Version: PAL 2.0.8
Excel Version: Office 365 - latest
Location: Brussels, Belgium
Contact:

Re: Cryptic TM1 Messages Decoded

Post by Wim Gielis » Tue Jan 17, 2012 4:32 pm

client does not have write privilege on this object

When manually trying to add an attribute, even with ADMIN rights, if the dimension contains no elements.

A TI process lets you do this.

Solution: add at least 1 element to the dimension. Or use TI.
Best regards,

Wim Gielis

Excel Most Valuable Professional, 2011-2014
http://www.wimgielis.com ==> 109 TM1 articles and a lot of custom code
Newest blog article: Set up a TM1 model with AutoHotKey as a service or application

David Usherwood
Site Admin
Posts: 1377
Joined: Wed May 28, 2008 9:09 am

Re: Cryptic TM1 Messages Decoded

Post by David Usherwood » Tue Apr 03, 2012 9:30 am

Sandboxerror.png
Sandboxerror.png (4.27 KiB) Viewed 10763 times
Occurs when you use the PersonalWorkspace and run a TI process which fires lots of feeders in the sandbox and blows the sandbox size.

John Hammond
Community Contributor
Posts: 262
Joined: Mon Mar 23, 2009 10:50 am
OLAP Product: TM1/PM/Cafe/Persp PAX 2.0.45
Version: 10.2 Dev PA 2.0
Excel Version: 2010 and 2013
Location: City of London

Re: Cryptic TM1 Messages Decoded

Post by John Hammond » Thu Apr 26, 2012 4:20 pm

Rule/TI using ATTRS against an alias does not work

test is

ATTRS(DimName,!Element,'SomeAlias') @= 'Alias Value'

The test fails where the element has no Alias because in the cube it is stored as the null string whereas in the subset editor and the attribute editor it APPEARS as the alias value.

Solution

Either use a TI to actually populate the alias with the core element - this will work without complaint despite the duplication or just change the test

!Element @= 'Alias Value'

Tres Confusant!

Post Reply