Search found 110 matches

by vladino
Mon Nov 27, 2017 10:41 pm
Forum: IBM TM1, Planning Analytics, PAx and PAW
Topic: Ownership status and TM1 web / PAW / CAFE
Replies: 0
Views: 732

Ownership status and TM1 web / PAW / CAFE

Guys, I have an approval app and take the ownership for one planning unit (via TM1 applications web). So this means that no one has write access to that planning unit for all cubes within this app which use approval dim/hierarchy. But what about TM1 web / PAW books / CAFE sheets? It seems to me that...
by vladino
Mon Nov 27, 2017 6:44 am
Forum: IBM TM1, Planning Analytics, PAx and PAW
Topic: Commented SKIPCHECK causing cube load errors and stack overflow?
Replies: 1
Views: 636

Commented SKIPCHECK causing cube load errors and stack overflow?

Hi guys, we have commented out SKIPCHECK on one of our cubes. I know this is not the best approach but as we are unable to use feeders and we need to calculate ConsolidatedAvg values on hierarchy nodes we can't use feeders at all. Is it possible that this is causing "Unable to load cube" in TM1 apps...
by vladino
Thu Nov 23, 2017 11:12 pm
Forum: IBM TM1, Planning Analytics, PAx and PAW
Topic: ConsolidatedAvg without feeders
Replies: 0
Views: 724

ConsolidatedAvg without feeders

Guys, I need to get an average on a consolidated member for a calculated measure. I can definitely use ConsolidatedAvg, that's for sure. But there is one showstopper here - the calculated measure is not fed. :-/ So the ConsolidatedAvg function doesn't work... For the time dimension i can easily do a...
by vladino
Thu Nov 23, 2017 12:24 am
Forum: IBM TM1, Planning Analytics, PAx and PAW
Topic: TM1 cube not showing data in Analysis/Report studio
Replies: 6
Views: 1822

Re: TM1 cube not showing data in Analysis/Report studio

Hi guys, thanks a lot for your replies! The reason why there are no feeders for this cube is quite complex model which implicates huge feeders. That's why we are calculating also C-level (either by using a formula or by ConsolidateChildren). So the data is there and even after suppressing zeros in T...
by vladino
Wed Nov 22, 2017 11:26 am
Forum: IBM TM1, Planning Analytics, PAx and PAW
Topic: TM1 cube not showing data in Analysis/Report studio
Replies: 6
Views: 1822

TM1 cube not showing data in Analysis/Report studio

Hi guys, we have a reporting cube in TM1 model that we would like to use in Analysis studio and Report studio. In Performance modeler we can see all data, including calculated cells. However, in Analysis studio and Report studio there is no data! Does anyone have any idea why this is happening? Coul...
by vladino
Sun Oct 29, 2017 5:29 pm
Forum: IBM TM1, Planning Analytics, PAx and PAW
Topic: Can feeders delete data from the cube!?!?!?
Replies: 2
Views: 808

Re: Can feeders delete data from the cube!?!?!?

Hi, thanks a lot for your reply! Yes, it sound like the same bug - actually those cells might be overfed. But I have discovered that if I remove MT* params from the CFG file and leave only MaximumCubeLoadThreads then it works even after restart. What should I do now? Should I report this as a potent...
by vladino
Sun Oct 29, 2017 12:28 am
Forum: IBM TM1, Planning Analytics, PAx and PAW
Topic: Can feeders delete data from the cube!?!?!?
Replies: 2
Views: 808

Can feeders delete data from the cube!?!?!?

Hello guys, I know that the basic answer to my question is "NO at all!". But I'm experiencing a bit different behavior right now... We just have upgraded to the latest PAL version which is 2.0.3. I'm not sure it this might be the reason... First of all, let me summarize the basics of the model which...
by vladino
Wed Aug 30, 2017 8:27 pm
Forum: IBM TM1, Planning Analytics, PAx and PAW
Topic: Unable to write to two WRITE members on control dim
Replies: 2
Views: 779

Re: Unable to write to two WRITE members on control dim

Hi, ok, it seems I haven't explained the situation very well... When you say your version dim is a 'control' dim do you simply mean its name is prefixed with the '}' character or do you mean it's actually one of TM1's pre-existing control dimensions? By "control dimension" I mean this: https://www.i...
by vladino
Tue Aug 29, 2017 5:49 am
Forum: IBM TM1, Planning Analytics, PAx and PAW
Topic: Unable to write to two WRITE members on control dim
Replies: 2
Views: 779

Unable to write to two WRITE members on control dim

Hi guys, we are experiencing a bit weird behavior on our TM1 application with control dim. We have an application with Version dim as a control dim. Two members are set to WRITE but users are able to write only to the second one in the list. The first remain in read-only mode even if the group has W...
by vladino
Fri Jun 16, 2017 9:23 am
Forum: IBM TM1, Planning Analytics, PAx and PAW
Topic: DimensionDeleteAllElements failover
Replies: 14
Views: 3521

DimensionDeleteAllElements failover

Hi guys, I'm using DimensionDeleteAllElements in Prolog and then re-create some of elements back in Metadata to preserve the data. But what if there's something wrong in Metadata and the script fails? Is my entire dimension (and the data) gone forever? If yes - is there any way how to avoid this? BR...
by vladino
Tue May 09, 2017 7:15 am
Forum: IBM TM1, Planning Analytics, PAx and PAW
Topic: SubsetAliasSet weird behavior
Replies: 4
Views: 1404

Re: SubsetAliasSet weird behavior

Wim Gielis wrote:What about restarting the model ?
Ahh, I forgot to use the easiest way how to fix most problems... After restarting the TM1 instance is works. :)

Thanks Wim!
by vladino
Fri May 05, 2017 10:12 am
Forum: IBM TM1, Planning Analytics, PAx and PAW
Topic: SubsetAliasSet weird behavior
Replies: 4
Views: 1404

Re: SubsetAliasSet weird behavior

Hi Wim, Are you sure that the objects exist ? What does SubsetExists( ... ) give you ? DimensionExists( ... ) ? Dimix( '}ElementAttributes_Dimension', 'Alias' ) ? Dtype( '}ElementAttributes_Dimension', 'Alias' ) ? Yes, the objects exist - SubsetExists returns 1, DimensionExists also returns 1. Dimix...
by vladino
Fri May 05, 2017 12:57 am
Forum: IBM TM1, Planning Analytics, PAx and PAW
Topic: SubsetAliasSet weird behavior
Replies: 4
Views: 1404

SubsetAliasSet weird behavior

Hi guys, I'm getting really strange behavior of SubsetAliasSet TI function. I have created a new dynamic subset (it doesn't matter if it's been created within TI process or manually). Now I would like to set the alias for the subset using SubsetAliasSet. When I use following code: SubsetAliasSet('Di...
by vladino
Wed Apr 05, 2017 9:25 pm
Forum: IBM TM1, Planning Analytics, PAx and PAW
Topic: Conditional feeders with attributes
Replies: 5
Views: 1702

Conditional feeders with attributes

Hi guys, I don't think I have discovered a wheel but I just wanted to share (and hopefully confirm) my thoughts... We are using conditional feeders for some specific things such as feeding budget versions with actuals only for specific periods of time, feeding only specific measures etc. I know that...
by vladino
Thu Mar 23, 2017 11:04 pm
Forum: IBM TM1, Planning Analytics, PAx and PAW
Topic: Copy version performance
Replies: 15
Views: 4522

Re: Copy version performance

- why are you using Bedrock.Cube.View.Create followed by Bedrock.Cube.Data.ViewExportToFile instead of Bedrock.Cube.Data.Export which would do the same work in one process? The reason is quite simple - Bedrock.Cube.Data.Export does not allow you to skip zero values - how large are some of the data ...
by vladino
Thu Mar 23, 2017 10:58 pm
Forum: IBM TM1, Planning Analytics, PAx and PAW
Topic: Copy version performance
Replies: 15
Views: 4522

Re: Copy version performance

What's in the message log and what happens when you run it for a single cube? It depends for which cube it's running... Some cubes are processed really quick but some cubes takes hours to complete. Some cubes generate "stack overflow" error in the log and it states "process terminated". But I'm not...
by vladino
Thu Mar 23, 2017 6:30 pm
Forum: IBM TM1, Planning Analytics, PAx and PAW
Topic: Copy version performance
Replies: 15
Views: 4522

Re: Copy version performance

It sounds like you are probably exporting a bunch of data points that are calculated via rules, instead of being raw data. If this is the case then TM1 must calculate those data points and this takes up cache. It's likely that by exporting the cube you have exceeded the allowed memory cache for the...
by vladino
Thu Mar 23, 2017 6:28 pm
Forum: IBM TM1, Planning Analytics, PAx and PAW
Topic: Copy version performance
Replies: 15
Views: 4522

Re: Copy version performance

You'll get a far better response if you post the code vCubeList = '}Cubes'; vNumCubes = DIMSIZ(vCubeList); vVersionDim = 'Version'; i = 0; While ( i < vNumCubes ); i = i + 1; j = 0; x = 0; sCubeName = DIMNM(vCubeList, i); If ( SUBST(sCubeName, 1, 1) @<> '}' ); sDim = TABDIM(sCubeName, j + 1); While...
by vladino
Thu Mar 23, 2017 2:56 pm
Forum: IBM TM1, Planning Analytics, PAx and PAW
Topic: Copy version performance
Replies: 15
Views: 4522

Re: Copy version performance

I don't use Bedrock but are you sure the views you are creating for the data source are zero-suppressed? Also, you really do need to turn off logging. Logging the transactions for a version copy is silly. Where would you ever need it? If the process goes wrong you just re-run it instead of trying t...
by vladino
Thu Mar 23, 2017 6:48 am
Forum: IBM TM1, Planning Analytics, PAx and PAW
Topic: Copy version performance
Replies: 15
Views: 4522

Copy version performance

Hi guys, I have created a process for copying version. The process takes all cubes that contain version dim, exports its data into file and then imports this file into another version. The script is leveraging Bedrock library (export source version - clear target version - import into target version...