Search found 619 matches

by macsir
Tue Jun 25, 2019 5:30 am
Forum: IBM TM1, Planning Analytics, PAx and PAW
Topic: Programmatically Update Websheets to TM1 Web
Replies: 14
Views: 2839

Re: Programmatically Update Websheets to TM1 Web

Just want to share, with REST API, it is possible now.
It can GET(download) and PATCH(update) now at least in 10.2.2 FP7.
by macsir
Mon Jun 24, 2019 10:49 pm
Forum: IBM TM1, Planning Analytics, PAx and PAW
Topic: Slow Login in Architect
Replies: 17
Views: 458

Re: Slow Login in Architect

Do you use SSL? If so, between which components? Is BI and TM1 installed on the same server? Is TM1 installed on one or multiple servers? Do you have any anti-virus on the servers? Would it be possible for you to test with native login once to see if you still if its still slow? 1.Yes, UseSSL=T but...
by macsir
Thu Jun 20, 2019 8:00 pm
Forum: IBM TM1, Planning Analytics, PAx and PAW
Topic: Slow Login in Architect
Replies: 17
Views: 458

Re: Slow Login in Architect

There should be "CAM_LPSvr.exe" processes. Do they consume CPU during slow user connections? It can consume the whole core (for example, 25% in 4-core processor). If so, try to kill it in Task manager. Cognos will recreate new, if it needs. And the most obvious (sorry if I didn't find this above ;)...
by macsir
Wed Jun 19, 2019 8:05 pm
Forum: IBM TM1, Planning Analytics, PAx and PAW
Topic: Slow Login in Architect
Replies: 17
Views: 458

Re: Slow Login in Architect

Hi, When you log in to TM1 with ISM=5, TM1 checks CAM client*group mapping (and adds new client if any). This can be reason How many groups do you have in TM1? How many groups does the "slow" user belong to? Do you have any rules in }Clientgroups cube? Any feeders from it? Does the problem affect a...
by macsir
Wed Jun 19, 2019 3:54 am
Forum: IBM TM1, Planning Analytics, PAx and PAW
Topic: Slow Login in Architect
Replies: 17
Views: 458

Re: Slow Login in Architect

Just want to share, The login duration was slowed down to around 20 seconds and I checked the DEBUG server log. There is no ERROR or WARNING at all. Compared to a login from fresh reboot, the log is showing more 105416 [] DEBUG 2019-06-19 05:59:55.385 TM1.Event mt_WaitForMultipleObjects: Timed out. ...
by macsir
Tue Jun 11, 2019 11:52 pm
Forum: IBM TM1, Planning Analytics, PAx and PAW
Topic: Slow Login in Architect
Replies: 17
Views: 458

Re: Slow Login in Architect

Anything suspicious in your tm1admsrv log files? May be worthwhile adding some additional loggers in your tm1s-log.properties to see if there is anything untoward going on e.g. log4j.logger.TM1.Server.Network=DEBUG, STATS log4j.appender.STATS=org.apache.log4j.SharedMemoryAppender log4j.appender.STA...
by macsir
Mon Jun 10, 2019 8:56 pm
Forum: IBM TM1, Planning Analytics, PAx and PAW
Topic: Slow Login in Architect
Replies: 17
Views: 458

Re: Slow Login in Architect

By the way, TM1 web was also slow when I had the issue. Now it takes around 15 seconds to show applications and views after open the URL in Chrome.
by macsir
Mon Jun 10, 2019 8:55 pm
Forum: IBM TM1, Planning Analytics, PAx and PAW
Topic: Slow Login in Architect
Replies: 17
Views: 458

Re: Slow Login in Architect

Once you are logged in are there further issues or is it only login that sees the delays? Do you have access to Cognos BI Security to see if anything odd is occuring at that end? My guess would be that the 'normal' identifiers for TM1 are clear so it could be a BI related issue? Thanks, no further ...
by macsir
Fri Jun 07, 2019 10:05 pm
Forum: IBM TM1, Planning Analytics, PAx and PAW
Topic: Slow Login in Architect
Replies: 17
Views: 458

Re: Slow Login in Architect

gtonkin wrote:
Fri Jun 07, 2019 4:18 pm
Is there a difference when you use the server name vs the IP address? Have had numerous issues when the DNS is fritzed - it takes forever to connect the dots.
I tried using IP in architect. No difference and still slow. Thanks
by macsir
Fri Jun 07, 2019 10:04 pm
Forum: IBM TM1, Planning Analytics, PAx and PAW
Topic: Slow Login in Architect
Replies: 17
Views: 458

Re: Slow Login in Architect

Edward Stuart wrote:
Fri Jun 07, 2019 1:31 pm
Which IntegratedSecurityMode are you using and are you using single sign on etc..?
Cam security mode 5 with sso. The cognos is installed on same server where TM1 is. Thanks.
by macsir
Fri Jun 07, 2019 12:14 pm
Forum: IBM TM1, Planning Analytics, PAx and PAW
Topic: Slow Login in Architect
Replies: 17
Views: 458

Slow Login in Architect

Tm1 10.2.2 fp7 I noticed that for around two weeks, it will sometimes become very slow to login from Architect or Perspectives or Web. The Architect I was testing just sits on the TM1 server itself. Thus there shouldn't be any network issue. After a reboot, the duration of login went back to normal ...
by macsir
Mon Jun 03, 2019 8:04 pm
Forum: IBM TM1, Planning Analytics, PAx and PAW
Topic: Planning Analytics - TM1 - Security
Replies: 5
Views: 182

Re: Planning Analytics - TM1 - Security

Did you refresh security after changing?
by macsir
Mon Jun 03, 2019 5:47 am
Forum: IBM TM1, Planning Analytics, PAx and PAW
Topic: Examples of GET/DELETE/PATCH applications in REST
Replies: 0
Views: 69

Examples of GET/DELETE/PATCH applications in REST

Hi, all Not sure if anyone is interested in examples of GET/DELETE/PATCH applications in REST, but I would like to share test.xlsx is an application under Tests folder, To GET an application (just dump the binary file and rename it as xlsx, you can open it in Excel) https://URL/api/v1/Contents('Appl...
by macsir
Sun Jun 02, 2019 8:19 pm
Forum: IBM TM1, Planning Analytics, PAx and PAW
Topic: RunTI Issue
Replies: 11
Views: 414

Re: RunTI Issue

How about triggering your TI via "tm1.ExecuteWithReturn" functions in rest api?
by macsir
Mon May 20, 2019 8:58 pm
Forum: IBM TM1, Planning Analytics, PAx and PAW
Topic: RulesOverwriteCellsOnLoad is NOT working
Replies: 10
Views: 354

Re: RulesOverwriteCellsOnLoad is NOT working

I found my root cause now. It is because of PersistentFeeders. I have that enabled and obviously, after disabling, RulsOverwriteCellsOnLoad works as expected. :D That's interesting. RulsOverwriteCellsOnLoad should be independent of PersistentFeeders! That this doesn't work when PersistentFeeders is...
by macsir
Mon May 20, 2019 3:51 am
Forum: IBM TM1, Planning Analytics, PAx and PAW
Topic: RulesOverwriteCellsOnLoad is NOT working
Replies: 10
Views: 354

Re: RulesOverwriteCellsOnLoad is NOT working

I have read the documentation and I understand its name as shown in the picture below. Another question that I found an interesting feature is that it is marked with the third option. I suppose this is updated with the update of the cube and in combat situations it will lead you according to the do...
by macsir
Wed May 15, 2019 11:54 pm
Forum: IBM TM1, Planning Analytics, PAx and PAW
Topic: RulesOverwriteCellsOnLoad is NOT working
Replies: 10
Views: 354

Re: RulesOverwriteCellsOnLoad is NOT working

and those two original values "1" and "2" are still there
555.PNG
555.PNG (2.95 KiB) Viewed 269 times
What's wrong here???
by macsir
Wed May 15, 2019 11:53 pm
Forum: IBM TM1, Planning Analytics, PAx and PAW
Topic: RulesOverwriteCellsOnLoad is NOT working
Replies: 10
Views: 354

Re: RulesOverwriteCellsOnLoad is NOT working

TM1SERVER_APP_version=TM1SERVER_APP-AW64-ML-RTM-11.0.6.71-0 WORKED FINE. write some data in cube. append on this slice rule savedataall restart. RulesOverwriteCellsOnLoad=F data save after disable rule RulesOverwriteCellsOnLoad=T data loss after disable rule hi, Drg I have same version as yours but...
by macsir
Fri May 03, 2019 5:03 am
Forum: IBM TM1, Planning Analytics, PAx and PAW
Topic: RulesOverwriteCellsOnLoad is NOT working
Replies: 10
Views: 354

Re: RulesOverwriteCellsOnLoad is NOT working

I can confirm same situation on PAL 2.0.6. Has anyone really got this parameter working as expected?