Upcoming server migration

Not related to a specific OLAP tool. (Includes forum policies and rules).
Post Reply
User avatar
Martin Ryan
Site Admin
Posts: 1941
Joined: Sat May 10, 2008 9:08 am
OLAP Product: TM1
Version: 10.1
Excel Version: 2010
Location: Wellington, New Zealand
Contact:

Upcoming server migration

Post by Martin Ryan » Thu Jun 22, 2017 8:04 am

Just to let you know that I'll be moving the forum to a new server in the next few weeks. Not quite sure when, depends on availability. I'll post on the forum Twitter and Facebook accounts before I start so if you find the forum's disappeared check there if that's the reason.

I'm hoping to do it in one evening, but it might take a couple as I'll try to squeeze the forum software upgrade in there too.
Please do not send technical questions via private message or email. Post them in the forum where you'll probably get a faster reply, and everyone can benefit from the answers.
Jodi Ryan Family Lawyer

User avatar
Martin Ryan
Site Admin
Posts: 1941
Joined: Sat May 10, 2008 9:08 am
OLAP Product: TM1
Version: 10.1
Excel Version: 2010
Location: Wellington, New Zealand
Contact:

Re: Upcoming server migration

Post by Martin Ryan » Mon Jul 17, 2017 8:52 am

Seems to have gone successfully this time. Welcome to the new digs. This server is now based in the States, Seattle I think, so might be a bit faster for the top half of the world(?)

I've also upgraded the forum version hence the slightly update skin. Let me know if you spot anything funny.

I've still got to get the advertising working again and also the emails - I don't think they come through automatically after an update.
Please do not send technical questions via private message or email. Post them in the forum where you'll probably get a faster reply, and everyone can benefit from the answers.
Jodi Ryan Family Lawyer

Paul Segal
Community Contributor
Posts: 228
Joined: Mon May 12, 2008 8:11 am
OLAP Product: TM1
Version: 10.2.2
Excel Version: 2010

Re: Upcoming server migration

Post by Paul Segal » Tue Jul 18, 2017 9:26 am

Hi Martin,

Advertising seems to be working, but I don't appear to be getting emails from the forum. Not that there's a rush...

While I'm here, thanks for the work and effort you put into this.

Best

Paul
Paul

User avatar
Martin Ryan
Site Admin
Posts: 1941
Joined: Sat May 10, 2008 9:08 am
OLAP Product: TM1
Version: 10.1
Excel Version: 2010
Location: Wellington, New Zealand
Contact:

Re: Upcoming server migration

Post by Martin Ryan » Wed Jul 19, 2017 9:38 am

I just had another crack at the emails, but I keep coming up against brick walls. I won't be able to get to it tomorrow either so hopefully will get to it over the weekend.
Please do not send technical questions via private message or email. Post them in the forum where you'll probably get a faster reply, and everyone can benefit from the answers.
Jodi Ryan Family Lawyer

Wim Gielis
MVP
Posts: 1522
Joined: Mon Dec 29, 2008 6:26 pm
OLAP Product: TM1
Version: PAL 2.0
Excel Version: 2016
Location: Brussels, Belgium
Contact:

Re: Upcoming server migration

Post by Wim Gielis » Thu Jul 20, 2017 11:43 pm

Thank you Martin
Best regards,

Wim Gielis

Excel Most Valuable Professional, 2011-2014
http://www.wimgielis.com ==> 103 TM1 articles and a lot of custom code
Newest blog article: TM1 message log analysis with Power Query

User avatar
jim wood
Site Admin
Posts: 3480
Joined: Wed May 14, 2008 1:51 pm
OLAP Product: TM1
Version: TM1 10.2.2
Excel Version: 2007
Location: 1639 Route 10, Suite 107, Parsippany, NJ, USA
Contact:

Re: Upcoming server migration

Post by jim wood » Fri Jul 21, 2017 1:00 pm

Martin Ryan wrote:
Wed Jul 19, 2017 9:38 am
I just had another crack at the emails, but I keep coming up against brick walls. I won't be able to get to it tomorrow either so hopefully will get to it over the weekend.
Martin,

Is it a port issue?

Jim.
Struggling through the quagmire of life to reach the other side of who knows where.
Application Consulting Group (ACG) TM1 Consulting
OS: Windows 7 64-bit. TM1 Version: 10.1.1

User avatar
Martin Ryan
Site Admin
Posts: 1941
Joined: Sat May 10, 2008 9:08 am
OLAP Product: TM1
Version: 10.1
Excel Version: 2010
Location: Wellington, New Zealand
Contact:

Re: Upcoming server migration

Post by Martin Ryan » Sun Jul 23, 2017 8:48 am

Don't think so. Still having trouble. Any Linux gurus out there who want to give me a hand? Send me a PM.
Please do not send technical questions via private message or email. Post them in the forum where you'll probably get a faster reply, and everyone can benefit from the answers.
Jodi Ryan Family Lawyer

User avatar
Martin Ryan
Site Admin
Posts: 1941
Joined: Sat May 10, 2008 9:08 am
OLAP Product: TM1
Version: 10.1
Excel Version: 2010
Location: Wellington, New Zealand
Contact:

Re: Upcoming server migration

Post by Martin Ryan » Wed Jul 26, 2017 9:48 am

Progress! You were right Jim, it was a port issue. Turns out the VM provider was blocking 25. I've got it opened up and can now send emails from the server.

It's still not quite configured right for the forum. You might get some emails, but they'll be the useless ones telling you there's a new post, but not what's in it. And there'll only be one until you revisit the site.

I'm done for the night, will come back to it another evening.
Please do not send technical questions via private message or email. Post them in the forum where you'll probably get a faster reply, and everyone can benefit from the answers.
Jodi Ryan Family Lawyer

User avatar
jim wood
Site Admin
Posts: 3480
Joined: Wed May 14, 2008 1:51 pm
OLAP Product: TM1
Version: TM1 10.2.2
Excel Version: 2007
Location: 1639 Route 10, Suite 107, Parsippany, NJ, USA
Contact:

Re: Upcoming server migration

Post by jim wood » Wed Jul 26, 2017 11:57 am

Fantastic news!!!! Well done Martin. We're all busy and I know you're even more busy. You know we (the admins) appreciate this and the hard work you put in to the migration. I just hope the wider community appreciates it as well.
Struggling through the quagmire of life to reach the other side of who knows where.
Application Consulting Group (ACG) TM1 Consulting
OS: Windows 7 64-bit. TM1 Version: 10.1.1

User avatar
gtonkin
MVP
Posts: 500
Joined: Thu May 06, 2010 3:03 pm
OLAP Product: TM1
Version: PAL 2.0.1
Excel Version: 2016 64-bit
Location: JHB, South Africa
Contact:

Re: Upcoming server migration

Post by gtonkin » Wed Jul 26, 2017 12:02 pm

I for one appreciate having this forum available to me. Thanks Martin and everyone else who keep it running smoothly.

lotsaram
MVP
Posts: 2989
Joined: Fri Mar 13, 2009 11:14 am
OLAP Product: TM1, CX
Version: TM1 10.2.2 PA 2.0x
Excel Version: 2010 2013 365
Location: Switzerland

Re: Upcoming server migration

Post by lotsaram » Wed Jul 26, 2017 2:51 pm

Email notifications working again :D
Please place all requests for help in a public thread. I will not answer PMs requesting assistance.

User avatar
gtonkin
MVP
Posts: 500
Joined: Thu May 06, 2010 3:03 pm
OLAP Product: TM1
Version: PAL 2.0.1
Excel Version: 2016 64-bit
Location: JHB, South Africa
Contact:

Re: Upcoming server migration

Post by gtonkin » Wed Jul 26, 2017 3:02 pm

I am receiving emails but it looks like there is a setting to be tweaked as I receive:
Hello gtonkin,

You are receiving this notification because you are watching the topic "Upcoming server migration" at "TM1 Forum". This topic has received a reply by lotsaram since your last visit. No more notifications will be sent until you visit the topic.
Previously I would receive something like:
mce said:
I observed the same problem there in Cube viewer. Copy and Paste takes ages...
Version: Planning Analytics Local 2.0...then the links
Edit:sorry hit submit rather than preview

User avatar
Martin Ryan
Site Admin
Posts: 1941
Joined: Sat May 10, 2008 9:08 am
OLAP Product: TM1
Version: 10.1
Excel Version: 2010
Location: Wellington, New Zealand
Contact:

Re: Upcoming server migration

Post by Martin Ryan » Thu Jul 27, 2017 2:25 am

Thanks for the thanks - it's usually quite fun messing about in Ubuntu, it's a nice change of scenery from data. Annoying when a snag like this comes up though.
gtonkin wrote:
Wed Jul 26, 2017 3:02 pm
I am receiving emails but it looks like there is a setting to be tweaked as I receive:
Yep, this is the default email approach. Unfortunately it's not simply a setting. I have to find and edit the appropriate source php files. Been a while since I've done it - IIRC the hard part was finding the right php file. The editing isn't overly difficult. I've still got the source code from the old server so hopefully can do a bit of copy and paste.
Please do not send technical questions via private message or email. Post them in the forum where you'll probably get a faster reply, and everyone can benefit from the answers.
Jodi Ryan Family Lawyer

User avatar
Martin Ryan
Site Admin
Posts: 1941
Joined: Sat May 10, 2008 9:08 am
OLAP Product: TM1
Version: 10.1
Excel Version: 2010
Location: Wellington, New Zealand
Contact:

Re: Upcoming server migration

Post by Martin Ryan » Thu Aug 17, 2017 12:53 am

Just an update to say that I haven't forgotten about fixing the email notifications to do what they used to do. I've just been very short of time in the evenings of late. No end in sight to that at this stage, but it's on my radar to finish this job.
Please do not send technical questions via private message or email. Post them in the forum where you'll probably get a faster reply, and everyone can benefit from the answers.
Jodi Ryan Family Lawyer

User avatar
gtonkin
MVP
Posts: 500
Joined: Thu May 06, 2010 3:03 pm
OLAP Product: TM1
Version: PAL 2.0.1
Excel Version: 2016 64-bit
Location: JHB, South Africa
Contact:

Re: Upcoming server migration

Post by gtonkin » Thu Aug 17, 2017 1:03 pm

HI Martin- saw this link Re: having email notification contain post body? Not sure if you have all the details on what to change but thought I would post in case you don't have them to hand.

User avatar
Martin Ryan
Site Admin
Posts: 1941
Joined: Sat May 10, 2008 9:08 am
OLAP Product: TM1
Version: 10.1
Excel Version: 2010
Location: Wellington, New Zealand
Contact:

Re: Upcoming server migration

Post by Martin Ryan » Mon Aug 28, 2017 8:58 pm

I've got the body of the email working now, but it currently will still only send you an email once and then won't send you another until you've visited the forum. Fixing that is next on the to-do list.
Please do not send technical questions via private message or email. Post them in the forum where you'll probably get a faster reply, and everyone can benefit from the answers.
Jodi Ryan Family Lawyer

Post Reply