Executive Viewer does not refresh display

Post Reply
lgmax
Posts: 2
Joined: Fri Jul 11, 2014 8:38 am
OLAP Product: Executive Viewer
Version: 5.2
Excel Version: 2010

Executive Viewer does not refresh display

Post by lgmax » Fri Jul 11, 2014 9:10 am

Hi, we have an existing application which uses Executive Viewer 5.2 (a very old version, I know) with Microsoft Analysis Services 2005. Recently we have been experiencing issues with data display in EV wherein it is not refreshing. For example, we originally have entry "1-234 ABC". This was then updated recently updated in the database to "1-234 DEF". We then refresh the cubes in MSAS, and it is reflecting correctly from there. But when we go to EV, it still reflects "1-234 ABC". This is an intermittent issue we have been experiencing, and so far our solution is to restart the Cognos TM1 Executive Viewer Service. Question is, is there any caching happening in EV? And does anyone know any solution for this besides restarting the service?

Thomas Gerblich
Posts: 2
Joined: Thu Jul 31, 2014 1:01 pm
OLAP Product: cubus EV, TM1, SSAS, Essbase
Version: 7.4.x 11.x 10.2 2005-2012
Excel Version: 2003-2013
Location: Germany
Contact:

Re: Executive Viewer does not refresh display

Post by Thomas Gerblich » Fri Aug 01, 2014 7:54 am

Hi lgmax,

EV is caching the MSAS structures (and even roles) internally.
Usually this cache is cleared when all open client connections are closed, but sometimes this doesn't work properly which could cause your issue as the cache will remain “forever”.

To force this ensure that your MSAS cube has an updated last schema update (check the properties within the sql server management studio).

If EV recognizes that this date is newer than the internal cache (even if it remained like described above) it will renew the cache and the users will get the new structure after reloading the view.

Let me know if you need further assistance on this one.

Best Regards
Thomas

User avatar
jim wood
Site Admin
Posts: 3600
Joined: Wed May 14, 2008 1:51 pm
OLAP Product: TM1
Version: TM1 10.2.2
Excel Version: 2007
Location: 1639 Route 10, Suite 107, Parsippany, NJ, USA
Contact:

Re: Executive Viewer does not refresh display

Post by jim wood » Fri Aug 01, 2014 12:01 pm

Post moved from the TM1 forum to the MS Analysis Services forum,

Admin Team.
Struggling through the quagmire of life to reach the other side of who knows where.
Application Consulting Group (ACG) TM1 Consulting
OS: Windows 10 64-bit. TM1 Version: 10.2.2

lgmax
Posts: 2
Joined: Fri Jul 11, 2014 8:38 am
OLAP Product: Executive Viewer
Version: 5.2
Excel Version: 2010

Re: Executive Viewer does not refresh display

Post by lgmax » Wed Aug 20, 2014 8:13 am

Hi Thomas,

Thank you for your reply.

I just want to check with you. In MSAS properties, I can see 3 dates:
1. Last Schema Update
2. Last Update
3. Last Processed

Do we really have to change the "Last Schema Update" date? Because I think this date will only get updated if I change anything in the Schema, and we do not have any changes for the Schema. It is only the "Last Processed" date that gets updated when we refresh/process the cubes daily.

Hope you can help me on this.

Best regards,
lgmax

Thomas Gerblich
Posts: 2
Joined: Thu Jul 31, 2014 1:01 pm
OLAP Product: cubus EV, TM1, SSAS, Essbase
Version: 7.4.x 11.x 10.2 2005-2012
Excel Version: 2003-2013
Location: Germany
Contact:

Re: Executive Viewer does not refresh display

Post by Thomas Gerblich » Mon Sep 01, 2014 8:21 am

Hi lgmax,

sorry for the late reply.

Right now this the last schema update is the only way to force EV to update the structures automatically without restarting the service.
This is going to be changed in cubus EV in an upcoming release.

Best Regards
Thomas

Post Reply