Page 1 of 1

Unable to connect to TM1 cube from different Cognos BI env

Posted: Tue Jun 05, 2012 7:22 pm
by Gene
Hi folks,

Can anybody tell me if there is a way to create a Connection within Cognos BI environment to a Cognos TM1 cube which is running in a separate server configuration?

More specifically:
I run a "departmental" Cognos BI installation that has Cognos Connection BI server, gateway, dispatcher, app server, etc. It authenticates users & groups against a corporate LDAP directory (i.e. an external namespace).

I would like to be able to run Cognos Query/Report Studio against a TM1 cube that is owned/maintained by another corporate organization. Although that TM1 cube installation authenticates users against the same corporate LDAP directory, the server infrastructure (app server, dispatcher, app server, security) is completely separate from mine.

Up until now, all external connections from my Cognos BI system have been to relational databases. Thus I created a bunch of signons that specify userid/password that are used for successful connections.

However when I create a new "IBM Cognos TM1" connection within Cognos Administration, no matter what I try, the test connection fails with a message:

http://mydispatcher:9300/p2pd IBM Cognos TM1 / Dynamic Failed XQE-DS-0006 Unable to logon to the data source.

Creating a signon or typing in my userid/password doesn't work either. The following connection string is shown by Cognos Administrator:

^User ID:^?Password:;LOCAL;TM;;TM1ServerName=MYSERVER;UID=%s;PWD=%s

So for some reason the userid/password combo used in Cognos BI 10.1 connection is not being passed correctly to TM1 9.5.2. Perhaps the name of the TM1 "namespace" has to be passed as part of connection string? Something else?

I know that my userid/password combination is correct because I can connect fine to TM1 from within Excel TM1 add-in which pops up the authentication window shown in the attachment.

Are there any changes I can make to my Cognos BI system to allow my namespace/userid/password to be passed successfully to remote TM1? If possible, I would like to avoid asking admins of the corporate TM1 system to make changes to their system.

Re: Unable to connect to TM1 cube from different Cognos BI e

Posted: Wed Jun 06, 2012 2:28 pm
by rkaif
You need to check the settings in the Cognos Connection. Or would be nice if you can share the screenshots from the Cognos connection.

More info on setting up TM1 Data sources on Cognos is explained here: ... ognos-8-bi

and ... nosbi.html

Re: Unable to connect to TM1 cube from different Cognos BI e

Posted: Wed Jun 06, 2012 5:21 pm
by Gene
Thanks, but I am not sure I got the answer from the posted URLs.

The first one seems to deal with the case where TM1 and other Cognos BI applications are all in the same Cognos BI "instance".

In my case TM1 server is hosted in a different/separate BI "instance".

The attached snapshot shows the connection page that I created in my Cognos Connections.

Re: Unable to connect to TM1 cube from different Cognos BI e

Posted: Tue Jan 08, 2013 7:04 am
by sypkens

I have the same issue i.e. multiple BI environments, Dispatchers, Content Managers. Does anybody I have any suggestions for making a TM1 datasource logon work through multiple CM's and using CAM Security?



Re: Unable to connect to TM1 cube from different Cognos BI e

Posted: Wed Jan 09, 2013 2:20 am
by PlanningDev
Have you installed the TM1 Client on the dispatchers in the other environment? I have multiple BI instances connected to the same TM1 Server. One setup is multi server the other is single server and TM1 is standalone.

If you have the TM1 client installed on your dispatchers then I would start checking the network ports to make sure they aren't blocked

Re: Unable to connect to TM1 cube from different Cognos BI e

Posted: Thu Jan 10, 2013 12:44 am
by sypkens
Hi PlanningDev

No I have not installed the TM1 client on every dispatcher. I installed it on the Content Manager in every instance and then only used that box to test the connection (which tested successfully depending on how I configured ServerCAMURI). Are you definitely using CAM Security in your TM1 models (i.e. IntegratedSecurity = 5)? If so what did you set your ServerCAMURI and ClientCAMURI to which environment? If you are using TM1 security that will explain why it is working.

I tried yesterday to see if I could set multiple connections of the ServerCAMURI and and also ClientCamURI. Whichever the last line in the TM1s.cfg was the connection it would use and then the connection was also working fine from that instance's Cognos Connection. The other instance would then error out on testing the connection. From my testing it would seem that IBM is not supporting coming in from multiple Cognos Connection instances even though they share the same Authentication Provider. I even tried ; separation and that did not work either.

I suspect I will have to set one instance as the main connection URI. The issue for me with this approach is the fact that the main instance will not be a contributor instance i.e. I don't control / Administer this particular instance (it is predominantly used for reporting) and hence I will not be able to install contributor on it. It limits the ability to deploy Contributor Apps from this particular appplication then.

The easiest fix for this would be to have a central approach to TM1 and BI (There are 3 separately controlled and administered TM1 instances in this particular organisation). But I am unfortunately not high enough in the food chain to make it happen.

BTW I am on Version 10.1.1 of TM1 and BI.



Re: Unable to connect to TM1 cube from different Cognos BI e

Posted: Tue Jul 14, 2015 1:26 pm
by scottofc
Thank you for your post on the issues with changing TM1 Connections in Cognos BI . I have been searching for a solution for this very issue. It seems like a total IBM disconnect; it shouldn’t require rocket-science to switch to a different Data Source on a different TM1 Server in my opinion. I have two identical 10.1.1 TM1 instances; one for DEV and one for PROD. I would have thought that my desire to test one or the other (from one BI 10.2 instance or the other) would not be such a challenge. I suppose it would help me to understand HOW is the TM1 Data Source connected to a Package (or vice versa)? It seems there is no way to verify the Data Source once a Package is published; ie, no Package Properties to display and certainly no way to change the Data Source for a particular Package, at least none that I have found. To me it seems utterly ridiculous to be forced to change the Tm1s.cfg file to switch from one environment to the other just so that the Test Connection will work in Cognos BI Administration. Doing so, in my case, basically disabled the DEV TM1 environment in order to connect to it from Production. Something is wrong with this picture so if anyone has any clues or other advice I would be most grateful; thanks!

PS. Adding a 2nd Connection entry to the Production Data Source in Cognos BI Administration did seem to connect to Dev but that option is not viable as we do not wish for Users to be promoted to select a Data Source in Production. If there is another way, please do tell!

Re: Unable to connect to TM1 cube from different Cognos BI env

Posted: Tue Nov 21, 2017 3:33 pm
by kool2zero
You would think they would allow this to make upgrades easier too.