Cube files missing

Post Reply
Ferteal
Posts: 3
Joined: Fri Oct 14, 2011 11:43 am
OLAP Product: TM1
Version: 9.5.2
Excel Version: Excel 2003 SP3

Cube files missing

Post by Ferteal » Sat Oct 15, 2011 2:30 pm

Dear all,

I've created a cube in my local server and I can't find the regarding files (f.e. '.cub'). However, the cube loading every time I start the local server. How can I find them?

Thanks in advance

ADMIN : Please read the posting guidelines this in not a bug, moved to the general forum.

Wim Gielis
MVP
Posts: 1748
Joined: Mon Dec 29, 2008 6:26 pm
OLAP Product: TM1
Version: PAL 2.0
Excel Version: 2016
Location: Brussels, Belgium
Contact:

Re: Cube files missing

Post by Wim Gielis » Sun Oct 16, 2011 12:01 pm

Hello

What is the name of the cube? Say MyCube.
Then in the local server data directory you should be able to find a file called MyCube.cub.

Are you looking in the correct folder? The file will be in that folder, not in a subfolder.

It is possible to have multiple data directories for 1 TM1 model: look at the config file tm1s.cfg in your data directory, and see what is used for "DataBaseDirectory=". (Although this will not work for a local server)

Using File > Options, what do you see on the right for Local Server Data Dir? Copy/paste the path and inspect the files.
Best regards,

Wim Gielis

Excel Most Valuable Professional, 2011-2014
http://www.wimgielis.com ==> 105 TM1 articles and a lot of custom code
Newest blog article: Looping over input files

Ferteal
Posts: 3
Joined: Fri Oct 14, 2011 11:43 am
OLAP Product: TM1
Version: 9.5.2
Excel Version: Excel 2003 SP3

Re: Cube files missing

Post by Ferteal » Sun Oct 16, 2011 2:20 pm

Hi Wim,

First of all thanks for your reply. The name of the cube is PNLCube2. I'm doing some test. There is only one folder, the default one (Path:C:\Program Files (x86)\Cognos\TM1\Custom\TM1Data\PData). I can't neither find Tm1s.cfg file. I don't understand anything. It might be into 'bin' folder, right? I've been looking for the file .cub through the windows tool "look for". Windows can't neither find it. Everything is too strange. The most strange is, as I told before, the cube is charged when the local server start to work. Maybe you can help me.

Thanks in advance,

Wim Gielis
MVP
Posts: 1748
Joined: Mon Dec 29, 2008 6:26 pm
OLAP Product: TM1
Version: PAL 2.0
Excel Version: 2016
Location: Brussels, Belgium
Contact:

Re: Cube files missing

Post by Wim Gielis » Sun Oct 16, 2011 9:40 pm

So you are certain that you are working in the data directory

C:\Program Files (x86)\Cognos\TM1\Custom\TM1Data\PData

when you update for instance a process or rules file, and you sort the file in that folder by the date of the last change, do you see the process or rules file being updated?

tm1s.cfg will not be in the bin folder.

In Windows explorer, do you turn on the file extensions?
Best regards,

Wim Gielis

Excel Most Valuable Professional, 2011-2014
http://www.wimgielis.com ==> 105 TM1 articles and a lot of custom code
Newest blog article: Looping over input files

Post Reply