Aggregations in Rows and Columns do not work

Post Reply
tomasfel
Posts: 3
Joined: Sun Mar 04, 2018 6:41 am
OLAP Product: TM1
Version: 10.2.2
Excel Version: 2010

Aggregations in Rows and Columns do not work

Post by tomasfel » Wed Sep 05, 2018 7:03 am

Hi,
we came accross a interesting issue on TM1 Production environment after creating view for one particular cube. After these modelling changes all of the views of this cube do not aggregate consolidations on rows and columns, while in the context consolidations work fine.
This behaviour appears dynamically, so swapping dimensions results in not-working consolidations of the dimensions on rows and columns that are shown at the time.
This issue happens only in TM1 Architect and TM1 Contributor. In PAW, TM1 Web and Porformance Modeler everything works just fine.

After showing aggregations in any of the working clients, TM1 Architect and Contributor shows the consolidations only for those particular cells.

We have tried restarting Web server without any progress. The only thing that works is restarting the instance, but the issue appears again after cca 3 hours of no activity on the server...
We have also tried to replace the data folder and to recreate the TM1 Application the cube is used in - again no progress.
When moving the data folder into another instance, everything works fine and no problem appears.

Do you have any suggestions about what might be causing this problem or how to resolve it?
Attachments
Not aggregating values.jpg
Not aggregating values.jpg (92.62 KiB) Viewed 377 times

Willi
Posts: 143
Joined: Mon Oct 07, 2013 11:51 am
OLAP Product: TM1
Version: 9.5.2
Excel Version: 2010

Re: Aggregations in Rows and Columns do not work

Post by Willi » Mon Sep 10, 2018 9:42 am

This looks for me like an issue with Feeders. The cells are probably not feeded!?

User avatar
macsir
Community Contributor
Posts: 551
Joined: Wed May 30, 2012 6:50 am
OLAP Product: TM1, SSAS
Version: 9.5 - 10.2
Excel Version: 97 - 2013
Contact:

Re: Aggregations in Rows and Columns do not work

Post by macsir » Mon Sep 10, 2018 8:49 pm

Do you have 0 weighting on dimensions?
In TM1,the answer is always yes though sometimes with a but....
http://tm1sir.blogspot.com.au/

tomasfel
Posts: 3
Joined: Sun Mar 04, 2018 6:41 am
OLAP Product: TM1
Version: 10.2.2
Excel Version: 2010

Re: Aggregations in Rows and Columns do not work

Post by tomasfel » Wed Sep 12, 2018 2:12 pm

Hi, thanks for the suggestions - feeders are correct as in context there are consolidated elements. Weighting is set to 1 on all the elements. The stated behaviour is dynamic - when swapping dimensions from context to rows, consolidations do not work on that particular subset used in rows and columns...

User avatar
Steve Rowe
Site Admin
Posts: 1818
Joined: Wed May 14, 2008 4:25 pm
OLAP Product: TM1
Version: 10.2.2., PAW
Excel Version: Nearly all of them

Re: Aggregations in Rows and Columns do not work

Post by Steve Rowe » Wed Sep 12, 2018 4:46 pm

Hi,

To summarise what you are saying in your post.

"When I look at particular consolidations on rows and columns , they display as zeros. When I look at the same elements as context / page / header references I get the results I expect. I only see this in the Cube Viewer in Architect or TM1 Web(?)

Restarting clears the issue for a bit"

I don't recognise the term TM1 Contributor, I think you mean the cube viewer in TM1 Web, this seems to be what is in your screen shot.

If we assume this is not a bug I would be looking very hard at the rules for the cube, in particular C level rules and Consolidate Children functions both of which can make the results unusual...

tomasfel
Posts: 3
Joined: Sun Mar 04, 2018 6:41 am
OLAP Product: TM1
Version: 10.2.2
Excel Version: 2010

Re: Aggregations in Rows and Columns do not work

Post by tomasfel » Mon Oct 01, 2018 12:04 pm

Hi I managed to find out what caused the issue, even though I do not know why it caused it:
In tm1s.cfg there has been specified parameter ViewConsolidationOptimization=F (default =T), to optimize the performance when loading the views.

From official IBM documentation:
View consolidation optimization stores the consolidated values that use leaf element components on either the row or column axis. For example, consider the dimension structure Year, 1Quarter with values Jan, Feb, and Mar.

Although this parameter should be changing only optimization, it (when something goes wrong) stops the consolidation when openning the view...

Tomas

Wim Gielis
MVP
Posts: 1826
Joined: Mon Dec 29, 2008 6:26 pm
OLAP Product: TM1
Version: PAL 2.0
Excel Version: 2016
Location: Brussels, Belgium
Contact:

Re: Aggregations in Rows and Columns do not work

Post by Wim Gielis » Mon Oct 01, 2018 1:01 pm

Good catch, thanks !
Best regards,

Wim Gielis

Excel Most Valuable Professional, 2011-2014
http://www.wimgielis.com ==> 105 TM1 articles and a lot of custom code
Newest blog article: Looping over input files

Post Reply