DataAdmin is not working properly

Post Reply
Posts: 13
Joined: Tue Mar 14, 2017 12:01 pm
OLAP Product: cognos tm1
Version: 10.2.2
Excel Version: excel 2013

DataAdmin is not working properly

Post by vino1493 » Mon May 14, 2018 9:34 am

Hi All,

I'm trying to explore the difference between SecurityAdmin and DataAdmin. Theoretically I understood the difference between them by going through IBM reference. I wanted to practically confirm to I provided my ID with SecurityAdmin and DataAdmin access separately and performed the test.

Case 1: With SecurityAdmin alone:
I was able to view all cubes, but was able to access only the security cubes and not even attribute cubes. It worked perfectly as I read.

Case 2: With DataAdmin alone:
I was only to view very few control objects (cubes), no data cubes were visible. All dimensions were visible though.
It was not correlating with what I read from IBM, they mentioned that DataAdmin would be able to read/write data cubes and read security cubes. But none of them were visible.

Now my question is: What was the issue? Why did it not work as mentioned? Could there be an issue with config file or something? Is DataAdmin dependent on any other setting?

Note: I tried the same with another instance (TM1 Instance), there it worked properly

User avatar
Posts: 121
Joined: Mon Nov 21, 2011 12:33 pm
OLAP Product: TM1
Version: 10.2.2
Excel Version: 2010

Re: DataAdmin is not working properly

Post by Elessar » Fri May 18, 2018 8:23 am


What version do you use?
Are there any differences in tm1s.cfg's of working and non-working instances?
Sorry for my English ;)

Post Reply