Active Form crashes Excel

Post Reply
Willi
Posts: 135
Joined: Mon Oct 07, 2013 11:51 am
OLAP Product: TM1
Version: 9.5.2
Excel Version: 2010

Active Form crashes Excel

Post by Willi » Wed May 09, 2018 9:56 am

Hello,

first of all we use PA 2.0.4 and Excel 2016.

I have the following situation with a model created long before I came here:

A cube with a couple of dimensions (5). And I want to span an active form over one of these dimensions. Still no problem until here.

The Dimension which is used as active form is the 4th dimension in the cube. And the elements have an attribute wich has the Elementname for the 2nd Dimension. I did it the following way:

Column B in Excel (A is the formatting Column): =TM1RPTROW($B$14;Server&":Dimension4";"Subset")
where $B$14 the TM1RPTVIEW, Server the Cell with the Server-Name and "Subset" a static subset is.

Column C is the DBRA wich gets the Attribute

Comumn D is =DBRW($B$14;$L$24;$C31;I$17;$B31;I$15) Where $L$24 is the same Cell where also the TM1RPTVIEW is pointing to and I$17 and I$15 are 2 Element-Names.

This crashes Excel if I want to open the active form.

If I replace the DBRA in Cell C.. with one of the correct Element-Names I get the correct result.

I even tried a DBR instead of DBRW but than the form does not open.

In TM1Web it displays correctly.

Any idea how I can get this to work in Excel?

Thx in advance

User avatar
gtonkin
MVP
Posts: 602
Joined: Thu May 06, 2010 3:03 pm
OLAP Product: TM1
Version: PAL 2.0.1
Excel Version: 2016 64-bit
Location: JHB, South Africa
Contact:

Re: Active Form crashes Excel

Post by gtonkin » Wed May 09, 2018 6:56 pm

Column C seems to be needed before column D can resolve but the AF is relying on column D to drive it. The dependencies seem to be "circular" which is why it works when you use a static element in column C.

When you say it works on TM1 Web - as you have it with formulas in column C and D or with column C as a static element?

Willi
Posts: 135
Joined: Mon Oct 07, 2013 11:51 am
OLAP Product: TM1
Version: 9.5.2
Excel Version: 2010

Re: Active Form crashes Excel

Post by Willi » Wed May 09, 2018 8:28 pm

Thx for the answer. Interesting idea. It is not a circular dependency as usual but probably one for "display reason" or "AF opening". But as far as I remember it worked in 10.2.2. I'll see if I can test it.

Yes, it works in TM1Web with the formulas!

Willi
Posts: 135
Joined: Mon Oct 07, 2013 11:51 am
OLAP Product: TM1
Version: 9.5.2
Excel Version: 2010

Re: Active Form crashes Excel

Post by Willi » Tue May 15, 2018 6:46 am

A little correction: I cannot test it in 10.2.2 because it was realized a complete other way. But I want to confirm that it works in PA 2.0.4 in TM1Web and not in Perspectives.

I use now another small cube with the same Dimension to open the AF so I don't need the Attributes for the AF, only to read the data wich is no problem.

Post Reply