TI Process slow

Post Reply
AskAndAnswer
Posts: 17
Joined: Fri Jun 02, 2017 6:35 pm
OLAP Product: TM1
Version: 10.2.2
Excel Version: 2013

TI Process slow

Post by AskAndAnswer » Mon Apr 16, 2018 11:25 pm

There are two processes - Process 1 and Process 2. Process 1 runs very quickly when executed independently. When it's executed from Process 2, it takes a while to complete hanging on the Epilog procedures. Process 2 is generally very slow, but ExecuteProcess (Process 1) is the first command in the Prolog, so there is no reason why it would hang.

Another issue is that Process 2 worked normally a month ago, now it takes a while to complete. The source is DB2 table, and it runs without delay. What could potentially cause the slowdown?

User avatar
PavoGa
Community Contributor
Posts: 240
Joined: Thu Apr 18, 2013 6:59 pm
OLAP Product: TM1
Version: 10.2.2 FP7, PA2.0
Excel Version: 2013
Location: Cleveland, Tennessee

Re: TI Process slow

Post by PavoGa » Tue Apr 17, 2018 2:10 pm

Sometimes the user interface is misleading as to what is really going on, e.g. seeming to be hanging up on the Epilog procedure. Your post does not mention if you have confirmed the observed performance in the server log itself by reviewing the time that Process 1 actually executes. Based on what else is happening in the prolog of Process 2, the progress window may report that the epilog of Process 1 is running when it is actually completing the balance of Process 2's prolog.

May need more information to diagnose this as well. Like what are the processes doing exactly besides reading from DB2?
Last edited by PavoGa on Wed Apr 18, 2018 12:08 pm, edited 1 time in total.
Ty
Cleveland, TN

AskAndAnswer
Posts: 17
Joined: Fri Jun 02, 2017 6:35 pm
OLAP Product: TM1
Version: 10.2.2
Excel Version: 2013

Re: TI Process slow

Post by AskAndAnswer » Tue Apr 17, 2018 10:22 pm

It turned out to be a feeder issue in one of the target cubes. Thank you.

Post Reply