PA 2 SSL_TLSv2

Post Reply
st2000
Posts: 61
Joined: Mon Aug 15, 2016 8:48 am
OLAP Product: TM1 (Windows) & SSAS 2014 Ent.
Version: 10.2.0 FP3
Excel Version: Excel 2013
Location: Hamburg, DE, EU
Contact:

PA 2 SSL_TLSv2

Post by st2000 » Wed Nov 08, 2017 9:29 am

Hello all,

I just installed PA 2.0.3 into a Linux VM (CentOS 7 on Virtualbox 5.2, Host Win10 Pro 64 Bit). It works as I can start Cognos Configuration and the processes (Admin Server, TM1 Server, Planning Sample). I configured the support for pre-TLS1.2 clients to true.

But although I can see the login page (localhost:9510/tm1web/), after typing the topmost parameter for Adminhost (name, IP or localhost), I get a window showing just: SSL_TLSv2. Same behaviour inside of the VM (Firefox) and outside from the host PC (IE 11).

This indicates a problem with certificates, but a login to applications like PMHUB works. tm1_inst (for PA V2 R0, latest I found at IBM) guides how to import a certificate using a keytool command to run from the JAVA_HOME folder, but at first it asks if I trust the file ("yes"), then it says JAVA I/O Error, no such file. I use the preinstalled JAVA 1.8 already contained into CentOS 7. Is there anything obvious I could have missed?

Best regards,
Stefan
-----------------------------------
Best regards,
Stefan

guntupalli
Posts: 18
Joined: Mon May 16, 2011 12:15 pm
OLAP Product: tm1
Version: 10.2
Excel Version: 2010

Re: PA 2 SSL_TLSv2

Post by guntupalli » Mon Jan 15, 2018 6:53 am

i came across this even though getting the same error.

1.did you run the keytool command from 'bin' location that is associated to JAVA_HOME?
2.check the permissions before going to execute the command..

keep posting.

Best Regards
Best Regards,
Guntupalli

asd900
Posts: 2
Joined: Mon Jan 29, 2018 11:40 am
OLAP Product: Tm1
Version: 2.0.2.1007
Excel Version: 14

Re: PA 2 SSL_TLSv2

Post by asd900 » Mon Jan 29, 2018 1:16 pm

Hi, i'm also having a similar issue on CentOS 7 with tm1 web giving me a error that says SSL_TLSv2,
while i'm still able to access tm1 applications.

I have imported a certificate using the keytool command from the location of the JAVA_HOME folder,
but to no success.

did you ever manager to solve this issue ? as i am not sure what i should do next.

Regards Matt

st2000
Posts: 61
Joined: Mon Aug 15, 2016 8:48 am
OLAP Product: TM1 (Windows) & SSAS 2014 Ent.
Version: 10.2.0 FP3
Excel Version: Excel 2013
Location: Hamburg, DE, EU
Contact:

Re: PA 2 SSL_TLSv2

Post by st2000 » Mon Mar 05, 2018 10:37 am

I managed to come over the problems partly:
  • I installed an IBM Java 7 instead of a kind of openJava already installed into the CentOS7 by default
  • then the import of the certificate into the keystore worked as described into the tm1_inst.pdf
  • and also I changed the URLs in CogConfig.sh from localhost to IP as far as they concern the application server; this seems to become exposed directly to the webserver and is not translated internally to the servers DNS name or IP
I could use now from the host outside from the VM TM1web and also Applications as they are pre-configured (VM-Network: Host-only, static IP).
But nevertheless I can't access from the Windows 10 - host via Architect or Performance Modeler to the Server inside the VM, which would be needed to create own Metadata and use a Linux Server at least for prototyping, development or demo purposes.

Unfortunately IBM only supports Windows and Linux OS which are not free. Even CentOS works here only as the nearestby variation to RHEL 7.
So I would need a separate windows license for each VM I work on... not very helpful.

IBM should offer a preconfigured VM including CentOS or different free OS for download, this would make it far easier for many of us.
For future tool evaluations this and also the need to use ILMT when hosted on a non-IBM cloud will be considered against other products as far as I will have to perform this somewhen.
-----------------------------------
Best regards,
Stefan

Post Reply