10.2.2 FP7 - increased time for feeder processing on restart

Post Reply
lpahnke
Posts: 18
Joined: Thu Jun 14, 2012 9:55 pm
OLAP Product: TM1
Version: 10.2.2
Excel Version: 2013

10.2.2 FP7 - increased time for feeder processing on restart

Post by lpahnke » Mon Oct 09, 2017 4:54 pm

We just upgraded to FP7 on our production server this weekend and as a result one of our cubes that already had a very long processing time for feeders on restarts now is taking significantly (~40%) longer. Some other cubes are also taking 20-30% longer, however those cubes took a lot less time to process feeders to begin with, so the time increase is not nearly as noticeable or problematic (and I'm not yet as positive those increases are consistent, as we've only had two days of restart data to go on since this occurred - the one that's taking a lot longer has shown about the same time the last two days, and I've never seen it do that before, so it's my main concern right now). Nothing changed in our model to explain this so the only difference I can find is moving from FP3 to FP7.
Has anyone else experienced this, have suggestions on what we might target in the cube in question that's especially problematic to try and figure out what's causing the longer times, or know of something in FP7 that affects feeder processing that we might have missed? I'd like to get our server restart time back down to its already very long processing if possible. I've considered trying to use MaximumCubeLoadThreads and/or PersistentFeeders, but due to our use of a lot of conditional feeders, I have some concerns those might not work well for us (although please feel free to tell me why I'm wrong on that if it would be a good option for us!). Thanks for any suggestions.

Post Reply