Old data pops up in a cube even after performing a deletion in a cubeview.

Post Reply
jack_008
Posts: 12
Joined: Wed Sep 28, 2016 2:20 pm
OLAP Product: TM1
Version: 10.3
Excel Version: Excel 2013

Old data pops up in a cube even after performing a deletion in a cubeview.

Post by jack_008 » Thu Sep 28, 2017 7:24 am

Hi everyone,

It would be really helpful if anyone could guide me through this error I'm facing.

I create a cubeview , then i perform a VIEWZEROOUT in order to delete the data of that specific view. If I crosscheck with the cube , I can see that the data has been zeroed out. (I delete the cubeview & subsets i had created for this procedure)

Now i try to input new data to that particular cubeview(I zeroed out before) , I see that the old data pops up in the view, that was present before performing deletion & not the data I'm trying to insert.

Can anyone please help me out with this ?

Thanks in advance !

AmbPin
Regular Participant
Posts: 173
Joined: Sat Mar 20, 2010 3:03 pm
OLAP Product: TM1
Version: 9.5.2
Excel Version: 2007-10

Re: Old data pops up in a cube even after performing a deletion in a cubeview.

Post by AmbPin » Thu Sep 28, 2017 7:55 am

Hello,

First thoughts are that your ZeroOut view is missing the data that you want to clear or that there are rules applicable to the cells that you are attempting to clear. Not sure why you would see no data values when you inspect after the ZeroOut though.
Not sure if you know or if this is applicable but... if you have at one time put a value into a cell that subsequently becomes rule based, then that value is retained and may return if the rule is removed. Are you able to build a new cube, or temporarily remove any rules, CubeClearData(Cube), then re-apply the rules.

User avatar
Alan Kirk
Site Admin
Posts: 5736
Joined: Sun May 11, 2008 2:30 am
OLAP Product: TM1
Version: 9.5.2 64 bit moving to 10.2.2
Excel Version: 2010
Location: Sydney, Australia
Contact:

Re: Old data pops up in a cube even after performing a deletion in a cubeview.

Post by Alan Kirk » Thu Sep 28, 2017 8:29 am

jack_008 wrote:
Thu Sep 28, 2017 7:24 am
Hi everyone,

It would be really helpful if anyone could guide me through this error I'm facing.

I create a cubeview , then i perform a VIEWZEROOUT in order to delete the data of that specific view. If I crosscheck with the cube , I can see that the data has been zeroed out. (I delete the cubeview & subsets i had created for this procedure)

Now i try to input new data to that particular cubeview(I zeroed out before) , I see that the old data pops up in the view, that was present before performing deletion & not the data I'm trying to insert.

Can anyone please help me out with this ?

Thanks in advance !
I suggest:
(a) Ensuring that logging is on on the cube before you do the zero out;
(b) Finding ONE N level example of this; then
(c) Looking at your transaction logs to see whether the value really was zeroed out and/or whether it was added back by someone or some process that you weren't expecting.

If there is no transaction log record of the data being zeroed then your cross-check view is probably not what you think it is.
"To them, equipment failure is terrifying. To me, it’s 'Tuesday.' "
-----------
Before posting, please check the documentation, the FAQ, the Search function and FOR THE LOVE OF GLUB the Request Guidelines.

jack_008
Posts: 12
Joined: Wed Sep 28, 2016 2:20 pm
OLAP Product: TM1
Version: 10.3
Excel Version: Excel 2013

Re: Old data pops up in a cube even after performing a deletion in a cubeview.

Post by jack_008 » Mon Oct 09, 2017 1:22 pm

Alan Kirk wrote:
Thu Sep 28, 2017 8:29 am
jack_008 wrote:
Thu Sep 28, 2017 7:24 am
Hi everyone,

It would be really helpful if anyone could guide me through this error I'm facing.

I create a cubeview , then i perform a VIEWZEROOUT in order to delete the data of that specific view. If I crosscheck with the cube , I can see that the data has been zeroed out. (I delete the cubeview & subsets i had created for this procedure)

Now i try to input new data to that particular cubeview(I zeroed out before) , I see that the old data pops up in the view, that was present before performing deletion & not the data I'm trying to insert.

Can anyone please help me out with this ?

Thanks in advance !
I suggest:
(a) Ensuring that logging is on on the cube before you do the zero out;
(b) Finding ONE N level example of this; then
(c) Looking at your transaction logs to see whether the value really was zeroed out and/or whether it was added back by someone or some process that you weren't expecting.

If there is no transaction log record of the data being zeroed then your cross-check view is probably not what you think it is.

Hi Alan,

Thanks for your reply !

I did ensure that the Logging is ON before performing the zero out.

Also i have this N level example that i have been using in order to perform the testing(So , I'm pretty sure that the deletion TI process is working).

The other strange thing is ,if i run the TI that inputs data ,twice , i get the desired result.

So the current scenario is if I use the TI in order to input data immediately after performing the Viewzero out , i get the old data that i had before performing Viewzero out.
But if i run the input TI twice , i get the desired result.

So as of now, i have this question, what happens when the function viewzeroout is called out?
Does it replace the target cell value with zero or is there any calculation performed by TM1 calculation engine in order to make the cell value zero.

Thanks for your help in advance !

User avatar
tiagoblauth79
Posts: 25
Joined: Fri Aug 26, 2016 1:42 pm
OLAP Product: Cognos BI and TM1
Version: 10.2.2
Excel Version: 10
Contact:

Re: Old data pops up in a cube even after performing a deletion in a cubeview.

Post by tiagoblauth79 » Mon Oct 09, 2017 6:03 pm

As Alan said, please check the transaction logging. In the log folder for the application check for tm1s.log file (or for example tm1s20171005214604.log). If you can stop the services, clear the log folder, start and run this process only, your life will be simplest.

tm1s.log example:
"","20171009165156","20171009165156","User","S","Queued","Running","GEN_Process_List","1","Status",""

"Queued" data was changed to "Running" on the cube "GEN_Process_List" in the cell "1","Status"

Post Reply