Tm1 public subsets gets cleared

Post Reply
Analytics123
Posts: 75
Joined: Tue May 23, 2017 12:45 pm
OLAP Product: Tm1
Version: 9.5
Excel Version: 2010

Tm1 public subsets gets cleared

Post by Analytics123 » Fri Sep 01, 2017 3:29 pm

Hi we have an issue at times were the public subsets created on dimension gets cleared randomly.
Can yuo guys tell me where should i start trouble shooting this .

Some times it happens after server restart , sometimes it happens randomly when server is running.

Thanks,

lotsaram
MVP
Posts: 3006
Joined: Fri Mar 13, 2009 11:14 am
OLAP Product: TM1, CX
Version: TM1 10.2.2 PA 2.0x
Excel Version: 2010 2013 365
Location: Switzerland

Re: Tm1 public subsets gets cleared

Post by lotsaram » Fri Sep 01, 2017 4:09 pm

If subsets are "getting cleared" then it's because elements are being deleted and added back to the dimension. To avoid this unwind the dimension rather than deleting elements. There are plenty of topics you can find on unwinding dimensions.
Please place all requests for help in a public thread. I will not answer PMs requesting assistance.

AmbPin
Regular Participant
Posts: 173
Joined: Sat Mar 20, 2010 3:03 pm
OLAP Product: TM1
Version: 9.5.2
Excel Version: 2007-10

Re: Tm1 public subsets gets cleared

Post by AmbPin » Wed Sep 06, 2017 11:42 am

I would inestigate the previous sugestion as there are risks with deleting and re-inserting elements. However you could perhaps make your subsets dynamic with MDX instead of static members, or recreate the subsets when you rebuild the dimension in TI.

User avatar
tomok
MVP
Posts: 2349
Joined: Tue Feb 16, 2010 2:39 pm
OLAP Product: TM1, Palo
Version: Beginning of time thru 10.2
Excel Version: 2003-2007-2010-2013
Location: Atlanta, GA
Contact:

Re: Tm1 public subsets gets cleared

Post by tomok » Wed Sep 06, 2017 12:11 pm

AmbPin wrote:
Wed Sep 06, 2017 11:42 am
However you could perhaps make your subsets dynamic with MDX instead of static members
Indeed. As a general rule I make all my user subsets MDX-based, if possible, even if it only has one member to avoid the problem noted in this thread.
Tom O'Kelley - Manager Finance Systems
American Tower
http://www.onlinecourtreservations.com/

Analytics123
Posts: 75
Joined: Tue May 23, 2017 12:45 pm
OLAP Product: Tm1
Version: 9.5
Excel Version: 2010

Re: Tm1 public subsets gets cleared

Post by Analytics123 » Thu Sep 07, 2017 8:25 pm

Okay I am using the below code to remove my levels from hierarchy in my dimension,This is the only one I can think of where the dimension element is touched again.
This will remove the element from its parent and put seperatley.
vMax = DIMSIZ(vDim);
vCount = 1;

WHILE (vCount <= vMax);
vElem = DIMNM(vDim, vCount);

vMaxParents = ELPARN(vDim, vElem);
WHILE (vMaxParents>0);

vParent = ELPAR(vDim, vElem, vMaxParents);
DimensionElementComponentDelete(vDim, vParent, vElem);
vMaxParents = vMaxParents - 1;
END;

vCount = vCount + 1;
END;

Could this cause an issue .For example I create a manual subset with two members from level2 . They get deleted randomly .

Wim Gielis
MVP
Posts: 1562
Joined: Mon Dec 29, 2008 6:26 pm
OLAP Product: TM1
Version: PAL 2.0
Excel Version: 2016
Location: Brussels, Belgium
Contact:

Re: Tm1 public subsets gets cleared

Post by Wim Gielis » Thu Sep 07, 2017 8:27 pm

If you don't delete elements from the dimension, this cannot be the reason that subsets would lose their elements. What you do is unwinding in the dimension (which is good and I also do that) but as Lotsaram already wrote unwinding is not the cause, it's deleting and reinserting elements.
Best regards,

Wim Gielis

Excel Most Valuable Professional, 2011-2014
http://www.wimgielis.com ==> 104 TM1 articles and a lot of custom code
Newest blog article: Delete a cube and its dimensions

Post Reply