Transfer rule value to other cube using TI

Post Reply
Posts: 14
Joined: Thu Jan 26, 2017 9:57 am
OLAP Product:
Version: 10.2.20400.80
Excel Version: 2007

Transfer rule value to other cube using TI

Post by emma » Mon Aug 28, 2017 9:59 am

Hi.. i want to transfer value from one cube to another cube using TI
but there is some value from source cube that came from rule calculated... How i transfer that value using TI ?
I already tried to uncheck skip rules calculated... but it didn't work... is there another way ? thank you

User avatar
jim wood
Site Admin
Posts: 3577
Joined: Wed May 14, 2008 1:51 pm
OLAP Product: TM1
Version: TM1 10.2.2
Excel Version: 2007
Location: 1639 Route 10, Suite 107, Parsippany, NJ, USA

Re: Transfer rule value to other cube using TI

Post by jim wood » Mon Aug 28, 2017 11:41 am

That should work. Without more details it's difficult to give an exact answer but it does sound like the values are not fed,

Struggling through the quagmire of life to reach the other side of who knows where.
Application Consulting Group (ACG) TM1 Consulting
OS: Windows 10 64-bit. TM1 Version: 10.2.2

Posts: 80
Joined: Fri Aug 12, 2016 10:02 am
OLAP Product: tm1
Version: 10.2.0 - 10.3.0
Excel Version: 2010

Re: Transfer rule value to other cube using TI

Post by Drg » Wed Sep 13, 2017 8:01 am

show your TI code!

Posts: 62
Joined: Mon Aug 15, 2016 8:48 am
OLAP Product: TM1 (Windows) & SSAS 2014 Ent.
Version: 10.2.0 FP3
Excel Version: Excel 2013
Location: Hamburg, DE, EU

Re: Transfer rule value to other cube using TI

Post by st2000 » Fri Sep 22, 2017 9:57 am

I had a (maybe) similar issue, and could solve it. My view (TI's sourceview) shows interactively also C-elements, but the TI does only log out N-element's values.

Before, I tweaked the view using the data source selectors GUI, and there I checked on to skip the consolidations. In the TI-view generated later and made to source by these commands...:

Code: Select all

...I expected to catch via TI/data tab the same amount of cells like the same view in the cube viewer does. But I never got the C-elements as displayed in the viewer grid.
It was only a desperate try&error-idea to add:

Code: Select all

ViewExtractSkipCalcsSet (sCube2Spread, sViewName,0);
which switches off the skipping (as per doc this is intended to use for writing out .cma-files). Now it works as desired and initially expected. It seems that this switch was in effect all the time. And not kept at 0 always when the view was created new per TI execution. Unfortunately I didn't found a TI variable to derive the current status of a view about skipping C/rule-values/zeros.

If this happens to you, under the hood, concerning rule-values this might help:

Code: Select all

ViewExtractSkipRuleValuesSet (Cube, ViewName, Flag);
Set the Flag=0 and try again. If the cause was a suppression of rule values, your TI should be able the catch them again. Hope it helps.
Best regards,

Post Reply