TM1 and Planning Analytics Workspace on Same Server 2016 Machine

Post Reply
codingCPA
Posts: 16
Joined: Sun Mar 12, 2017 1:41 am
OLAP Product: TM1
Version: Planning Analytics 2.0.21, PAW
Excel Version: Excel 2013
Location: Los Angeles, Atlanta

TM1 and Planning Analytics Workspace on Same Server 2016 Machine

Post by codingCPA » Fri Aug 11, 2017 4:00 pm

Does anyone have experience running TM1 and Planning analytics Workspace on the same server 2016 machine? We're experimenting with a new setup in azure and can't seem to get it to work like we are able to on our server 2008 environment with PAW running on a Linux virtual machine. The issue is that we can't seem to be able to find the correct URI's to get Workspace to be able to connect to TM1. On our 2008 environment, we are able to use localhost. IBM says this won't work in a server 2016 environment (can confirm it doesn't). Using the universal address of our sever that they are both running on doesn't seem to work either. They have some other IP's listed in support but nothing I can find on IBM's site seems to work.

Any insights here??

Thanks in advance.

codingCPA
Posts: 16
Joined: Sun Mar 12, 2017 1:41 am
OLAP Product: TM1
Version: Planning Analytics 2.0.21, PAW
Excel Version: Excel 2013
Location: Los Angeles, Atlanta

Re: TM1 and Planning Analytics Workspace on Same Server 2016 Machine

Post by codingCPA » Fri Aug 11, 2017 8:46 pm

Worked this one out. Ended up finding the internal IP that the containers were using and using that and things are all hooked up now.

tez
Posts: 40
Joined: Tue Dec 21, 2010 12:43 am
OLAP Product: Cognos Express
Version: 10.2.1 FP3
Excel Version: 2013

Re: TM1 and Planning Analytics Workspace on Same Server 2016 Machine

Post by tez » Tue Nov 21, 2017 12:07 am

Hi codingCPA

I'm glad I found your post as I'm having the exact same issue with an installation of TM1 & PAW on the same MS Server 2016 vm.

I have all the sample TM1 servers installed on Planning Analytics 2.0.3, but only have the Planning Sample TM1 Server running, & using its HTTPPortNumber of 12354 for the Login Server URI.

The PAW IP is 172.22.171.138 & the gateway is 172.22.160.1, but when I try this in the PAW admin tool config, I get timeout errors. True IP of the vm is 192.168.75.74.

PAW config.PNG
PAW config.PNG (41.52 KiB) Viewed 209 times

Does anyone have any idea where I'm going wrong?

Thanks in advance
Terri

dr.nybble
Posts: 87
Joined: Wed Aug 17, 2011 3:51 pm
OLAP Product: TM1
Version: 10.2.2
Excel Version: Excel 2007

Re: TM1 and Planning Analytics Workspace on Same Server 2016 Machine

Post by dr.nybble » Tue Nov 21, 2017 3:20 pm

You may have to add firewall rules to permit it. Even communication on the same box can be blocked by the Windows firewall.

Try to temporarily disable it to see if that addresses the problem.

tez
Posts: 40
Joined: Tue Dec 21, 2010 12:43 am
OLAP Product: Cognos Express
Version: 10.2.1 FP3
Excel Version: 2013

Re: TM1 and Planning Analytics Workspace on Same Server 2016 Machine

Post by tez » Wed Nov 22, 2017 12:05 am

Hi dr.nybble

Fantastic, thanks for that...it worked! :D

Cheers
Terri

trentban
Posts: 10
Joined: Tue Aug 20, 2013 6:28 am
OLAP Product: TM1
Version: 10.2.2
Excel Version: Excel 2013

Re: TM1 and Planning Analytics Workspace on Same Server 2016 Machine

Post by trentban » Fri Nov 24, 2017 5:20 am

have you guys experienced any performance issues with them being on the same server?

Post Reply