Region Settings

Post Reply
Jorge Rachid
Posts: 39
Joined: Fri Jul 22, 2016 8:33 pm
OLAP Product: TM1
Version: 10.2
Excel Version: 2013

Region Settings

Post by Jorge Rachid » Tue Aug 08, 2017 3:00 pm

Hi there,

I am facing difficult to use format number as 1.000.000,00 instead of 1,000,000.00.

I am using Planning Analytics on SaaS.

The problem is when I run the process to upload data from a csv to a cube.

I have changed the region configuration as word file attached but as example the number 0,12 is 12 on tm1 and I don't know what to do anymore.

Does anyone have an idea?

Thanks a lot,

JR
Attachments
Problem.docx
Region Configuration and result on TM1 from CSV file
(61.17 KiB) Downloaded 3 times
CsvFile.csv
File uploaded to tm1
(183 Bytes) Downloaded 4 times

Drg
Posts: 40
Joined: Fri Aug 12, 2016 10:02 am
OLAP Product: tm1
Version: 10.2.0 - 10.3.0
Excel Version: 2010

Re: Region Settings

Post by Drg » Tue Aug 08, 2017 4:11 pm

If you use TI to load data you must define decimal separate char and thousand saparate char in TI.
Image

Jorge Rachid
Posts: 39
Joined: Fri Jul 22, 2016 8:33 pm
OLAP Product: TM1
Version: 10.2
Excel Version: 2013

Re: Region Settings

Post by Jorge Rachid » Tue Aug 08, 2017 5:13 pm

Hi,

My TI is like that but it is still not working.

TM1 is ignoring the comma and I don't know why.

Wim Gielis
MVP
Posts: 1480
Joined: Mon Dec 29, 2008 6:26 pm
OLAP Product: TM1
Version: PAL 2.0
Excel Version: 2016
Location: Brussels, Belgium
Contact:

Re: Region Settings

Post by Wim Gielis » Tue Aug 08, 2017 5:31 pm

If your variable is defined as a string, try the function StringToNumberEx, and specify the separators.
Does that work ?
See http://www.wimgielis.com/tm1_numbersandstrings_EN.htm
Best regards,

Wim Gielis

Excel Most Valuable Professional, 2011-2014
http://www.wimgielis.com ==> 103 TM1 articles and a lot of custom code
Newest blog article: TM1 message log analysis with Power Query

Jorge Rachid
Posts: 39
Joined: Fri Jul 22, 2016 8:33 pm
OLAP Product: TM1
Version: 10.2
Excel Version: 2013

Re: Region Settings

Post by Jorge Rachid » Tue Aug 08, 2017 6:02 pm

Hi Wim,

Amazing!

I have tried here and seems to work!

I will fix all variables that I have on TI but I am quite sure that will work.

Thank you so much.

Best regards,

JR

Jorge Rachid
Posts: 39
Joined: Fri Jul 22, 2016 8:33 pm
OLAP Product: TM1
Version: 10.2
Excel Version: 2013

Re: Region Settings

Post by Jorge Rachid » Tue Aug 08, 2017 6:48 pm

Hi Wim,

Everything is correct now!

Thanks a lot for your help again.

See ya,

JR

Wim Gielis
MVP
Posts: 1480
Joined: Mon Dec 29, 2008 6:26 pm
OLAP Product: TM1
Version: PAL 2.0
Excel Version: 2016
Location: Brussels, Belgium
Contact:

Re: Region Settings

Post by Wim Gielis » Tue Aug 08, 2017 7:06 pm

You're welcome ;-)
Best regards,

Wim Gielis

Excel Most Valuable Professional, 2011-2014
http://www.wimgielis.com ==> 103 TM1 articles and a lot of custom code
Newest blog article: TM1 message log analysis with Power Query

Post Reply