Application name not listed in TM1 web URL

Post Reply
rni
Posts: 9
Joined: Tue Feb 07, 2017 2:48 pm
OLAP Product: IBM Cognos TM1
Version: 10.2.2
Excel Version: 2010

Application name not listed in TM1 web URL

Post by rni » Tue Aug 08, 2017 7:54 am

Hi,

When we try to login to the application through web link, http://localhost:9510/tm1web, none of the applications are listed.
Tried re-generating cryptographic keys, still the issue exists.
SSL validity is good.
The link was working fine until yesterday.
Any ideas welcome.

Thanks.

Edward Stuart
Community Contributor
Posts: 197
Joined: Tue Nov 01, 2011 10:31 am
OLAP Product: TM1
Version: All
Excel Version: All
Location: Manchester
Contact:

Re: Application name not listed in TM1 web URL

Post by Edward Stuart » Tue Aug 08, 2017 10:20 am

What do you mean by Applications?

Do you mean http://localhost:9510/pmpsvc

rni
Posts: 9
Joined: Tue Feb 07, 2017 2:48 pm
OLAP Product: IBM Cognos TM1
Version: 10.2.2
Excel Version: 2010

Re: Application name not listed in TM1 web URL

Post by rni » Tue Aug 08, 2017 10:40 am

The running TM1 Sample application (SData) is not populating in the Web url. It shows Blank. Attached a screenshot for reference.
Attachments
issue.png
issue.png (16.3 KiB) Viewed 529 times

Drg
Posts: 64
Joined: Fri Aug 12, 2016 10:02 am
OLAP Product: tm1
Version: 10.2.0 - 10.3.0
Excel Version: 2010

Re: Application name not listed in TM1 web URL

Post by Drg » Tue Aug 08, 2017 3:58 pm

check your admin host in fpmsvc_config.xml

User avatar
Elessar
Posts: 103
Joined: Mon Nov 21, 2011 12:33 pm
OLAP Product: TM1
Version: 10.2.2
Excel Version: 2010

Re: Application name not listed in TM1 web URL

Post by Elessar » Wed Aug 09, 2017 7:22 am

Did you try other browsers?

Is the server really up and running? Can you see it in Architect?

Also check adminhost in tm1s.cfg
Sorry for my English ;)

rni
Posts: 9
Joined: Tue Feb 07, 2017 2:48 pm
OLAP Product: IBM Cognos TM1
Version: 10.2.2
Excel Version: 2010

Re: Application name not listed in TM1 web URL

Post by rni » Tue Sep 05, 2017 7:07 am

Many thanks for your suggestions.
Specifying the port numbers in Windows firewall Advanced security got the application name in place. But it is still grayed out, and then shows an error has occurred in the login page.
Tried all suggestion is posts http://www.tm1forum.com/viewtopic.php?t=9529 and http://www.tm1forum.com/viewtopic.php?t=9926. Still no luck
The Application is up and running. Tried in all browsers in multiple systems.
Also Re-checked the admin host in fpmsvc_config.xml. It shows the right value.
Attachments
Issue_Login.png
Issue_Login.png (113.38 KiB) Viewed 359 times

Edward Stuart
Community Contributor
Posts: 197
Joined: Tue Nov 01, 2011 10:31 am
OLAP Product: TM1
Version: All
Excel Version: All
Location: Manchester
Contact:

Re: Application name not listed in TM1 web URL

Post by Edward Stuart » Tue Sep 05, 2017 11:47 am

Have you checked that all of the firewall ports are open?

Unable to log in to Architect/Perspectives/TM1 Web: TM1 server is not showing

and just to be sure on the tm1web side of things:

TM1Web does not show any TM1 Servers in the server dropdown

Can you confirm if you are able to login via Architect/ Perspectives/ Performance Modeler and which version of Cognos TM1 you are using (or more specifically; IIS or Tomcat)?

User avatar
Elessar
Posts: 103
Joined: Mon Nov 21, 2011 12:33 pm
OLAP Product: TM1
Version: 10.2.2
Excel Version: 2010

Re: Application name not listed in TM1 web URL

Post by Elessar » Tue Sep 05, 2017 12:45 pm

Also, what does tm1web.log say?
Sorry for my English ;)

rni
Posts: 9
Joined: Tue Feb 07, 2017 2:48 pm
OLAP Product: IBM Cognos TM1
Version: 10.2.2
Excel Version: 2010

Re: Application name not listed in TM1 web URL

Post by rni » Fri Sep 08, 2017 6:35 am

Issue resolved temporarily. IBM guys suggested to add the ip address in the tm1s.cfg file. Somehow the server is currently having two ip addresses. When added them in the tm1s file, it works.. but this should not be the resolution ideally.

Edward Stuart
Community Contributor
Posts: 197
Joined: Tue Nov 01, 2011 10:31 am
OLAP Product: TM1
Version: All
Excel Version: All
Location: Manchester
Contact:

Re: Application name not listed in TM1 web URL

Post by Edward Stuart » Fri Sep 08, 2017 6:49 am

For reference and to assist other users searching the forum, multiple network adapters can cause issues:

Unable to login to TM1 Server when TM1 Admin Server has multiple network adapters (NICs)

Post Reply