CubeProcessFeeders - when to use?

Post Reply
fleaster
Regular Participant
Posts: 165
Joined: Wed Mar 30, 2011 11:57 pm
OLAP Product: TM1
Version: 10.2.2
Excel Version: XL2010

CubeProcessFeeders - when to use?

Post by fleaster » Wed May 17, 2017 7:08 am

Hi all,
Hopefully this should be a quick one... my understanding of the CubeProcessFeeders TI function, is that it only needs to be run when you have a change in the underlying data of a cube with Conditional Feeders.

i.e. if the cube has normal feeders, then there is no need to run CubeProcessFeeders , as all the Rules/Feeders will be calculating properly on the fly

...is my understanding correct? :)

thanks!

Matt

Wim Gielis
MVP
Posts: 1538
Joined: Mon Dec 29, 2008 6:26 pm
OLAP Product: TM1
Version: PAL 2.0
Excel Version: 2016
Location: Brussels, Belgium
Contact:

Re: CubeProcessFeeders - when to use?

Post by Wim Gielis » Wed May 17, 2017 8:39 am

True :-)
Best regards,

Wim Gielis

Excel Most Valuable Professional, 2011-2014
http://www.wimgielis.com ==> 103 TM1 articles and a lot of custom code
Newest blog article: TM1 message log analysis with Power Query

fleaster
Regular Participant
Posts: 165
Joined: Wed Mar 30, 2011 11:57 pm
OLAP Product: TM1
Version: 10.2.2
Excel Version: XL2010

Re: CubeProcessFeeders - when to use?

Post by fleaster » Wed May 17, 2017 10:53 pm

Goodo thanks! :)

User avatar
gtonkin
MVP
Posts: 511
Joined: Thu May 06, 2010 3:03 pm
OLAP Product: TM1
Version: PAL 2.0.1
Excel Version: 2016 64-bit
Location: JHB, South Africa
Contact:

Re: CubeProcessFeeders - when to use?

Post by gtonkin » Thu May 18, 2017 9:52 am

You also need to run feeders where you are feeding based on a reference to an attribute or from a consolidation that may have changed. I seem to recall a model where we were feeding to an intersection to a target cell which included referenced few DB reads to the cube to bring back the elements required. We had to trigger feeders periodically. FEEDSTRINGS had no impact in this situation.

LEP
Posts: 2
Joined: Mon Sep 18, 2017 10:04 am
OLAP Product: IBM Congos TM1
Version: 10.2.2
Excel Version: 2010

Re: CubeProcessFeeders - when to use?

Post by LEP » Mon Sep 18, 2017 11:23 am

Hi,

I have similar experiences in a TM1modell.
gtonkin wrote:
Thu May 18, 2017 9:52 am
You also need to run feeders where you are feeding based on a reference to an attribute or from a consolidation that may have changed. I seem to recall a model where we were feeding to an intersection to a target cell which included referenced few DB reads to the cube to bring back the elements required. We had to trigger feeders periodically. FEEDSTRINGS had no impact in this situation.
Some feeders are based on a reference to an attribute value and after restart those feeder will not re-fire (If I check the source cells with "Trace feeders..." shows that the target cell is feed but still the target values are "zeroed-out"). After re-save of the rule file or running a TI proc with CubeProcessFeeders is everything fine.

@gtonkin: may I ask you which TM1 version are you using ? Did you find any other solution except running TI proc periodically?

Note:
- TM1 version: 10.2.2 FP1
- PersistentFeeders=F
- No conditinal feeders

Thanks in advance.

User avatar
gtonkin
MVP
Posts: 511
Joined: Thu May 06, 2010 3:03 pm
OLAP Product: TM1
Version: PAL 2.0.1
Excel Version: 2016 64-bit
Location: JHB, South Africa
Contact:

Re: CubeProcessFeeders - when to use?

Post by gtonkin » Mon Sep 18, 2017 5:50 pm

LEP wrote:
Mon Sep 18, 2017 11:23 am
...
Some feeders are based on a reference to an attribute value and after restart those feeder will not re-fire (If I check the source cells with "Trace feeders..." shows that the target cell is feed but still the target values are "zeroed-out"). After re-save of the rule file or running a TI proc with CubeProcessFeeders is everything fine.
...
The model where we had these issues is on 10.2.2 FP4.
I am still unsure if there is some internal dependency or solve order but it is one of those things that I have never been able to successfully re-create and come up with a suitable explanation. What works, as you found was triggering feeders via TI.
Just to give some context - I also had a fairly simple feeder i.e. element reference merely substituted with an ATTRS to a string Attribute.
I was not expecting a change in the value of the attribute to re-fire. And neither did I have conditional feeders and was thus not using ForceReevaluationOfFeedersForFedCellsOnDataChange.

If I find anything further of relevance in solving this whether a workaround or correcting something I may have done wrong, will post back.

LEP
Posts: 2
Joined: Mon Sep 18, 2017 10:04 am
OLAP Product: IBM Congos TM1
Version: 10.2.2
Excel Version: 2010

Re: CubeProcessFeeders - when to use?

Post by LEP » Tue Sep 19, 2017 7:26 am

Hi gtonkin,

thanks you for your answer.

First of all it is important to me that a newer FP wouldn’t solve the problem - at least until FP4. I have some ideas for workaround: the rule is about account numbers so I can use numeric attribute instead of string attribute / replace ATTRS function with DB function / create a normal parameter cube to replace attribute cube.
I’m going to try out these techniques and inform you of results.

Post Reply