Server hangs on ODBC-import

hansstip
Posts: 22
Joined: Fri Sep 19, 2008 8:29 am
OLAP Product: TM1
Version: 9.1 SP 3
Excel Version: Excel 2007

Re: Server hangs on ODBC-import

Post by hansstip » Tue May 13, 2014 1:24 pm

On the client side we use Office 2007 on XP, on the server it's 2003 R2.
During the upgrade we will up that to Office 2013 on Windows 8 and Server 212 R2.

User avatar
jim wood
Site Admin
Posts: 3610
Joined: Wed May 14, 2008 1:51 pm
OLAP Product: TM1
Version: TM1 10.2.2
Excel Version: 2007
Location: 1639 Route 10, Suite 107, Parsippany, NJ, USA
Contact:

Re: Server hangs on ODBC-import

Post by jim wood » Tue May 13, 2014 1:52 pm

OK, I was checking to see if you were using server 2008 which has been tied down quite considerably. I would now look Michel's point about the user being used to run the TM1 service,

Jim.
Struggling through the quagmire of life to reach the other side of who knows where.
Application Consulting Group (ACG) TM1 Consulting
OS: Windows 10 64-bit. TM1 Version: 10.2.2

hansstip
Posts: 22
Joined: Fri Sep 19, 2008 8:29 am
OLAP Product: TM1
Version: 9.1 SP 3
Excel Version: Excel 2007

Re: Server hangs on ODBC-import

Post by hansstip » Wed May 14, 2014 12:50 pm

Nothing is changed to the user that runs the TM1 service and a TM1-Save works fine. It's just that when I try to run (or edit) a TI-process that uses an ODBC-connection the system hangs.
I guess the messages in the windows event log occur when the server is restarted after I had to manually stop the services (or when that didn't work kill the tm1sd.exe using the task manager) when the system hangs.
I now made workarounds for the import using the old-school I_PROCESS ("Process Data"), that is ok to use for a few weeks until we upgrade to 10.2.1. I hope the upgrade then also fixes the ODBC-problem.
Thanks all for your ideas !

User avatar
Michel Zijlema
Site Admin
Posts: 702
Joined: Wed May 14, 2008 5:22 am
OLAP Product: TM1, PALO
Version: both 2.5 and higher
Excel Version: 2003-2007-2010
Location: Netherlands
Contact:

Re: Server hangs on ODBC-import

Post by Michel Zijlema » Thu May 15, 2014 8:46 am

Hi Hans,

Another logger you could try to get some usable debug info is

Code: Select all

log4j.logger.TM1.ODBC=DEBUG
Michel

bgregs
Posts: 38
Joined: Wed Sep 12, 2018 11:19 am
OLAP Product: TM1 / Planning Analytics
Version: 2.0
Excel Version: 2016

Re: Server hangs on ODBC-import

Post by bgregs » Wed Sep 12, 2018 11:58 am

Hi Everyone,

This has by far been the most helpful thread in diagnosing a similar issue I was having with a slugish Oracle 11g import through ODBC. Just thought I'd share my solution in case it helps anyone! After spending days trying everything from TI optimization, to stored procedure calls, and finally different Oracle ODBC driver versions, I finally gave in and called the Oracle support team. Turns out what I thought was a static table was just a complex view that executed LARGE queries (5 years of data between multiple tables) every time it was run. Once this was identified and the data was aggregated into a single table (refreshed daily), everything works in a matter of minutes vs. hours.

Moral of the story, sometimes it's worth picking up the phone.

Thanks everyone for your comments throughout this thread!

Post Reply