TM1Web Websheets - Scroll to bottom not showing all rows

Ideas and tips for enhancing your TM1 application
Post Reply
User avatar
gtonkin
MVP
Posts: 511
Joined: Thu May 06, 2010 3:03 pm
OLAP Product: TM1
Version: PAL 2.0.1
Excel Version: 2016 64-bit
Location: JHB, South Africa
Contact:

TM1Web Websheets - Scroll to bottom not showing all rows

Post by gtonkin » Tue Oct 10, 2017 12:22 pm

Had an issue today with and ActiveForm in a websheet.
Websheet would build about 100 rows or so requiring the user to scroll down on the vertical scroll bar, page down or down arrow to get to off screen detail.

The problem was that scroll to the bottom ended prematurely and by zooming out, you could see the missing content.
Went back to my templates and made sure that they were saved as 100% Zoom (may have other rendering issues if lower than 100% when Save) - did not solve. Added additional 5 rows below my report to increase the report length-no luck.

Did some testing and with the cursor at the bottom of the screen, off the visible area, clicking Recalculate on the toolbar magically showed the content that was previously missing. Curious.

After some more testing I noticed that some of the columns had long data causing wrapping in by so doing "lengthening" then report area.
Clicking the Auto Fit Selected Column Width for each column seemed to widen and shorten the report allowing scrolling to be have as expected.

Amended the template to widen the columns and avoid wrapping, where I am expecting long contents and seems better now.

HTH others who may run into this issue.
Model running on 10.2.2 FP4

Post Reply