11-116375091 - Client 9.4.1 FP1 SubNm Formulas, Alias Error

Post bug reports and the status of reported bugs
Post Reply
User avatar
Alan Kirk
Site Admin
Posts: 5724
Joined: Sun May 11, 2008 2:30 am
OLAP Product: TM1
Version: 9.5.2 64 bit moving to 10.2.2
Excel Version: 2010
Location: Sydney, Australia
Contact:

11-116375091 - Client 9.4.1 FP1 SubNm Formulas, Alias Error

Post by Alan Kirk » Fri May 08, 2009 6:28 am

As posted on Insight this afternoon. (I said that I wouldn't post any more on that until IBM's system came on line, but I believe this to be connected to an existing one.)

I believe that this is related to the changes made in SubNm formulas in 9.4.1FP1 (NB: That release does not appear in the Build drop down;it's 9.4.10100.55168. I've chosen the closest one.) See also request 11-115841041, which may be related.

If you select an element with an alias via SubNm, the 4th argument of the SubNm formula will be populated with the alias name.

In earlier versions, when you double click on the cell and launch the subset editor then the editor will display the elements with that alias displayed. In 9.4.1 FP1, the alias will NOT be displayed, and all of the elements will show their base names. You need to reselect the alias name to have the SubNm display it.

I can't confirm that this came in with FP1, though I can confirm that 9.1.4 displayes the aliases correctly.
"To them, equipment failure is terrifying. To me, it’s 'Tuesday.' "
-----------
Before posting, please check the documentation, the FAQ, the Search function and FOR THE LOVE OF GLUB the Request Guidelines.

Post Reply