Page 1 of 1

84020999616 TM1 Web 9.1.4 Websheets Don't Honour Line Breaks

Posted: Fri Aug 28, 2009 12:31 am
by Alan Kirk
As submitted. The attempts at adding a line break via the Char() function weren't expected to work, but had to be tried...

How is this problem impacting your business?
Unable to create presentation websheets without breaking content into separate cells. This in turn creates an unnecessary amount of formatting work.

Problem Description
In Excel you can insert a line break in a cell (stored in the cell as a Char(10) character) by pressing [Alt]+[Enter] while in cell edit mode.

If a workbook is stored as an application, the line break will be visible when you open the application in Excel. See the attached file ApplicationSheet.jpg.
ApplicationSheet.jpg
ApplicationSheet.jpg (55.66 KiB) Viewed 1862 times
In a Websheet, the line break is ignored. See the attached file websheet.jpg.
Websheet2.jpg
Websheet2.jpg (74.29 KiB) Viewed 1862 times
We have found this behaviour in 9.1.4, but others have reported it in 9.4 as well. (http://forums.olapforums.com/viewtopic.php?f=3&t=1430)

Could this please be corrected.

Thank you.

Re: 84020999616 TM1 Web 9.1.4 Websheets Don't Honour Line Breaks

Posted: Fri Aug 28, 2009 4:37 am
by Alan Kirk
Response from IBM Support:
I found the issue you've reported for carriage returns in Excel was reported as a defect in tm1_9.4 tm1 mr1.

I can see that the defect is targeted to be fix in 9.5 which is expected to be out in 3rd quarter of 2009.