Search found 463 matches

by gtonkin
Mon Aug 21, 2017 5:42 am
Forum: Cognos TM1
Topic: Trouble setting up integrated login in TM1 10.2
Replies: 14
Views: 675

Re: Trouble setting up integrated login in TM1 10.2

HI Kaz, I have not been down the road of Method 2-Integrated Login using the DevWorks method (I like what little sanity I have) I would however make sure that Method 1 is configured and works. From the error logs, what comes to mind is SSL certificate updates i.e. the ones replaced last year-did you...
by gtonkin
Fri Aug 18, 2017 8:38 am
Forum: Cognos TM1
Topic: Trouble setting up integrated login in TM1 10.2
Replies: 14
Views: 675

Re: Trouble setting up integrated login in TM1 10.2

I think you are going to require lots of patience if you head down this road. There are two options AFAIK: 1) Single Signon 2) Integrated login The two are not synonymous - Single Signon allows you to authenticate with your windows credentials i.e. type in your userid and password. Integrated Login ...
by gtonkin
Thu Aug 17, 2017 1:03 pm
Forum: General
Topic: Upcoming server migration
Replies: 14
Views: 1156

Re: Upcoming server migration

HI Martin- saw this link Re: having email notification contain post body? Not sure if you have all the details on what to change but thought I would post in case you don't have them to hand.
by gtonkin
Thu Aug 17, 2017 8:48 am
Forum: Cognos TM1
Topic: Trouble setting up integrated login in TM1 10.2
Replies: 14
Views: 675

Re: Trouble setting up integrated login in TM1 10.2

...And, do you know the preferred format of user & domain name for setting SPN for tm1s? I say that because I have different formats;... Hard to say for sure but I generally use the domain returned from a plain whoami without any parameters. ...Means, I need to import them into TM1 using ETLDDAP? I...
by gtonkin
Thu Aug 17, 2017 7:27 am
Forum: Cognos TM1
Topic: Trouble setting up integrated login in TM1 10.2
Replies: 14
Views: 675

Re: Trouble setting up integrated login in TM1 10.2

...In the last part of your post, you said that clients should be set up aligned to the domain account. Did you mean creating users in AD? Where will the clients be created? Sorry lost you there... Users should already be configured in AD - you should be creating them in TM1 with the same user name...
by gtonkin
Thu Aug 17, 2017 6:44 am
Forum: Cognos TM1
Topic: Error during modify existing TI Data Source
Replies: 1
Views: 145

Re: Error during modify existing TI Data Source

May be worthwhile checking that you are connecting to the 64-bit Oracle/ODBC drivers-assuming you are running 64-bit TM1.
by gtonkin
Thu Aug 17, 2017 6:41 am
Forum: Cognos TM1
Topic: Trouble setting up integrated login in TM1 10.2
Replies: 14
Views: 675

Re: Trouble setting up integrated login in TM1 10.2

HI Kaz, Try running the whoami command from the command prompt. This should return your username in the format <domain>\<user> e.g. acme\george I then have a rule to derive UniqueID by joining Client to the domain to keep things simple: SKIPCHECK; [UniqueID]=S:!}Clients|'@acme'; FEEDERS; The above w...
by gtonkin
Wed Aug 16, 2017 7:02 am
Forum: Cognos TM1
Topic: Feeder for rule used in DB Function
Replies: 12
Views: 538

Re: Feeder for rule used in DB Function

... And one thing to be noted here is target has an additional dimension called country .but I assume that is like a constant and doesnt matter . I think your assumption would be wrong-you need to make sure you specify the complete address (set of coordinates) to feed the target-Your feeder does no...
by gtonkin
Sat Aug 12, 2017 5:26 pm
Forum: Useful code, tips and tricks
Topic: TM1Web Websheet Charts / Graphs not rendering
Replies: 4
Views: 279

Re: TM1Web Websheet Charts / Graphs not rendering

Thanks Declan, I generally do the same with the white font rather than change the chart options to allow data in hidden ranges.
Just not getting the expected results on my side.
by gtonkin
Fri Aug 11, 2017 1:25 pm
Forum: Useful code, tips and tricks
Topic: TM1Web Websheet Charts / Graphs not rendering
Replies: 4
Views: 279

Re: TM1Web Websheet Charts / Graphs not rendering

I am seeing this behaviour on 10.2.2 FP4 and PA 2.0.1. In terms of leaving some visible but blank rows - I experiment with 5, 10, 20, 100 - seems to behave the same. @Declan - would appreciate if you have 5 mins to create a basic chart like the one below-basically typed in some random numbers, highl...
by gtonkin
Thu Aug 10, 2017 6:14 pm
Forum: Cognos TM1
Topic: Cube Size
Replies: 11
Views: 562

Re: Cube Size

... I was trying something like this: ['Price'] => DB (IF(['Price'] > 0 , DB('Destination Cube', !Dim1, !Dim2, !Dim3, 'Price'),0); Do you expect negative prices? Guessing not, so only cells with prices would trigger the feeder anyway, you do not need to check for non-zero. TM1 by default limits non...
by gtonkin
Tue Aug 08, 2017 3:07 pm
Forum: Useful code, tips and tricks
Topic: TM1Web Websheet Charts / Graphs not rendering
Replies: 4
Views: 279

TM1Web Websheet Charts / Graphs not rendering

Posting to save others time should they encounter a similar issue. Had an issue where I had created a basic websheet with a line chart plotting Actual vs Budget. All very basic DBRWs, to get data. Cleaned up formatting and published. Opened on TM1Web and chart showed up as a placeholder indicating a...
by gtonkin
Tue Aug 08, 2017 6:54 am
Forum: Cognos TM1
Topic: TM1 Web View value is different Architect View
Replies: 2
Views: 161

Re: TM1 Web View value is different Architect View

From the screenshots, the dimensions and elements look the same, however, you will notice that cube view has white cells i.e. open for input and the cube view has greyed cells-are you sure that you are looking at the same cube and all intersections. The only other thing I can suggest is to break bot...
by gtonkin
Mon Aug 07, 2017 4:26 am
Forum: Cognos TM1
Topic: Store values VS. Accumulate values
Replies: 10
Views: 497

Re: Store values VS. Accumulate values

Hi sunlight, Accumulating is basically getting the value in the cube then adding to that the value in the incoming record. The result is then written back to the relevant cell (based on the data in the record e.g. Version, month, product etc.) in the cube. Store is simply taking the value from the i...
by gtonkin
Fri Aug 04, 2017 3:41 pm
Forum: Cognos TM1
Topic: Tracking User Logins
Replies: 17
Views: 1443

Re: Tracking User Logins

I tried the way using the log4j logger.... log4j.logger.TM1.Login = DEBUG, LOGIN log4j.appender.LOGIN = org.apache.log4j.SharedMemoryAppender log4j.appender.LOGIN.MemorySize = 1MB log4j.appender.LOGIN.File = C:\TM1MODELS\Metadatenmgmt\tm1login.log ... Have you tried just using tm1login.log for the ...
by gtonkin
Thu Aug 03, 2017 6:02 pm
Forum: Cognos TM1
Topic: Finding out which Views a Subset belongs to?
Replies: 19
Views: 546

Re: Finding out which Views a Subset belongs to?

Works for me if and only if the dimension and subset names contain no spaces. Once the names contain spaces FINDSTR treats the space as an OR operator within the context of the regex regardless whether the /L argument is given. So end up with more false positives then ever since most subsets and mo...
by gtonkin
Thu Aug 03, 2017 3:40 pm
Forum: Cognos TM1
Topic: Tracking User Logins
Replies: 17
Views: 1443

Re: Tracking User Logins

st2000 wrote:
Thu Aug 03, 2017 3:32 pm
...The tm1slog.properties resides now in the same folder like the tm1s.cfg which is noticed as a requirement in the tm1_op manual...
Just checking if this is a typo - is your file called tm1s-log.properties There must be a hyphen between tm1s and log.
by gtonkin
Thu Aug 03, 2017 9:38 am
Forum: Cognos TM1
Topic: Create a cube with a separate administrator
Replies: 11
Views: 313

Re: Create a cube with a separate administrator

...if the business is willing to pay for the admin license then create the new model... Not sure if your terminology for Administrator means the same thing as TM1's licensing. If the HR person is only going to be administering data, running processes etc. and not changing rules, developing TI etc. ...
by gtonkin
Thu Aug 03, 2017 7:55 am
Forum: Cognos TM1
Topic: Create a cube with a separate administrator
Replies: 11
Views: 313

Re: Create a cube with a separate administrator

A good (albeit a little old-school) option for that sort of single-user payroll cube is the Local Server you can run from Architect/Perspectives ('Start Local Server'). The Modeller licence (which that person needs anyway) covers that type of usage already if memory serves me well. I am stretching ...
by gtonkin
Wed Aug 02, 2017 7:10 pm
Forum: Cognos TM1
Topic: Finding out which Views a Subset belongs to?
Replies: 19
Views: 546

Re: Finding out which Views a Subset belongs to?

Hope you don't mind Wim, but copied your work to the following batch file (staying old school command prompt) - worked OOTB for me! Only minor gotcha may be that you will get matched where susbset being searched for is part of a longer named one I.e. Contained in. Will test by adding the CRLF after ...