Search found 75 matches

by Analytics123
Thu Nov 02, 2017 12:27 pm
Forum: Cognos TM1
Topic: static subsets saved disappears
Replies: 6
Views: 260

Re: static subsets saved disappears

dim update customers first unwinding code : DIMENSIONSORTORDER(vDim,'','','ByHierarchy','ASCENDING'); vMax = DIMSIZ(vDim); vCount = 1; WHILE (vCount <= vMax); vElem = DIMNM(vDim, vCount); vMaxParents = ELPARN(vDim, vElem); WHILE (vMaxParents>0); vParent = ELPAR(vDim, vElem, vMaxParents); DimensionEl...
by Analytics123
Thu Nov 02, 2017 12:25 pm
Forum: Cognos TM1
Topic: static subsets saved disappears
Replies: 6
Views: 260

Re: static subsets saved disappears

yes elements with in subsets are disappearing . we are not deleting the element any where .
by Analytics123
Wed Nov 01, 2017 5:27 pm
Forum: Cognos TM1
Topic: static subsets saved disappears
Replies: 6
Views: 260

static subsets saved disappears

Hi , We have static subsets disappearing in few dimension . we are not deleting any elements , while the dimension is updated we just unwind the dimension elements and re add the elements. Also I could see the subset data in the data folder but opening up the editor showing blank for subsets. Is thi...
by Analytics123
Wed Nov 01, 2017 12:38 pm
Forum: Cognos TM1
Topic: TM1 process in chore starts with 2 min delay
Replies: 2
Views: 97

TM1 process in chore starts with 2 min delay

Hi ,

we are in 10.1.1 and our process defined in chore starts 2 mins later than the scheduled time . IS there a setting that is controlled or a bug . It happens only recently .

Thanks
by Analytics123
Tue Oct 31, 2017 3:31 pm
Forum: Cognos TM1
Topic: Unwinding specific elements in GLobal Customer diension
Replies: 1
Views: 97

Unwinding specific elements in GLobal Customer diension

Hi , I have a customer dimension with customers from US, Germany and Asia . The Us customers might swap over the hierachy and other two customers are loaded in run time . In the first process I am unwinding all the elements and adding only us elements and Germany and Asia parent nodes . All -Custome...
by Analytics123
Fri Oct 20, 2017 8:45 pm
Forum: Cognos TM1
Topic: Adding a subset to a dbrw
Replies: 7
Views: 363

Re: Adding a subset to a dbrw

Yeah i have done it , but not sure it will cause performance issues .
by Analytics123
Fri Oct 20, 2017 7:22 pm
Forum: Cognos TM1
Topic: Count the number of Accounts for each agency
Replies: 2
Views: 296

Count the number of Accounts for each agency

Hi ,

I have a hierrachy like Region, Agency,Subregion, Rep and accounts .

The user wants the count of number of accounts under each agency .

Is there a TI function I can use which will take the agency as input and give me the count of accounts under that agency .


Thanks,
by Analytics123
Thu Oct 19, 2017 5:02 pm
Forum: Cognos TM1
Topic: Adding a subset to a dbrw
Replies: 7
Views: 363

Adding a subset to a dbrw

I have a subset that refreshes nightly .

Is there a way i can refer that subset in a dbrw to retrieve cube value .

Thanks,
by Analytics123
Wed Oct 18, 2017 3:22 pm
Forum: Cognos TM1
Topic: MDX expession
Replies: 3
Views: 221

MDX expession

I have the below mdx to select the 3 items in level 3 {TM1FILTERBYLEVEL({TM1DRILLDOWNMEMBER({[Items].[All Teams].[50].[50 - 5].[50 - 5 - 406],[Items].[All Teams].[50].[50 - 5].[50 - 5 - 407],[Items].[All Teams].[50].[50 - 5].[50 - 5 - 409]}, ALL, RECURSIVE )}, 3)} now i need modify the mdx to choose...
by Analytics123
Thu Oct 12, 2017 12:27 pm
Forum: Cognos TM1
Topic: replace a subset value in db function
Replies: 4
Views: 199

replace a subset value in db function

Hi, I have to replace a subset value in place of hard coded month in the below DB expression ['Average DSO'] =DB('AR History', !Customers SoldTo Only, 'US01', 'Jul 2017' , 'All Currencies', 'Local Currency', 'ASSETS', 'All Customer Types', '6 month DSO'); I have a subset name called Months - Prior M...
by Analytics123
Mon Oct 09, 2017 3:03 pm
Forum: Cognos TM1
Topic: replace an element in mdx with a variable
Replies: 1
Views: 93

replace an element in mdx with a variable

Hi, I have this mdx . { ORDER( {TM1FILTERBYLEVEL( {TM1DRILLDOWNMEMBER({[Months].[FY2017]}, ALL, RECURSIVE )},0)} , [testcube].([Sales Measures].[Full Revenue],[testcty].[usa]), BASC) } here instead of [testcty].[USA], I have to replace a user variable vcountry from my variable tab in a ti process. C...
by Analytics123
Thu Oct 05, 2017 6:11 pm
Forum: Cognos TM1
Topic: Median in tm1 using mdx sort
Replies: 4
Views: 160

Re: Median in tm1 using mdx sort

yeah , i was asking in the below scenario it returns me the sorted months by sales, is there was a way I could directly get the sales value directly ,

without using cellgetn

Thanks,
by Analytics123
Thu Oct 05, 2017 1:43 pm
Forum: Cognos TM1
Topic: Median in tm1 using mdx sort
Replies: 4
Views: 160

Re: Median in tm1 using mdx sort

Okay I got this working to sort my months based on a customer sale . { ORDER( {TM1FILTERBYLEVEL( {TM1DRILLDOWNMEMBER({[Months].[FY2017]}, ALL, RECURSIVE )},0)} , [testcube].([Sales Measures].[Full Revenue],[testcty].[usa]), BASC) } This returns me months in ascending order with sales value for USA ....
by Analytics123
Thu Oct 05, 2017 12:47 pm
Forum: Cognos TM1
Topic: Median in tm1 using mdx sort
Replies: 4
Views: 160

Median in tm1 using mdx sort

Hi , I need to find a median for customers in a 12 month period sales . I know we dont have a formula in tm1 for median . so for work around , I have the cube with customers, 12 month sales data. I am planning to write a ti process on the customer subset . Take each customer and write a mdx which ta...
by Analytics123
Tue Oct 03, 2017 2:17 pm
Forum: Cognos TM1
Topic: Average and Average ifs excel function in tm1
Replies: 4
Views: 224

Re: Average and Average ifs excel function in tm1

okay ima trying to replicate average if not equal to zero in tm1 rule .

May be i wil do it for 2 months first .

I dont think so its straightForward .It will have multiple ifs for 2 months only .
by Analytics123
Fri Sep 29, 2017 3:43 pm
Forum: Cognos TM1
Topic: Average and Average ifs excel function in tm1
Replies: 4
Views: 224

Re: Average and Average ifs excel function in tm1

I just want to know if there is an equivalent formula in tm1 to write the rule for the below calculation 1 and calculation 2 .
If so can you please let me know how to write that calculation.
by Analytics123
Fri Sep 29, 2017 2:50 pm
Forum: Cognos TM1
Topic: Average and Average ifs excel function in tm1
Replies: 4
Views: 224

Average and Average ifs excel function in tm1

Hi , I am planning to build a credit scoring model in tm1 based on last 24 month sales of customer . Ideally this should have been done in excel after exporting the data in tm1.But however i wanted to try if the calculations are able to performed in tm1 . Calculation 1 : I will have 24 months of sal...
by Analytics123
Sat Sep 16, 2017 7:38 pm
Forum: Cognos TM1
Topic: carryforward ending balance to beginning balance
Replies: 1
Views: 183

carryforward ending balance to beginning balance

Hi, I am planning to write a ti process to carry forward ending balance to beginning balance of next month via ti. I have my data starting july 2015 in my cube , i should now start carry forward july ending balnce as august beginning balance . For this I will create a ti with datasource as a view wi...
by Analytics123
Thu Sep 07, 2017 8:25 pm
Forum: Cognos TM1
Topic: Tm1 public subsets gets cleared
Replies: 5
Views: 334

Re: Tm1 public subsets gets cleared

Okay I am using the below code to remove my levels from hierarchy in my dimension,This is the only one I can think of where the dimension element is touched again. This will remove the element from its parent and put seperatley. vMax = DIMSIZ(vDim); vCount = 1; WHILE (vCount <= vMax); vElem = DIMNM(...
by Analytics123
Fri Sep 01, 2017 3:29 pm
Forum: Cognos TM1
Topic: Tm1 public subsets gets cleared
Replies: 5
Views: 334

Tm1 public subsets gets cleared

Hi we have an issue at times were the public subsets created on dimension gets cleared randomly.
Can yuo guys tell me where should i start trouble shooting this .

Some times it happens after server restart , sometimes it happens randomly when server is running.

Thanks,